Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#29503 - [nvidia] X freezes often, mouse very slow, no keyboard!

Attached to Project: Arch Linux
Opened by Chris (realdarkman) - Tuesday, 17 April 2012, 13:27 GMT
Last edited by Andrea Scarpino (BaSh) - Tuesday, 07 August 2012, 09:41 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To No-one
Architecture i686
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 6
Private No

Details

Description: X freezes often, mouse very slow, no keyboard, cold boot required!

Additional info:
Current packages: kernel 3.3.2-1-ARCH, Xorg 1.12.1-1, gnome 3.2.1-1, nvidia 295.40-1

AMD Phenom II X4 975, 4GB Ram, GeForce 8800GTS 512

/var/log/Xorg.0.log:
[ 5797.032] [mi] EQ overflowing. Additional events will be discarded until existing events are processed.
[ 5797.032]
[ 5797.032] Backtrace:
[ 5797.049] 0: /usr/bin/Xorg (xorg_backtrace+0x49) [0x81b6bb9]
[ 5797.050] 1: /usr/bin/Xorg (mieqEnqueue+0x223) [0x8195503]
[ 5797.050] 2: /usr/bin/Xorg (0x8048000+0x43df5) [0x808bdf5]
[ 5797.050] 3: /usr/bin/Xorg (xf86PostMotionEventM+0xf9) [0x80c5699]
[ 5797.050] 4: /usr/lib/xorg/modules/input/evdev_drv.so (0xb4460000+0x33dd) [0xb44633dd]
[ 5797.050] 5: /usr/lib/xorg/modules/input/evdev_drv.so (0xb4460000+0x481c) [0xb446481c]
[ 5797.050] 6: /usr/bin/Xorg (0x8048000+0x6cfd1) [0x80b4fd1]
[ 5797.050] 7: /usr/bin/Xorg (0x8048000+0x92a05) [0x80daa05]
[ 5797.050] 8: (vdso) (__kernel_sigreturn+0x0) [0xb77bd400]
[ 5797.050] 9: /usr/lib/xorg/modules/drivers/nvidia_drv.so (0xb4a61000+0x61f06) [0xb4ac2f06]
[ 5797.050]
[ 5797.050] [mi] These backtraces from mieqEnqueue may point to a culprit higher up the stack.
[ 5797.050] [mi] mieq is *NOT* the cause. It is a victim.
This task depends upon

Closed by  Andrea Scarpino (BaSh)
Tuesday, 07 August 2012, 09:41 GMT
Reason for closing:  Upstream
Additional comments about closing:  We cannot fix binaries
Comment by Ionut Biru (wonder) - Tuesday, 17 April 2012, 13:28 GMT
bug in nvidia 295.40. nvidia admit it that they screwed badly this version.
please downgrade to 295.33
Comment by Daniel Wallace (gtmanfred) - Tuesday, 17 April 2012, 13:32 GMT
I had the same issue with nvidia 295.40-2

downgrading to nvidia 295.33-1 worked for me
Comment by Chris (realdarkman) - Tuesday, 17 April 2012, 13:44 GMT
Ok, thanks! ...but cannot downgrade, pacman says: nvidia-295.33-1 needs kernel<3.3
Comment by Daniel Wallace (gtmanfred) - Wednesday, 18 April 2012, 01:06 GMT
use nvidia-295.33-2 then
Comment by Chris (realdarkman) - Wednesday, 18 April 2012, 17:42 GMT
Done, thanks! Hope, that helps!
Comment by Stefano Franchi (cleinias) - Friday, 20 April 2012, 00:31 GMT
I have the same problem as D Wallace and pacman -U refuses to downgrade nvidia 295.40 to 295.33.2 because it cannot resolve a dependency:

nvidia: requires nvidia-utils=295.33

even though I still have nvidia-utils-295.33.1 in the package cache. Which options do I have?

Stefano
Comment by Daniel Wallace (gtmanfred) - Friday, 20 April 2012, 00:36 GMT
downgrade both packages at the same time using pacman -U
Comment by Stefano Franchi (cleinias) - Friday, 20 April 2012, 00:57 GMT
Thanks, that worked. I'd never have guessed it'd be so simple.
Comment by Chris (realdarkman) - Sunday, 22 April 2012, 21:55 GMT
Same freeze again with nvidia 295.33-2, but another log output:

[ 38400.020] (II) NVIDIA(0): Setting mode "nvidia-auto-select"
[ 38400.487] (II) NVIDIA(0): ACPI: failed to connect to the ACPI event daemon; the daemon
[ 38400.487] (II) NVIDIA(0): may not be running or the "AcpidSocketPath" X
[ 38400.487] (II) NVIDIA(0): configuration option may not be set correctly. When the
[ 38400.487] (II) NVIDIA(0): ACPI event daemon is available, the NVIDIA X driver will
[ 38400.487] (II) NVIDIA(0): try to use it to receive ACPI event notifications. For
[ 38400.487] (II) NVIDIA(0): details, please see the "ConnectToAcpid" and
[ 38400.487] (II) NVIDIA(0): "AcpidSocketPath" X configuration options in Appendix B: X
[ 38400.487] (II) NVIDIA(0): Config Options in the README.
[ 39803.224] [mi] EQ overflowing. Additional events will be discarded until existing events are processed.
[ 39803.225]
[ 39803.225] Backtrace:
[ 39803.270] 0: /usr/bin/Xorg (xorg_backtrace+0x49) [0x81b6bb9]
[ 39803.270] 1: /usr/bin/Xorg (mieqEnqueue+0x223) [0x8195503]
[ 39803.270] 2: /usr/bin/Xorg (0x8048000+0x43df5) [0x808bdf5]
[ 39803.271] 3: /usr/bin/Xorg (xf86PostMotionEventM+0xf9) [0x80c5699]
[ 39803.271] 4: /usr/lib/xorg/modules/input/evdev_drv.so (0xb4382000+0x33dd) [0xb43853dd]
[ 39803.271] 5: /usr/lib/xorg/modules/input/evdev_drv.so (0xb4382000+0x481c) [0xb438681c]
[ 39803.271] 6: /usr/bin/Xorg (0x8048000+0x6cfd1) [0x80b4fd1]
[ 39803.271] 7: /usr/bin/Xorg (0x8048000+0x92a05) [0x80daa05]
[ 39803.271] 8: (vdso) (__kernel_sigretu

EDIT:
[ 22039.537] [mi] EQ overflowing. Additional events will be discarded until existing events are processed.
[ 22039.555]
[ 22039.555] Backtrace:
[ 22039.635] 0: /usr/bin/Xorg (xorg_backtrace+0x49) [0x81b6bb9]
[ 22039.635] 1: /usr/bin/Xorg (mieqEnqueue+0x223) [0x8195503]
[ 22039.635] 2: /usr/bin/Xorg (0x8048000+0x43df5) [0x808bdf5]
[ 22039.635] 3: /usr/bin/Xorg (xf86PostMotionEventM+0xf9) [0x80c5699]
[ 22039.635] 4: /usr/lib/xorg/modules/input/evdev_drv.so (0xb440b000+0x33dd) [0xb440e3dd]
[ 22039.635] 5: /usr/lib/xorg/modules/input/evdev_drv.so (0xb440b000+0x481c) [0xb440f81c]
[ 22039.635] 6: /usr/bin/Xorg (0x8048000+0x6cfd1) [0x80b4fd1]
[ 22039.635] 7: /usr/bin/Xorg (0x8048000+0x92a05) [0x80daa05]
[ 22039.635] 8: (vdso) (__kernel_sigreturn+0x0) [0xb776b400]
[ 22039.635] 9: /usr/lib/xorg/modules/drivers/nvidia_drv.so (0xb4a13000+0x61ec2) [0xb4a74ec2]
[ 22039.635]
[ 22039.635] [mi] These backtraces from mieqEnqueue may point to a culprit higher up the stack.
[ 22039.635] [mi] mieq is *NOT* the cause. It is a victim.
Comment by Stefano Franchi (cleinias) - Monday, 23 April 2012, 21:04 GMT
Same here---X still freezes up after downgrade to nvidia 295.33-2.
Log:
[331080.346] [mi] EQ overflow continuing. 1000 events have been dropped.
[331080.346] [mi] No further overflow reports will be reported until the clog is cleared.
[331080.346] Backtrace:
[331080.346] 0: /usr/bin/X (xorg_backtrace+0x36) [0x55f646]
[331080.346] 1: /usr/bin/X (0x400000+0x47f62) [0x447f62]
[331080.346] 2: /usr/lib/xorg/modules/input/evdev_drv.so (0x7f8f7ad37000+0x5478) [0x7f8f7ad3c478]
[331080.346] 3: /usr/bin/X (0x400000+0x6eab7) [0x46eab7]
[331080.347] 4: /usr/bin/X (0x400000+0x92d40) [0x492d40]
[331080.347] 5: /lib/libpthread.so.0 (0x7f8f82a0e000+0xf140) [0x7f8f82a1d140]
[331080.347] 6: /usr/lib/xorg/modules/drivers/nvidia_drv.so (0x7f8f7c68c000+0x8e322) [0x7f8f7c71a322]
[331080.347] 7: /usr/lib/xorg/modules/drivers/nvidia_drv.so (0x7f8f7c68c000+0x8fe8d) [0x7f8f7c71be8d]
[331080.347] 8: /usr/lib/xorg/modules/drivers/nvidia_drv.so (0x7f8f7c68c000+0x1011fe) [0x7f8f7c78d1fe]
[331080.347] 9: /usr/lib/xorg/modules/drivers/nvidia_drv.so (0x7f8f7c68c000+0x533aac) [0x7f8f7cbbfaac]
[331080.347] 10: /usr/lib/xorg/modules/drivers/nvidia_drv.so (0x7f8f7c68c000+0x533c9f) [0x7f8f7cbbfc9f]
[331080.347] 11: /usr/lib/xorg/modules/drivers/nvidia_drv.so (0x7f8f7c68c000+0x522dea) [0x7f8f7cbaedea]
[331080.347] 12: /usr/bin/X (0x400000+0xf1c39) [0x4f1c39]
[331080.347] 13: /usr/bin/X (0x400000+0xeaba4) [0x4eaba4]
[331080.347] 14: /usr/bin/X (0x400000+0x34472) [0x434472]
[331080.347] 15: /usr/bin/X (0x400000+0x23535) [0x423535]
[331080.347] 16: /lib/libc.so.6 (__libc_start_main+0xf5) [0x7f8f818c3455]
[331080.347] 17: /usr/bin/X (0x400000+0x2380d) [0x42380d]
Comment by Chris (realdarkman) - Monday, 23 April 2012, 21:46 GMT
Just now, freezed again:

[ 1088.182] (II) NVIDIA(0): Setting mode "nvidia-auto-select"
[ 1088.216] (II) NVIDIA(0): ACPI: failed to connect to the ACPI event daemon; the daemon
[ 1088.216] (II) NVIDIA(0): may not be running or the "AcpidSocketPath" X
[ 1088.216] (II) NVIDIA(0): configuration option may not be set correctly. When the
[ 1088.216] (II) NVIDIA(0): ACPI event daemon is available, the NVIDIA X driver will
[ 1088.216] (II) NVIDIA(0): try to use it to receive ACPI event notifications. For
[ 1088.216] (II) NVIDIA(0): details, please see the "ConnectToAcpid" and
[ 1088.216] (II) NVIDIA(0): "AcpidSocketPath" X configuration options in Appendix B: X
[ 1088.216] (II) NVIDIA(0): Config Options in the README.
[ 2105.524] (II) NVIDIA(0): Setting mode "nvidia-auto-select"
[ 2105.559] (II) NVIDIA(0): ACPI: failed to connect to the ACPI event daemon; the daemon
[ 2105.559] (II) NVIDIA(0): may not be running or the "AcpidSocketPath" X
[ 2105.559] (II) NVIDIA(0): configuration option may not be set correctly. When the
[ 2105.559] (II) NVIDIA(0): ACPI event daemon is available, the NVIDIA X driver will
[ 2105.559] (II) NVIDIA(0): try to use it to receive ACPI event notifications. For
[ 2105.559] (II) NVIDIA(0): details, please see the "ConnectToAcpid" and
[ 2105.559] (II) NVIDIA(0): "AcpidSocketPath" X configuration options in Appendix B: X
[ 2105.559] (II) NVIDIA(0): Config Options in the README.
[ 5544.274] (WW) NVIDIA(0): WAIT (0, 7, 0x8000, 0x00008368, 0x00008368)
[ 5547.275] (WW) NVIDIA(0): WAIT (0, 7, 0x8000, 0x0000839c, 0x0000839c)
[ 5550.276] (WW) NVIDIA(0): WAIT (0, 7, 0x8000, 0x000083d0, 0x000083d0)
[ 5553.277] (WW) NVIDIA(0): WAIT (0, 7, 0x8000, 0x00008404, 0x00008404)
[ 5556.278] (WW) NVIDIA(0): WAIT (0, 7, 0x8000, 0x00008438, 0x00008438)
[ 5559.279] (WW) NVIDIA(0): WAIT (0, 7, 0x8000, 0x0000846c, 0x0000846c)
[ 5562.280] (WW) NVIDIA(0): WAIT (0, 7, 0x8000, 0x000084a0, 0x000084a0)
[ 5565.281] (WW) NVIDIA(0): WAIT (0, 7, 0x8000, 0x000084d4, 0x000084d4)
[ 5568.282] (WW) NVIDIA(0): WAIT (0, 7, 0x8000, 0x00008508, 0x00008508)
[ 5571.283] (WW) NVIDIA(0): WAIT (0, 7, 0x8000, 0x0000853c, 0x0000853c)
[ 5574.284] (WW) NVIDIA(0): WAIT (0, 7, 0x8000, 0x00008570, 0x00008570)
[ 5577.285] (WW) NVIDIA(0): WAIT (0, 7, 0x8000, 0x000085a4, 0x000085a4)
[ 5580.286] (WW) NVIDIA(0): WAIT (0, 7, 0x8000, 0x000085d8, 0x000085d8)
[ 5583.287] (WW) NVIDIA(0): WAIT (0, 7, 0x8000, 0x0000860c, 0x0000860c)
[ 5586.288] (WW) NVIDIA(0): WAIT (0, 7, 0x8000, 0x00008640, 0x00008640)
[ 5589.289] (WW) NVIDIA(0): WAIT (0, 7, 0x8000, 0x00008674, 0x00008674)
[ 5592.290] (WW) NVIDIA(0): WAIT (0, 7, 0x8000, 0x000086a8, 0x000086a8)
[ 5595.291] (WW) NVIDIA(0): WAIT (0, 7, 0x8000, 0x000086dc, 0x000086dc)
[ 5598.292] (WW) NVIDIA(0): WAIT (0, 7, 0x8000, 0x00008710, 0x00008710)
[ 5601.293] (WW) NVIDIA(0): WAIT (0, 7, 0x8000, 0x00008744, 0x00008744)
[ 5604.294] (WW) NVIDIA(0): WAIT (0, 7, 0x8000, 0x00008778, 0x00008778)
[ 5607.295] (WW) NVIDIA(0): WAIT (0, 7, 0x8000, 0x000087ac, 0x000087ac)
[ 5610.296] (WW) NVIDIA(0): WAIT (0, 7, 0x8000, 0x000087e0, 0x000087e0)
[ 5613.297] (WW) NVIDIA(0): WAIT (0, 7, 0x8000, 0x00008814, 0x00008814)
[ 5616.298] (WW) NVIDIA(0): WAIT (0, 7, 0x8000, 0x00008848, 0x00008848)
[ 5619.299] (WW) NVIDIA(0): WAIT (0, 7, 0x8000, 0x0000887c, 0x0000887c)
[ 5622.300] (WW) NVIDIA(0): WAIT (0, 7, 0x8000, 0x000088b0, 0x000088b0)
[ 5625.301] (WW) NVIDIA(0): WAIT (0, 7, 0x8000, 0x000088e4, 0x000088e4)
[ 5628.302] (WW) NVIDIA(0): WAIT (0, 7, 0x8000, 0x00008918, 0x00008918)
[ 5631.303] (WW) NVIDIA(0): WAIT (0, 7, 0x8000, 0x0000894c, 0x0000894c)
[ 5634.304] (WW) NVIDIA(0): WAIT (0, 7, 0x8000, 0x00008980, 0x00008980)
[ 5637.305] (WW) NVIDIA(0): WAIT (0, 7, 0x8000, 0x000089b4, 0x000089b4)
[ 5640.306] (WW) NVIDIA(0): WAIT (0, 7, 0x8000, 0x000089e8, 0x000089e8)
[ 5643.307] (WW) NVIDIA(0): WAIT (0, 7, 0x8000, 0x00008a1c, 0x00008a1c)
[ 5646.308] (WW) NVIDIA(0): WAIT (0, 7, 0x8000, 0x00008a50, 0x00008a50)
[ 5649.309] (WW) NVIDIA(0): WAIT (0, 7, 0x8000, 0x00008a84, 0x00008a84)
[ 5652.310] (WW) NVIDIA(0): WAIT (0, 7, 0x8000, 0x00008ab8, 0x00008ab8)
[ 5655.311] (WW) NVIDIA(0): WAIT (0, 7, 0x8000, 0x00008aec, 0x00008aec)
[ 5658.312] (WW) NVIDIA(0): WAIT (0, 7, 0x8000, 0x00008b20, 0x00008b20)
[ 5661.313] (WW) NVIDIA(0): WAIT (0, 7, 0x8000, 0x00008b54, 0x00008b54)
[ 5664.314] (WW) NVIDIA(0): WAIT (0, 7, 0x8000, 0x00008b88, 0x00008b88)
[ 5667.315] (WW) NVIDIA(0): WAIT (0, 7, 0x8000, 0x00008bbc, 0x00008bbc)
[ 5670.316] (WW) NVIDIA(0): WAIT (0, 7, 0x8000, 0x00008bf0, 0x00008bf0)
[ 5673.317] (WW) NVIDIA(0): WAIT (0, 7, 0x8000, 0x00008c24, 0x00008c24)
[ 5676.318] (WW) NVIDIA(0): WAIT (0, 7, 0x8000, 0x00008c58, 0x00008c58)

Always cold reboot needed! No keyboard, no mouse, no response!
Comment by Stefano Franchi (cleinias) - Wednesday, 25 April 2012, 17:03 GMT
Happened again, similar log. I am averaging one complete freeze a day now.
Comment by Stefano Franchi (cleinias) - Wednesday, 25 April 2012, 17:06 GMT
I meant my log is similar to the previous ones I posted, not to Chris's last one (which looks a bit different to my ignorant eyes). For the sake of completeness, here is my log's tail:

[157466.971] Backtrace:
[157466.971] 0: /usr/bin/X (xorg_backtrace+0x36) [0x55f646]
[157466.971] 1: /usr/bin/X (0x400000+0x47f62) [0x447f62]
[157466.971] 2: /usr/lib/xorg/modules/input/evdev_drv.so (0x7f41e0866000+0x5478) [0x7f41e086b478]
[157466.971] 3: /usr/bin/X (0x400000+0x6eab7) [0x46eab7]
[157466.971] 4: /usr/bin/X (0x400000+0x92d40) [0x492d40]
[157466.971] 5: /lib/libpthread.so.0 (0x7f41e853a000+0xf140) [0x7f41e8549140]
[157466.971] 6: /usr/lib/xorg/modules/drivers/nvidia_drv.so (0x7f41e21bb000+0x8e2d2) [0x7f41e22492d2]
[157466.971] 7: /usr/lib/xorg/modules/drivers/nvidia_drv.so (0x7f41e21bb000+0x8f234) [0x7f41e224a234]
[157466.971] 8: /usr/lib/xorg/modules/drivers/nvidia_drv.so (0x7f41e21bb000+0x10471e) [0x7f41e22bf71e]
[157466.971] 9: /usr/lib/xorg/modules/drivers/nvidia_drv.so (0x7f41e21bb000+0x533942) [0x7f41e26ee942]
[157466.971] 10: /usr/lib/xorg/modules/drivers/nvidia_drv.so (0x7f41e21bb000+0x533c2f) [0x7f41e26eec2f]
[157466.971] 11: /usr/lib/xorg/modules/drivers/nvidia_drv.so (0x7f41e21bb000+0x522853) [0x7f41e26dd853]
[157466.972] 12: /usr/bin/X (0x400000+0xf1c39) [0x4f1c39]
[157466.972] 13: /usr/bin/X (miGlyphs+0x4d6) [0x4e1146]
[157466.972] 14: /usr/lib/xorg/modules/drivers/nvidia_drv.so (0x7f41e21bb000+0x523a39) [0x7f41e26dea39]
[157466.972] 15: /usr/bin/X (0x400000+0xf1ecd) [0x4f1ecd]
[157466.972] 16: /usr/bin/X (0x400000+0xeb0b6) [0x4eb0b6]
[157466.972] 17: /usr/bin/X (0x400000+0x34472) [0x434472]
[157466.972] 18: /usr/bin/X (0x400000+0x23535) [0x423535]
[157466.972] 19: /lib/libc.so.6 (__libc_start_main+0xf5) [0x7f41e73ef455]
[157466.972] 20: /usr/bin/X (0x400000+0x2380d) [0x42380d]
[157466.972]
[157468.581] (WW) NVIDIA(0): WAIT (1, 7, 0x8000, 0x0000eb70, 0x0000ec68)
[157468.581] [mi] Increasing EQ size to 512 to prevent dropped events.
[157468.581] [mi] EQ processing has resumed after 1273 dropped events.
[157468.581] [mi] This may be caused my a misbehaving driver monopolizing the server's resources.
[157471.585] (WW) NVIDIA(0): WAIT (2, 7, 0x8000, 0x0000eb70, 0x0000fdac)
[157478.585] (WW) NVIDIA(0): WAIT (1, 7, 0x8000, 0x0000eb70, 0x0000fdac)
[157481.589] (WW) NVIDIA(0): WAIT (2, 7, 0x8000, 0x0000eb70, 0x000064b4)
[157488.589] (WW) NVIDIA(0): WAIT (1, 7, 0x8000, 0x0000eb70, 0x000064b4)
[157488.589] [mi] Increasing EQ size to 1024 to prevent dropped events.


Comment by Chris (realdarkman) - Thursday, 26 April 2012, 08:33 GMT
Just now freezes again, Xorg CPU 100%! Cannot find any errors in logs! Cold reboot required!

Up to three freezes a day! This sucks! When comes a fix finitely???
Comment by Jelle van der Waa (jelly) - Thursday, 26 April 2012, 08:53 GMT
Please stay calm, archlinux devs can't fix upstreams code. This seems like its all nvidia's fault, so ask them @ http://www.nvnews.net/vbulletin/forumdisplay.php?f=14&order=desc&page=2
Comment by Chris (realdarkman) - Thursday, 26 April 2012, 09:06 GMT
Ok, thanks!
Comment by Stefano Franchi (cleinias) - Saturday, 28 April 2012, 13:33 GMT
Well, there are plenty of messages on the nvidia board about the problem with 295.40 and older cards, including this one:

http://www.nvnews.net/vbulletin/showthread.php?t=178460

which acknowledges it's their fault. But I could not find anything about the 295.33 driver, except for Chris's message, which he reposted there.

In another tread, someone vaguely suggested it may be related to the Xorg update, not to nvidia. So I guess we'll have to wait for either of the two to come up with a fix.

Cheers,

S.
Comment by Ciriaco Garcia de Celis (cgarcia) - Tuesday, 01 May 2012, 17:57 GMT
I only have *INTEL* integrated graphics (Dell 5420) and this bug has triggered 2 times in my computer today, and I remember it also from a recent day. It occurred entering in certain web page (after restarting firefox going to it again) but now I can't reproduce it in the same web page.

It is possible to enter the computer by the network and gracefully restart it, though (only XWindow/keyboard are hang).

Comment by Ciriaco Garcia de Celis (cgarcia) - Tuesday, 01 May 2012, 17:58 GMT
[ 2424.663] [mi] EQ overflow continuing. 1000 events have been dropped.
[ 2424.663] [mi] No further overflow reports will be reported until the clog is cleared.
[ 2424.663]
[ 2424.663] Backtrace:
[ 2424.663] 0: /usr/bin/X (xorg_backtrace+0x36) [0x55f646]
[ 2424.663] 1: /usr/bin/X (0x400000+0x47f62) [0x447f62]
[ 2424.663] 2: /usr/lib/xorg/modules/input/evdev_drv.so (0x7f4bacebc000+0x5478) [0x7f4bacec1478]
[ 2424.663] 3: /usr/bin/X (0x400000+0x6eab7) [0x46eab7]
[ 2424.663] 4: /usr/bin/X (0x400000+0x92d40) [0x492d40]
[ 2424.663] 5: /lib/libpthread.so.0 (0x7f4bb18f7000+0xf140) [0x7f4bb1906140]
[ 2424.663] 6: /lib/libc.so.6 (ioctl+0x7) [0x7f4bb0868727]
[ 2424.663] 7: /usr/lib/libdrm.so.2 (drmIoctl+0x28) [0x7f4baee007e8]
[ 2424.663] 8: /usr/lib/libdrm_intel.so.1 (0x7f4bae789000+0x81d9) [0x7f4bae7911d9]
[ 2424.663] 9: /usr/lib/xorg/modules/drivers/intel_drv.so (0x7f4bae9a7000+0xb408) [0x7f4bae9b2408]
[ 2424.663] 10: /usr/lib/xorg/modules/drivers/intel_drv.so (0x7f4bae9a7000+0x1225a) [0x7f4bae9b925a]
[ 2424.663] 11: /usr/lib/xorg/modules/drivers/intel_drv.so (0x7f4bae9a7000+0x351e4) [0x7f4bae9dc1e4]
[ 2424.663] 12: /usr/bin/X (0x400000+0xf1ecd) [0x4f1ecd]
[ 2424.663] 13: /usr/bin/X (0x400000+0xeb0b6) [0x4eb0b6]
[ 2424.663] 14: /usr/bin/X (0x400000+0x34472) [0x434472]
[ 2424.663] 15: /usr/bin/X (0x400000+0x23535) [0x423535]
[ 2424.663] 16: /lib/libc.so.6 (__libc_start_main+0xf5) [0x7f4bb07ac455]
[ 2424.663] 17: /usr/bin/X (0x400000+0x2380d) [0x42380d]
Comment by mangus (mangus) - Sunday, 06 May 2012, 11:51 GMT
I just had this crash with the nvidia beta drivers 302.07
Comment by Jelle van der Waa (jelly) - Sunday, 06 May 2012, 12:13 GMT
Good, then go complain at nvidia!
Comment by mangus (mangus) - Monday, 04 June 2012, 13:10 GMT
Jelly,please stay calm and don't panic. We are searching for clues here, and workarounds.

It might be a problem with nvidia powermizer and the change of clock freqs that this feature do when it's set to 'adaptive' (default option I think) . It might affects only some chipsets, too.
I add
Option "RegistryDwords" "PowerMizerEnable=0x1; PerfLevelSrc=0x2222; PowerMizerDefaultAC=0x1"
to /etc/X11/xorg.conf.d/20-nvidia.conf in the device section
This sets the card to maximum clock performance, without the adaptive switch.
Never had problems since then. Somehow this change is not retained in the nvidia-settings GUI, so using that for this seems pretty useless.
GeForce GTS 450
driver nvidia-beta 302.11
Comment by Jelle van der Waa (jelly) - Tuesday, 19 June 2012, 10:52 GMT
any update?
Comment by Darren Davison (davison) - Monday, 02 July 2012, 08:13 GMT
I can confirm this happening in 302.17-1 (after quitting bzflag). I'll try the powermizer config change mangus notes above later tonight (not on that machine at present) and report back.
Comment by Divan Santana (divansantana) - Tuesday, 03 July 2012, 18:52 GMT
I had similar problem as this bug report with my nvidia GF119 [Quadro NVS 4200M]. Didn't work at all and sometimes with binary blob driver had this exact problem.

Anyway I used bumblebee and all works fine for me.

See below for more info

https://bbs.archlinux.org/viewtopic.php?pid=1124924#p1124924
Comment by Barry (MeisBarry) - Monday, 30 July 2012, 00:25 GMT
Any word on this issue from NVIDIA? I was unable to get mangus' solution to work (this file doesn't exist on my system).

I'm still having mouse latency issues and an X freeze at least once per day. nvidia-302.17 64bit
Comment by mangus (mangus) - Sunday, 05 August 2012, 21:40 GMT
@barry
just create it yourself , here is mine attached
Comment by Barry (MeisBarry) - Sunday, 05 August 2012, 22:14 GMT
@mangus

I actually made one myself a few days ago and tested it out, but was still getting the same X lockups. If your configuration works for you, I'll try it in place of my own.
Comment by Jelle van der Waa (jelly) - Sunday, 05 August 2012, 22:23 GMT
If you still have these issue you could try the current nvidia-beta ( from AUR ). Else report it to the nvidia developers, archlinux devs can't binary blobs

Loading...