Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#29497 - [Qt] doesn't allow typing of accented characters

Attached to Project: Arch Linux
Opened by Bill Seremetis (bserem) - Monday, 16 April 2012, 22:04 GMT
Last edited by Andrea Scarpino (BaSh) - Wednesday, 13 June 2012, 20:34 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Andrea Scarpino (BaSh)
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No



When I type an accented character in Qt and Qt-application (like Opera) nothing gets printed on the screen.

Additional info:
* package version(s)
qt 4.8.1-2
opera (any version I tried)

* config and/or log files etc.

Steps to reproduce:
Install Qt and/or Opera on an Arch64 system and try to type an accented character. I'm greek so I tried the following:
Άά Έέ Ήή Ίί Όό Ύύ Ώώ ΐ ΰ Ϊϊ Ϋϋ

Nothing gets printed out though (this report is being done from Firefox in order to type out the characters).
This task depends upon

Closed by  Andrea Scarpino (BaSh)
Wednesday, 13 June 2012, 20:34 GMT
Reason for closing:  Upstream
Additional comments about closing:  we cannot do anything about this, please follow the upstream bug report
Comment by Andrea Scarpino (BaSh) - Tuesday, 17 April 2012, 16:09 GMT
Which other Qt application did you try?
Comment by Nikos Theodorou (GordonGR) - Tuesday, 17 April 2012, 17:16 GMT
Already known, I'm afraid:

I filed a bug report in QT, I expect the results:
Comment by Bill Seremetis (bserem) - Tuesday, 17 April 2012, 21:41 GMT
Andrea I tried all three applications coming with Qt (Designer, Assistant, Linguist). I do not know if I have anything else that is Qt based.
None of the above three accepts accented characters.

Nikos I will see the links you provide and follow the progress in the qt-project report. I hope that this gets solved, mainly for Opera but also for everybody who is using accents in their language.
Comment by Nikos Theodorou (GordonGR) - Friday, 20 April 2012, 19:13 GMT
OK, that's interesting: Following this report I tried starting a qt application (eg kate) by
$ LANG=en_GB.UTF-8 kate
and dead keys work for the us_intl layout, but not for the greek one! The same using C or en_US.

So I guess the actual problem (and the reason you can't recreate it), is because your LANG is normally set at an anglophone locale. Can you try activating el_GR.UTF-8 and then recreate it calling the application under that locale?

CC at QT bugtracker (url at my previous comment).
Comment by Nikos Theodorou (GordonGR) - Saturday, 21 April 2012, 10:49 GMT Comment by Bill Seremetis (bserem) - Saturday, 21 April 2012, 13:02 GMT
Nikos I can confirm that by typing:
LANG=en_US.UTF-8 opera
in the command line I can type accented greek characters (when turning the keyboard layout to greek of course).
It even worked with skype (which is a 32bit app under my 64bit Arch system).

Strangelly enough though, I tried the following:
LANG=el_GR.UTF-8 opera
and it worked!! This confuses me because my system has both el_GR and en_US in /etc/locale.gen

I'm afraid I do not know how to type an accented character under the us layout.
Comment by Nikos Theodorou (GordonGR) - Saturday, 21 April 2012, 13:31 GMT
[Accidentally reposted an earlier comment and deleted.]
Comment by Nikos Theodorou (GordonGR) - Saturday, 21 April 2012, 13:38 GMT
Uhm… I can verify that too! LANG=el_GR.UTF-8 anyqtapplication works too! And I bet it does with el_CY too (I've been working with a Greek-Cypriot friend as well on this issue.) But then this IS confusing, as my "locale" verifies I have already set LANG=el_GR.UTF-8 system-wide. I'm exporting it to ~/.bashrc, rebooting and reporting back.

Edit: exporting LANG=el_GR.UTF-8 in ~/.bashrc broke Bill's observation. So, I guess what Qt does wrongly is parse the LANG information when that is not explicitely defined at en_US? I don't know, I'm at a loss again.

Andrea, are you still watching this?

Edit2: Bill, in order to write accented latin letters you need some (variant of) a latin keyboard, eg (the one I use), English International With Dead Keys.
Comment by Bill Seremetis (bserem) - Sunday, 22 April 2012, 10:23 GMT
Nikos I've send you an email (in the one I found in flyspray) about accented latin characters.

I'd like to add to this conversation that Opera doesn't have Qt as a dependency. But it is Qt based and reacts to the problem just like Qt...
Comment by Nikos Theodorou (GordonGR) - Sunday, 22 April 2012, 12:54 GMT
Bill, yes I got your email, thank you. I didn't have the time to reply yesterday. And actually I don't know what to reply any more. After I exported LANG=el_GR.UTF-8 in ~/.bashrc yesterday and your observation broke, I removed the line and relogged/sourced/rebooted a few times but now any qt application under LANG=el_GR.UTF-8 doesn't type dead latin qt keys. So I am at a complete loss. :-S

As for Opera, I guess it uses qt and compiles it internally. At least I know SecondLife/OpenSimulator viewers do that. I don't know.
Comment by Bill Seremetis (bserem) - Sunday, 22 April 2012, 13:46 GMT
Nikos can you please tell the LOCALE line in your /etc/rc.conf file?

Mine was empty (and I believe it should be empty). I added:
instead and now EVERYTHING works fine in regard with Qt applications!
Comment by Nikos Theodorou (GordonGR) - Sunday, 22 April 2012, 14:43 GMT
Mine was set to el_GR.UTF-8. I changed it to en_US.UTF-8 as you recommended and nothing changed. *shrugs*
Comment by Bill Seremetis (bserem) - Monday, 23 April 2012, 19:35 GMT
It seems that something in how Qt communicates with the system isn't exactly right
Comment by Andrea Scarpino (BaSh) - Wednesday, 23 May 2012, 13:01 GMT
Please check 4.8.2. Let we know, thanks.
Comment by Bill Seremetis (bserem) - Thursday, 24 May 2012, 22:35 GMT
My mirror still has the old package (strange!) so I'll post back once he updates, or once I change my mirror.

Thanks for your patience
Comment by Bill Seremetis (bserem) - Wednesday, 06 June 2012, 11:26 GMT
Nothing changed with the new package, neither in Qt developer tools nor in Opera :(

However the solution with en_US.UTF-8 works fine