Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#29495 - [xf86-video-nouveau] 1.12.1-2 partially invisible text

Attached to Project: Arch Linux
Opened by György Balló (City-busz) - Monday, 16 April 2012, 19:52 GMT
Last edited by Ionut Biru (wonder) - Saturday, 19 May 2012, 08:33 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To Andreas Radke (AndyRTR)
Ionut Biru (wonder)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 21
Private No

Details

Description:
After I updated xorg-server from version 1.12.1-1 to 1.12.1-2, some texts (characters) are randomly missing in applications.

Additional info:
* package version(s)
- xorg-server 1.12.1-2
- xf86-video-nouveau 0.0.16_git20120210-1

* config and/or log files etc.
- no errors in Xorg.log

Steps to reproduce:
1. Start xorg-server
2. Launch an application
This task depends upon

Closed by  Ionut Biru (wonder)
Saturday, 19 May 2012, 08:33 GMT
Reason for closing:  Fixed
Additional comments about closing:  xorg-server 1.12.1.901-3
Comment by Ionut Biru (wonder) - Tuesday, 17 April 2012, 11:27 GMT
i know about this issue and I'm in contact with upstream.

today i was announced that the issue is fixed and i'm waiting to be committed and backported to olddrm
Comment by Ionut Biru (wonder) - Saturday, 12 May 2012, 16:40 GMT
since cairo moved unexpectedly in extra, i had to get the new drm and split the nouveau provider in order to build the latest ddx from nouveau, which depends on new drm.

please test xf86-video-nouveau-0.0.16_git20120512-1 which landed in testing.
Comment by György Balló (City-busz) - Saturday, 12 May 2012, 20:11 GMT
I tested xf86-video-nouveau-0.0.16_git20120512-1 from testing and it works well, all texts are visible.
Comment by Kerrick Staley (KerrickStaley) - Sunday, 13 May 2012, 08:12 GMT
Another temporary work-around is:
1. Install gnome-tweak-tool and open it
2. Under Fonts, choose the "Rgba" option for Antialiasing

I will try the [testing] package when I get a chance, though.
Comment by Kerrick Staley (KerrickStaley) - Sunday, 13 May 2012, 08:16 GMT
Err, the above comment assumes you're running Gnome. In general, you need to enable full RGBA anti-aliasing for fonts. I'm guessing that this page [1] will tell you how to do so in a distro-agnostic manner (but I'm not sure).
[1]: https://wiki.archlinux.org/index.php/Font_Configuration
Comment by Ionut Biru (wonder) - Sunday, 13 May 2012, 08:29 GMT
still, does it work with the current version from testing without applying any workarounds?
Comment by Kerrick Staley (KerrickStaley) - Sunday, 13 May 2012, 10:25 GMT
I just tried the latest package, and it does not fix the issue; I still have to enable RGBA antialiasing for things to work.
Comment by Kerrick Staley (KerrickStaley) - Sunday, 13 May 2012, 10:33 GMT
I have a newer graphics card, so the fix for my card might not be in the Git yet (I don't know anything about the nature of this issue, so this is just a guess; I do know that Nouveau's support for different cards varies considerably, and my card wasn't supported at all by the shipping driver until a month or so ago).
My card is a GeForce GTX 560M (which is the NVC0 architecture).
Comment by Stéphane Marguet (Stemp) - Sunday, 13 May 2012, 10:48 GMT
I upgraded xf86-video-nouveau and installed libdrm-nouveau from testing and the problem is fixed for me.
Comment by Diego Viola (diegoviola) - Sunday, 13 May 2012, 10:50 GMT
Upgraded to testing and the problem is fixed here. Thanks to the nouveau and archlinux devs :-)

My card is: GeForce 9500 GT.
Comment by Bill Good (bkgood) - Monday, 14 May 2012, 06:35 GMT
These packages appear to be out of test but I'm still seeing the bug with these from [extra]:

bill@billdesk ~ $ pacman -Q xorg-server cairo xf86-video-nouveau libdrm-new libdrm-nouveau
xorg-server 1.12.1-2
cairo 1.12.2-1
xf86-video-nouveau 0.0.16_git20120512-1
libdrm-new 2.4.34-1
libdrm-nouveau 2.4.34-1

My Nvidia card is a GTX 570, I first noticed the text disappearing after I rebooted today after updates yesterday, to both cairo xorg-server (but I guess cairo is the relevant one).
Comment by Ionut Biru (wonder) - Monday, 14 May 2012, 07:58 GMT
why did you install libdrm-new ? using this version will break nouveau-dri. get back to libdrm + libdrm-nouveau.
Comment by Bill Good (bkgood) - Monday, 14 May 2012, 15:12 GMT
It got pulled onto my system when I built xf86-video-nouveau from abs I think. I don't use nouveau-dri as software rendering works well enough for me, and I don't think nouveau-dri worked with my card the last time I tried, but I moved back to libdrm:

bill@billdesk ~ $ pacman -Q xorg-server cairo xf86-video-nouveau libdrm libdrm-nouveau
xorg-server 1.12.1-2
cairo 1.12.2-1
xf86-video-nouveau 0.0.16_git20120512-1
libdrm 2.4.33-1
libdrm-nouveau 2.4.34-1

The problem persists.
Comment by Ionut Biru (wonder) - Monday, 14 May 2012, 15:16 GMT
OK, please contact Ben Skeggs (bskeggs@redhat.com) since he fixed rendering issues (the commits from 2012-04-24).

http://cgit.freedesktop.org/nouveau/xf86-video-nouveau/log/

Send him pictures, Xorg.0.log, card model etc.
Comment by Michael Hartman (gatorm) - Tuesday, 15 May 2012, 01:39 GMT
I have the same text problem with the same package versions as Bill Good.
Comment by Diego Viola (diegoviola) - Tuesday, 15 May 2012, 03:26 GMT
Have you guys reported this upstream yet?
Comment by Bill Good (bkgood) - Tuesday, 15 May 2012, 03:30 GMT
I sent an email earlier today but haven't heard back.
Comment by m t (ElKatrina) - Wednesday, 16 May 2012, 02:39 GMT
Ben Skeggs replied:

Your distribution applied a patch from that bug which (as mentioned in
the bug) doesn't help the issue completely, and actually makes it worse
for some people.

There's nothing I can do about this.

The latest upstream nouveau driver code has support for the operation
which was previously a fallback and triggers the bug in the current
xserver code.

Thanks,
Ben.
Comment by Diego Viola (diegoviola) - Wednesday, 16 May 2012, 02:51 GMT
I'm confused, so the xserver needs a fix also? Perhaps someone should report this to the xorg guys?
Comment by Ionut Biru (wonder) - Wednesday, 16 May 2012, 09:09 GMT
can you update to xorg from testing?
Comment by m t (ElKatrina) - Wednesday, 16 May 2012, 10:22 GMT
I upgraded so that I had the same configuration as Bill Good above, but without libdrm-new. This did not help. I have downgraded to xorg-server 1.12.1-1 for now until the problem is fixed, but I'd be happy to try other things out
Comment by Bill Good (bkgood) - Wednesday, 16 May 2012, 18:54 GMT
Updating xorg from testing didn't help.


xorg-server 1.12.1.901-2
xf86-video-nouveau 0.0.16_git20120512-1
libdrm 2.4.33-1
libdrm-nouveau 2.4.34-1
cairo 1.12.2-1
Comment by Bill Good (bkgood) - Wednesday, 16 May 2012, 20:55 GMT
Building and installing xorg-server (and xorg-server-common) without EXA_Fall_back_earlier_and_more_thoroughly_from_exaGlyphsV2.diff as in abs/testing (xorg-server 1.12.1.901-2) fixed the issue on my end.

Edit: same goes for PKGBUILD currently in [extra] (xorg-server 1.12.1-2). I should mention I'm not advocating blind removal of the patch as I'm sure it's there for a reason (helps others) but it seems to be the problem in this case.
Comment by Ionut Biru (wonder) - Wednesday, 16 May 2012, 21:13 GMT
Andy, AXA_Fall_back_earlier_and_more_thoroughly_from_exaGlyphsV2.diff is still needed for ati/intel? It seems that is breaking nouveau badly.
Comment by Diego Viola (diegoviola) - Thursday, 17 May 2012, 04:28 GMT
00:25 < diegoviola> darktama: hi
00:25 < diegoviola> darktama: might you know about this issue please? https://bugs.archlinux.org/task/29495
00:25 < diegoviola> or what can be done to fix those users with that problem still...
00:26 < darktama> as my email reply that's pasted in the bug mentioned, it's not my problem
00:26 < darktama> arch is shipping a known-broken EXA patch
00:26 < diegoviola> oh i see
00:26 < diegoviola> thanks
00:27 < darktama> i added solid picture support to nouveau, which will avoid the original problem that that EXA patch was supposed to fix
00:27 < darktama> and i *think* arch is now shipping it
00:30 < diegoviola> darktama: ty
00:31 < diegoviola> darktama: sorry to bother with this, thanks for the explanation
00:31 < darktama> ah no worries
00:32 * darktama has been getting it a *lot* from arch people recently
00:51 < diegoviola> do you guys know if the intel or radeon driver needs that patch?
01:05 < RAOF> Intel doesn't use EXA, so won't exhibit any EXA problems; radeon might.
Comment by Andreas Radke (AndyRTR) - Thursday, 17 May 2012, 09:09 GMT
Ioni: https://bugs.freedesktop.org/show_bug.cgi?id=47266#c109

I guess that Xorg patch is needed. If it breaks nouveau you should report it again to the cairo bug an to Michael and Alex that they have a look
if the server patch needs an improvement or nouveau is still buggy.
Comment by Ionut Biru (wonder) - Thursday, 17 May 2012, 09:17 GMT
Andy, darktama is the main developer of nouveau ddx and he said that patch is broken, is a work in progress.

In my opinion we should stop shipping that change because is not committed at all xserver git

Whoever has problems with this patch, can you guys report to the report that Andy has pasted? explain better what happens with it enabled, card model, logs and not forget to mention that nouveau has now support for solid picture.
Comment by Michael Hartman (gatorm) - Thursday, 17 May 2012, 17:01 GMT
Good news everyone. I installed xorg-server 1.12.1.901-3 and xorg-server-common 1.12.1.901-3 from testing and this has fixed the problem on my end.
Comment by Ionut Biru (wonder) - Thursday, 17 May 2012, 17:07 GMT
horay
Comment by Diego Viola (diegoviola) - Saturday, 19 May 2012, 08:00 GMT
Is the latest xorg-server from extra shipping without the EXA_Fall_back_earlier_and_more_thoroughly_from_exaGlyphsV2.diff patch?
Comment by Ionut Biru (wonder) - Saturday, 19 May 2012, 08:33 GMT
yes.

Loading...