Pacman

Welcome to the Pacman bug tracker. Please search the current bugs and feature requests before filing a new one! Use advanced search and select "Search in Comments".

* Please select the correct category and version.
* Write a descriptive summary, background info, and provide a reproducible test case whenever possible.
Tasklist

FS#29479 - Categories support for Pacman/Makepkg/or the respective related

Attached to Project: Pacman
Opened by Pablo Lezaeta (Jristz) - Sunday, 15 April 2012, 23:12 GMT
Last edited by Allan McRae (Allan) - Sunday, 22 April 2012, 12:11 GMT
Task Type Feature Request
Category Backend/Core
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version 4.0.2
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 5
Private No

Details

Summary and Info:
Support of categories in pacman, like wm or laptop...
If you want to install package xxx just type pacman -S xxx, but if you don't know package name but you want some stuff for laptops just browse pacman -option app-laptop catagory.

Steps to Reproduce:
search for firmware and see that not all firmware ar chowed or search for laptop apps like the example

maybe look like Pacman -S --app laptop and display all related do laprop like drivers (ip220-fw) firmware (buez-firmware) and oters (laptop-mode-tools powerdown)

other form is a GOOS gouping management not only X11 gnome, more than X11 part of video and digicam KDE part of video....this can help in searching for a package
This task depends upon

Closed by  Allan McRae (Allan)
Sunday, 22 April 2012, 12:11 GMT
Reason for closing:  Duplicate
Additional comments about closing:  FS#7132
Comment by Karol Błażewicz (karol) - Sunday, 15 April 2012, 23:32 GMT
Have a look at pacnet: http://pacnet.karbownicki.com/ -> http://pacnet.karbownicki.com/category/app-laptop/

We also have a wiki article that should help with the laptop part https://wiki.archlinux.org/index.php/Laptop
Comment by Allan McRae (Allan) - Monday, 16 April 2012, 00:36 GMT Comment by Pablo Lezaeta (Jristz) - Tuesday, 17 April 2012, 01:41 GMT
the idea is for help finding packages not nessesari the adding of the same feaute tan group, is moe like a @meta@/grouping

exaple> ip220/fw and ip2100/fw may ni base but not installed by default ok...
then both can in category firmware and/or laptop, this help peoples to find firmwares (in this case) for they machina

oter use cam by adding them for offimatic: the majority use libreoffice ok, but not nessesary know the existence of abiword and a category for this can help

bassicaly the idea is for the grat problem : the description not nessesary are acurated or show wht is the package, or searching a package fom a category that not know theyr name

and this pathc can by help...I not try now, but on weekend I test this
Comment by Allan McRae (Allan) - Wednesday, 18 April 2012, 04:10 GMT
I am going to point out that in Arch Linux "pacman -Ss firmware" should return all firmware packages. Otherwise the description line needs fixed.
Comment by Pablo Lezaeta (Jristz) - Thursday, 19 April 2012, 00:23 GMT
example:
emacs: not show in IDE dev develop development
ekiga: search for IDe an ekiga is show in results
my idea """fix""" de bad descriptions, is more esasy fill category rathen that fill a decription tath fill all possibles and reals form to search a package and at the same thime maintain the decription
Comment by Allan McRae (Allan) - Thursday, 19 April 2012, 03:47 GMT
I will point out that I am not against adding category support to pacman. Particular if there was a way to list packages in a category or search only within a category (which is not supplied in the chakra patch). Especially since categories are useful for packagekit frontends.

However, I do not see Arch Linux using them even if they get implemented in pacman. Packages used to be categorized, but that disappeared a long time ago... Much like the ChangeLogs.

Loading...