Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#29469 - [qt] assistant crash after upgrade

Attached to Project: Arch Linux
Opened by David (amen) - Sunday, 15 April 2012, 12:45 GMT
Last edited by Andrea Scarpino (BaSh) - Tuesday, 18 September 2012, 07:08 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Andrea Scarpino (BaSh)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 15
Private No

Details

Description:
after updating to the newest qt package Qt Assistant crash on start.

Additional info:
* Qt 4.8.1-2

dmesg log:
assistant[4645]: segfault at 26d6ff0 ip 00007fc396e7c24a sp 00007fff32d3bec8 error 4 in libc-2.15.so[7fc396d4e000+197000]

Steps to reproduce:
Start Qt Assistant (more than once).
This task depends upon

Closed by  Andrea Scarpino (BaSh)
Tuesday, 18 September 2012, 07:08 GMT
Reason for closing:  Fixed
Additional comments about closing:  qt 4.8.3-2
Comment by Andrea Scarpino (BaSh) - Sunday, 15 April 2012, 15:32 GMT
I rebuilt our qt package with no patches and this do not solve the issue. (if you want to try: http://pkgbuild.com/~andrea/pkgs/qt/trunk/qt-4.8.1-3-x86_64.pkg.tar.xz )
Both 4.8.1-2 and 4.8.1-3 are built with GCC 4.7, so I guess that is causing some error.

reported upstream https://bugreports.qt-project.org/browse/QTBUG-25324
Comment by David (amen) - Sunday, 15 April 2012, 17:33 GMT Comment by Matej Lach (MatejLach) - Wednesday, 18 April 2012, 12:53 GMT
I am also experiencing this problem.
More info at http://bbs.archlinux.org/viewtopic.php?id=139803
Comment by Miguel Angel Rasero (skuda) - Wednesday, 18 April 2012, 13:50 GMT
i have deleted ~.local/share/data/Trolltech/Assistant and now it works, assistant have recreated some files there (the search index i think), but only fix one time, the next time you loads assistant it get other segmentation fault loading the existing index files.
Comment by Marius Cirsta (mcirsta) - Wednesday, 25 April 2012, 19:51 GMT
Here is a backtrace from Qt with debug symbols take from Frugalware with the same problem:

#0 __memcpy_sse2 () at ../sysdeps/x86_64/multiarch/../memcpy.S:273
#1 0x000000000044e9dd in node_copy (src=0xffffffff9faff288, to=<optimized out>, from=<optimized out>, this=<optimized out>) at ../../../../include/QtCore/../../src/corelib/tools/qlist.h:423
#2 detach_helper (alloc=<optimized out>, this=0x7fffffffd050) at ../../../../include/QtCore/../../src/corelib/tools/qlist.h:711
#3 QList<QWidget*>::detach_helper (this=0x7fffffffd050) at ../../../../include/QtCore/../../src/corelib/tools/qlist.h:725
#4 0x000000000044c6d2 in QList (l=..., this=0x7fffffffd050) at ../../../../include/QtCore/../../src/corelib/tools/qlist.h:122
#5 QForeachContainer (t=..., this=0x7fffffffd050) at ../../../../include/QtCore/../../src/corelib/global/qglobal.h:2338
#6 MainWindow::updateApplicationFont (this=this@entry=0x781d00) at mainwindow.cpp:948
#7 0x000000000044d5f8 in MainWindow::MainWindow (this=0x781d00, cmdLine=<optimized out>, parent=<optimized out>) at mainwindow.cpp:236
#8 0x0000000000424e51 in main (argc=1, argv=<optimized out>) at main.cpp:427
(gdb) quit

The problem is from here :

if (src != from && to - from > 0)
memcpy(from, src, (to - from) * sizeof(Node *));

My guess is that some of these addresses for memcpy aren't OK. Going to attach the same backtrace and comment to upstream too, maybe they can fix their thing.
Comment by Andrea Scarpino (BaSh) - Wednesday, 23 May 2012, 13:00 GMT
Still not fixed in 4.8.2
Comment by André Vitor Matos (andre.vmatos) - Friday, 14 September 2012, 16:57 GMT
  • Field changed: Percent Complete (100% → 0%)
Regression in 4.8.3-1, this bug was resurrected. Same problem, deleting ~/.local/share/data/Trolltech/Assistant make it load, but, next time, Segfault again
Comment by Andrea Scarpino (BaSh) - Friday, 14 September 2012, 16:57 GMT
I get some crash on starting rekonq/kwrite too.
Comment by André Vitor Matos (andre.vmatos) - Monday, 17 September 2012, 21:26 GMT
Fixed in 4.8.3-2

Loading...