Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#29438 - [linux] enable MTRR cleanup by default

Attached to Project: Arch Linux
Opened by Jan Alexander Steffens (heftig) - Friday, 13 April 2012, 20:44 GMT
Last edited by Tobias Powalowski (tpowa) - Monday, 16 April 2012, 08:23 GMT
Task Type Bug Report
Category Kernel
Status Closed
Assigned To Tobias Powalowski (tpowa)
Thomas B├Ąchler (brain0)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

This should allow some devices to enable write-combining for the graphics card, if it otherwise couldn't. At least my old Thinkpad X61 needed it.

AFAIK, it won't hurt if it's not needed.
This task depends upon

Closed by  Tobias Powalowski (tpowa)
Monday, 16 April 2012, 08:23 GMT
Reason for closing:  Not a bug
Comment by Tobias Powalowski (tpowa) - Saturday, 14 April 2012, 09:22 GMT
Name in config file? There is not MTRR CLEANUP
Comment by Jan de Groot (JGC) - Saturday, 14 April 2012, 10:19 GMT
CONFIG_MTRR_SANITIZER_ENABLE_DEFAULT=1 should do that.

The question is: is this desirable for all systems? I've seen reports on MTRR cleanup failing because it needs additional options anyways. You can enable mtrr cleanup by adding "enable_mtrr_cleanup" to the kernel boot line. That boot option doesn't require any changes to our current kernel configuration.
Comment by Tobias Powalowski (tpowa) - Monday, 16 April 2012, 08:22 GMT
Ok activate it by kernel cmdline then.

Loading...