Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#29414 - [deluge] libtorrent-rasterbar update breaks deluge download

Attached to Project: Arch Linux
Opened by Marcin Orszulski (Nastirh) - Thursday, 12 April 2012, 21:29 GMT
Last edited by Jan Steffens (heftig) - Saturday, 12 January 2013, 12:48 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Ionut Biru (wonder)
Jan Steffens (heftig)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 22
Private No

Details

Description:

Deluge doesn't work with package libtorrent-rasterbar 0.16.0-1. Works fine with libtorrent-rasterbar 0.15.10-1.

Additional info:
Deluge 1.3.4-2
libtorrent-rasterbar 0.16.0-1


Steps to reproduce:

1. Upgrade libtorrent-rasterbar to 0.16.0-1
2. Reboot
3. Deluge doesn't downloading torrents. On progress bars are inscriptions "Error"
This task depends upon

Closed by  Jan Steffens (heftig)
Saturday, 12 January 2013, 12:48 GMT
Reason for closing:  Fixed
Additional comments about closing:  1.3.5-4. If still affected, try removing and readding failing torrents.
Comment by Maciej Sitarz (macieks2) - Saturday, 14 April 2012, 08:22 GMT
Deluge devs seem to know about the issue and they reccomend using 0.15: http://forum.deluge-torrent.org/viewtopic.php?f=8&t=39665
Comment by Maciej Sitarz (macieks2) - Saturday, 14 April 2012, 08:28 GMT
My deluge downloads torrents but I can't add new torrents using magnet links, also I can't control bandwidth limits.
Comment by Bruno Guerreiro (American_Jesus) - Sunday, 15 April 2012, 13:38 GMT
Adding uid=USER,gid=users to fstab on ntfs-3g partitions solve the problem, in my case
Relative Link: http://www.archlinux.it/forum/viewtopic.php?f=18&t=14296&sid=9879394572e29c7517b707f0ba98cf41
Comment by Maciej Sitarz (macieks2) - Sunday, 15 April 2012, 13:44 GMT
But are you able to control bandwidth or add new torrents?

I think your issue is not related with libtorrent-rasterbar update.
Comment by Bruno Guerreiro (American_Jesus) - Sunday, 15 April 2012, 13:48 GMT
Only can add torrents with .torrent file, magnet links not working
control bandwidth are working (global and per torrent)
Comment by Fernando Costa (fernando_costa) - Sunday, 15 April 2012, 16:32 GMT Comment by Martins (kurrata) - Sunday, 15 April 2012, 18:39 GMT
Deluge doesn't work with package libtorrent-rasterbar 0.16.0-1. Works fine with libtorrent-rasterbar 0.15.10-1.

I can confirm this, deluge doest work with 0.16 and downgrading helps
Comment by Fernando Costa (fernando_costa) - Sunday, 15 April 2012, 19:04 GMT
Yes, but deluge 1.3.5-1 doesn't work with libtorrent-rasterbar < 0.16.0-1

[code]
Traceback (most recent call last):
File "/usr/lib/python2.7/site-packages/deluge/ui/gtkui/gtkui.py", line 308, in _on_reactor_start
client.start_classic_mode()
File "/usr/lib/python2.7/site-packages/deluge/ui/client.py", line 563, in start_classic_mode
self._daemon_proxy = DaemonClassicProxy(self.__event_handlers)
File "/usr/lib/python2.7/site-packages/deluge/ui/client.py", line 436, in __init__
self.__daemon = deluge.core.daemon.Daemon(classic=True)
File "/usr/lib/python2.7/site-packages/deluge/core/daemon.py", line 141, in __init__
from deluge.core.core import Core
File "/usr/lib/python2.7/site-packages/deluge/core/core.py", line 36, in <module>
from deluge._libtorrent import lt
File "/usr/lib/python2.7/site-packages/deluge/_libtorrent.py", line 59, in <module>
import libtorrent as lt
ImportError: libboost_system.so.1.48.0: cannot open shared object file: No such file or directory
[/code]
Comment by Ionut Biru (wonder) - Sunday, 15 April 2012, 19:18 GMT
i don't know why your trace contains boost 1.48. We have boost 1.49 and libtorrent-rasterbar was built against it.
Comment by Jan Steffens (heftig) - Sunday, 15 April 2012, 19:26 GMT
Nothing we can do here. Just wait for upstream to fix this.
Comment by Andrew (gman) - Sunday, 15 April 2012, 19:42 GMT
Old libtorrent-rasterbar(0.15.9) is linked with old boost-libs (1.48).
Comment by Ionut Biru (wonder) - Sunday, 15 April 2012, 19:44 GMT
use 0.15.10
Comment by Andrew (gman) - Sunday, 15 April 2012, 19:48 GMT
thank
Comment by Fernando Costa (fernando_costa) - Sunday, 15 April 2012, 20:12 GMT
It didn't work. Now that I installed libtorrent-rasterbar 0.15.0-1 and boost 1.49, it complains about libtorrent:

Traceback (most recent call last):
File "/usr/lib/python2.7/site-packages/deluge/ui/gtkui/gtkui.py", line 308, in _on_reactor_start
client.start_classic_mode()
File "/usr/lib/python2.7/site-packages/deluge/ui/client.py", line 563, in start_classic_mode
self._daemon_proxy = DaemonClassicProxy(self.__event_handlers)
File "/usr/lib/python2.7/site-packages/deluge/ui/client.py", line 436, in __init__
self.__daemon = deluge.core.daemon.Daemon(classic=True)
File "/usr/lib/python2.7/site-packages/deluge/core/daemon.py", line 141, in __init__
from deluge.core.core import Core
File "/usr/lib/python2.7/site-packages/deluge/core/core.py", line 36, in <module>
from deluge._libtorrent import lt
File "/usr/lib/python2.7/site-packages/deluge/_libtorrent.py", line 59, in <module>
import libtorrent as lt
ImportError: No module named libtorrent



But actually, libtorrent is installed:

$ pacman -Qs libtorrent
local/libtorrent 0.12.9-1
BitTorrent library written in C++
local/libtorrent-rasterbar 0.15.0-1
A C++ library that aims to be a good alternative to all the other bittorrent implementations around


I think I will give up and wait for the problem to be fixed upstream. Meanwhile I can use .torrent files.
Comment by Andrew (gman) - Sunday, 15 April 2012, 20:18 GMT
Fernando, try install 0.15.10-1 instead 0.15.0-1.
Comment by Swift Geek (swiftgeek) - Friday, 20 April 2012, 20:50 GMT
libtorrent-rasterbar doesn't want to compile with python (3.x) in system. I had to -Rdd :(
Works after downgrade with epoch=1
Comment by Bruno Guerreiro (American_Jesus) - Friday, 20 April 2012, 21:03 GMT
Try to add export PYTHON="/usr/bin/python2" before ./configure
Comment by Swift Geek (swiftgeek) - Friday, 20 April 2012, 21:14 GMT
That have fixed PKGBUILD ;)
thx and please update PKGBUILD in trunk
Comment by Nikolay Amiantov (abbradar) - Wednesday, 25 April 2012, 05:03 GMT
we have deluge-1.3.5-1 in [extra] now, it works with new libtorrent-rasterbar 0.16.0-1, why downgrade?
Comment by Swift Geek (swiftgeek) - Wednesday, 25 April 2012, 05:17 GMT
It works with 0.16, but not in 100%
One of these broken features is magnet link support.
Comment by Nikolay Amiantov (abbradar) - Wednesday, 25 April 2012, 07:07 GMT
I can confirm this now (made some testing, but with magnet links - only after the request), so I'm sorry for reopening this - just hadn't known how to close a request.
Comment by Florian Baumann (DerFlob) - Wednesday, 27 June 2012, 12:52 GMT
libtorrent-rasterbar has since been updated to 0.16.1. I gave it a try and adding magnet link works for me again. This was the only issue I had with 0.16 before. So I don't know about other issues, described here. Maybe they could give it a try, too.
Comment by Roberto Malinverni (daneel971) - Friday, 20 July 2012, 21:11 GMT
with libtorrent-rasterbar 0.16.1, deluge won't move anymore completed torrent to another directory.
Comment by miskoala (miskoala) - Sunday, 22 July 2012, 19:38 GMT
with libtorrent-rasterbar 0.16.2 I had problem with renaming and moving any directories. Also problem with new added torrents (status and directories for them), some buggy appearance in deluge-gtk client. I downgraded libtorrent-rasterbar to 0.15.10-1 and boost-libs to 1.49.0-2 and deluge works fine again
Comment by Ionut Biru (wonder) - Sunday, 22 July 2012, 20:34 GMT
instead of using an old and broken boost-libs, is easier to just switch clients.

transmission-gtk is better
Comment by miskoala (miskoala) - Sunday, 22 July 2012, 21:01 GMT
I can't switch deluge to transmission. I can consider that only if they implement this: https://trac.transmissionbt.com/ticket/1220
but this is offtopic
Comment by Andreas Thorp (thorp) - Saturday, 25 August 2012, 18:51 GMT
Dirty hack to fix the torrent moving bug attached. Source: https://bugs.launchpad.net/deluge/+bug/1041415
Comment by Alexander F Rødseth (xyproto) (trontonic) - Tuesday, 11 September 2012, 05:52 GMT
Does the patch work for anyone else? (just while waiting for a new deluge release, I presume)
Comment by Tim (tes) - Friday, 19 October 2012, 17:12 GMT
It works for me
Edit: the patch that is
Comment by Alexander F Rødseth (xyproto) (trontonic) - Saturday, 20 October 2012, 12:27 GMT
Thanks for testing. The patch could be applied while waiting for a fixed upstream release, but it's up to the package maintainers.
Comment by FND (FND) - Tuesday, 23 October 2012, 07:41 GMT
I'm afraid applying the patch doesn't make any difference for me (deluge 1.3.5, libtorrent 0.16.4.0, libtorrent-rasterbar 1:0.16.4-1).

Downgrading libtorrent-rasterbar to 1:0.16.3-1 makes it work again (even without the patch).
Comment by Swift Geek (swiftgeek) - Tuesday, 23 October 2012, 07:44 GMT
Is it possible to compile 0.15.10 now? If yes, then it's maybe worth posting that pkgbuild on AUR as a temporary fix…
Maybe it would be possible to link it statically against older boost
Comment by Andrew (DSpider) - Tuesday, 23 October 2012, 08:57 GMT Comment by John (graysky) - Monday, 31 December 2012, 16:05 GMT
Does 0.16.6 solve resolve the issue (need to build via ABS)?
Comment by Mikkel Oscar Lyderik (moscar) - Tuesday, 01 January 2013, 18:00 GMT
0.16.6 does seem to solve the issue but deluge looks for libtorrent-rasterbar.so.6 and 0.16.6 provides .so.7 (I renamed .so.7 to .so.6 to test it, and that works)
Comment by Mikkel Oscar Lyderik (moscar) - Wednesday, 09 January 2013, 02:02 GMT
I talked to some of the deluge guys and it turns out that the current stable release 1.3.5 doesn't officially support the 0.16-branch of libtorrent-rasterbar.

I would suggest using deluge-git from aur (which is compatible with the 0.16-branch and the latest release in extra), until they release a stable version which support 0.16.
Comment by Alexander F Rødseth (xyproto) (trontonic) - Wednesday, 09 January 2013, 13:57 GMT
Since it's currently broken, would it be possible to temporarily use the git version of deluge as the official package, while waiting for the upstream release?
Comment by Mikkel Oscar Lyderik (moscar) - Wednesday, 09 January 2013, 14:15 GMT
To follow up on my previous comment.

The deluge guys recommended using, the 1.3-stable branch of the git version, the master branch isn't stable. I have made an aurpackage called deluge-stable which builds the 1.3-stable branch from git.

Here it is: https://aur.archlinux.org/packages/deluge-stable/
Comment by John (graysky) - Wednesday, 09 January 2013, 16:44 GMT
Thank you for the stable git package... if this is a true incompatibility I would think that our official deluge package should be temporarily point to a shanpshot from this branch much like the mplayer package does. Thoughts?
Comment by Jan Steffens (heftig) - Wednesday, 09 January 2013, 16:46 GMT
I'll check it out later, maybe stick something into [testing].
Comment by Jan Steffens (heftig) - Thursday, 10 January 2013, 12:39 GMT
Updated deluge in [testing] using current 1.3-stable HEAD. Please check it out.
Comment by Alexander F Rødseth (xyproto) (trontonic) - Thursday, 10 January 2013, 15:12 GMT
Same problem here with 1.3.5-dev from [testing].
Comment by Alexander F Rødseth (xyproto) (trontonic) - Thursday, 10 January 2013, 16:09 GMT
Re-adding torrents solved the problem here. Works now.
Comment by John (graysky) - Saturday, 12 January 2013, 12:46 GMT
Packages from [testing] are working fine on my systems as well. Seeding archlinux-2013.01.04-dual.iso just fine. Recommend you push to stable repos.

Loading...