Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#29402 - [qt] Fix a crash in cursorToX() when new block is added (QTBUG-24718)

Attached to Project: Arch Linux
Opened by Elvis Stansvik (estan) - Thursday, 12 April 2012, 12:22 GMT
Last edited by Andrea Scarpino (BaSh) - Saturday, 14 April 2012, 09:00 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Andrea Scarpino (BaSh)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 6
Private No



The attached file adds a fix for a crash [1] that was introduced in 4.8.x. The crash most notably affects the recently released Calligra Suite 2.4, but also GNU TeXmacs and probably others. The fix will be in the upcoming 4.8.2 [2], but until then it would be great if you could update the package with this patch.


Additional info:

The attached patch is for the qt-4.8.1-1 package.
Fedora has also decided to patch Qt 4.8.1 with this fix, since it's pretty serious.

Steps to reproduce:

E.g. Calligra Words exhibits exceedingly crashy behavior without this patch, to the point where the developers of Calligra has disabled compilation on Qt 4.8+ unless you specify -DIHAVEPATCHEDQT=1 when building.
This task depends upon

Closed by  Andrea Scarpino (BaSh)
Saturday, 14 April 2012, 09:00 GMT
Reason for closing:  Fixed
Additional comments about closing:  qt 4.8.1-2