Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#29399 - [phpmyadmin] won't browse tables

Attached to Project: Community Packages
Opened by K (LeHibou) - Thursday, 12 April 2012, 07:05 GMT
Last edited by Sergej Pupykin (sergej) - Wednesday, 18 April 2012, 15:11 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Sergej Pupykin (sergej)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

I updated my system as usual (daily basis).

But since new versions of lamp components came out, I just cannot browse my tables in phpmyadmin.
It just shows headers of the table but blank results.
No way to make a query either. Blank result.

Same results with Firefox, Chromium, Opera, all with emptied cache.

Exporting tables shows all my datas. So my tables are not fucked up.
Moreover, works well if I make a query directly in mysql command line.

Reinstalled phpmyadmin and created a new database : same thing.

It looks like being related to phpmyadmin install/rights?. I didn't configure anything between the moment it used to work and now. Updated via yaourt -Syu.

No error message.

Additional info:
* package version(s)
* config and/or log files etc.

Apache : 2.2.22-3
Php : 5.3.10-4
Mysql : 5.5.22-1
phpmyadmin : 3.5.0-1


Steps to reproduce:
- Connect to phpmyadmin
- Select database / or create one
- Browse tables -> blank results but headers will show up.
This task depends upon

Closed by  Sergej Pupykin (sergej)
Wednesday, 18 April 2012, 15:11 GMT
Reason for closing:  Not a bug
Comment by Jelle van der Waa (jelly) - Thursday, 12 April 2012, 07:25 GMT
Did you check the error log of Apache? Also this is a support question not a bug. So ask the forums for extra help
Comment by Sergej Pupykin (sergej) - Friday, 13 April 2012, 15:19 GMT
upgrade did not break anything on 2 my machines
Comment by K (LeHibou) - Sunday, 15 April 2012, 07:39 GMT
it did for me : more exactly, phpmyadmin is the culprit as adminer works like a charm. Phpmyadmin cannot access anymore all my tables, that they are new or not.

It is definitely a phpmyadmin problem-related.

What do you suggest ?

Thanks,

Kevin
Comment by Sergej Pupykin (sergej) - Monday, 16 April 2012, 09:39 GMT
Try to downgrade phpmyadmin package only.

https://wiki.archlinux.org/index.php/Downgrading_Packages
Comment by K (LeHibou) - Wednesday, 18 April 2012, 13:26 GMT
Ok, it was a json-related problem with module json in php.ini.


Everything is ok right now, something might have changed since last version of phpmyadmin, since it now relies on json.

Many thanks !

Loading...