Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#29398 - ata_id[1605]: HDIO_GET_IDENTITY failed for '/dev/sdb': Invalid argument Bug but still boots

Attached to Project: Arch Linux
Opened by Jake Godusky (jakebpg) - Wednesday, 11 April 2012, 22:10 GMT
Last edited by Dave Reisner (falconindy) - Friday, 20 April 2012, 01:01 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To No-one
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description: This message shows up every time I boot Arch linux. My configuration is multiple disk partitions with multiple OSs on these partitons. Not sure why it is reporting /dev/sdb when there is NO /dev/sdb installed. The machine is a Toshiba L655 S5165 laptop with a 500GB drive. The following are the results of running fdisk -l

sudo fdisk -l
Password:

Disk /dev/sda: 500.1 GB, 500107862016 bytes
255 heads, 63 sectors/track, 60801 cylinders, total 976773168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0xd6de40c5

Device Boot Start End Blocks Id System
/dev/sda1 * 2048 3074047 1536000 27 Hidden NTFS WinRE
/dev/sda2 3074048 768534527 382730240 7 HPFS/NTFS/exFAT
/dev/sda3 768534528 769558527 512000 83 Linux
/dev/sda4 769558528 976773167 103607320 5 Extended
/dev/sda5 769560576 934842368 82640896+ 8e Linux LVM
/dev/sda6 934844416 976773167 20964376 83 Linux

As you can see there are multiple partitions and here is how they relate to the OSs on my system.

/dev/sda1 Windows 7
/dev/sda2 Windows 7
/dev/sda3 fedora 17 boot
/dev/sda4 extended partition as listed above
/dev/sda5 fedora LVM containing /root /home /swap
/dev/sda6 Arch 2011.08.19 fully updated running KDE and kernel(as stated by uname -a)Linux ArchLinux 3.3.1-1-ARCH #1 SMP PREEMPT Tue Apr 3 06:46:17 UTC 2012 x86_64 Intel(R) Core(TM) i5 CPU M 480 @ 2.67GHz GenuineIntel GNU/Linux

Is this because Arch is loading from its own partition and reporting the remainder of the drive as /dev/sdb?

Steps to reproduce: Load multiple OSs before loading Arch. Arch was the last loaded system and skip installing grub since grub2 was already installed by fedora 17 and I used fedoras grub2-mkconfig -o /boot/grub2/grub.cfg program which includes OS_prober. This detected the Arch installation and all is good from there except for the error mentioned in the summary which pops up at every boot.

I really like Arch and have been using it as my main OS but still need fedora and windows for various other tasks but in the future may eliminate fedora but this error message is very annoying and something I wish not to see if I do move to Arch altogether and eliminate fedora.
This task depends upon

Closed by  Dave Reisner (falconindy)
Friday, 20 April 2012, 01:01 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#27060 
Comment by Jan de Groot (JGC) - Friday, 13 April 2012, 19:04 GMT
ata_id is run by udisks or udev and is executed for every disk device using the SCSI layer. This can be a SATA harddisk, but also a USB stick or a cardreader with no media inserted. Can you attach the output of dmesg?
Comment by Jake Godusky (jakebpg) - Friday, 13 April 2012, 20:08 GMT
Here's the requested output of dmesg.
   dmesg.txt (50.5 KiB)
Comment by Jake Godusky (jakebpg) - Wednesday, 18 April 2012, 23:26 GMT
I solved this error by making a change to /etc/rc.d/functions! P{roving that there is a problem with the functions script which I reported as a bug(bug number  FS#29496 )

And this is what corrected this error along with the error from bug #  FS#29496 !

Here's the fix to that got rid of this error which was claimed to NOT be a bug or syntax error which evidently is an error that causes more then just the 2 errors I've come across! Replace "<(findmnt" by "$(findmnt"

This fix was found in bug # FS#28331 .

People shouldn't be so quick to jump to conclusions with out FULLY investigating what the problem actually is based off of other bug reports closed claiming that the real problem lays with an AUR program of which I have NONE installed!

This not only frustrates the user but keeps actual bugs from being corrected when they are reported. And having a user receive or see the following on their bug report just makes things even worse
(Closed by Dave Reisner (falconindy)
Monday, 16 April 2012, 21:26 GMT
Reason for closing: Duplicate
Additional comments about closing: Duplicate of way too many bugs.

Well maybe there are WAY TO MANY BUGS BECAUSE THEY ARE NOT BEING FIXED AND SIMPLY IGNORED AS BEING THE USERS PROBLEM INSTEAD OF AN ACTUAL SYSTEM PROBLEM!
Comment by Dave Reisner (falconindy) - Wednesday, 18 April 2012, 23:37 GMT
Maybe you should learn how bash works before you go and claim that you've miraculously fixed this by causing the function not to actually perform its intended purpose.

<(command) runs the command inside the parenthesis and returns a named pipe (visible as, e.g. /dev/fd/63) containing the stdout of the program. This is formally known as process substitution.

$(command) runs the command inside the parenthesis and replaces the stdout of the command with a string. This is formally known as command substitution.

In the first case, we redirect the named pipe to the while loop. This is acceptable. A while loop can read from a file in this manner. In the second case, you're redirecting a string, assumed to be the name of a file (and unquoted no less) to the while loop.

Perhaps you should try running the command yourself and see what happens:

$ while read foo; do echo "$foo"; done < $(findmnt)
bash: $(findmnt): ambiguous redirect

Does that look right to you? I really have no idea why you think that code which only runs on shutdown is affecting your bootstrap, but feel free to continue and delude yourself into thinking that I'm closing all these bug reports for no apparent reason.
Comment by Jake Godusky (jakebpg) - Thursday, 19 April 2012, 00:16 GMT
Well I made that simple change and both of the bugs I reported are NO LONGER HAPPENING!

I rest my case!~

Evidently finding the real issue is NOT a priority!

Loading...