Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#29341 - [dbus-core] Missing dependancy for post install/remove

Attached to Project: Arch Linux
Opened by Rob (android_808) - Sunday, 08 April 2012, 19:25 GMT
Last edited by Andreas Radke (AndyRTR) - Monday, 09 April 2012, 14:32 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To Ionut Biru (wonder)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
Installation doesn't correctly run post_install/remove:
Unable to add/remove user/group.

Scripts make use of useradd and groupadd, which are owned by shadows. Unfortunately the package doesn't depend on them so they may not be installed prior to installation.

Without this stage, dbus fails to start.

https://bbs.archlinux.org/viewtopic.php?pid=1084500#p1084500

Additional info:
* At least 1.4.16-1 onwards.

Steps to reproduce:
Fresh install
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Monday, 09 April 2012, 14:32 GMT
Reason for closing:  Fixed
Additional comments about closing:  fixed in 1.4.20-2
Comment by Matthias Dienstbier (fs4000) - Sunday, 08 April 2012, 20:30 GMT
This is because of  FS#28576 .
Comment by Rob (android_808) - Monday, 09 April 2012, 08:12 GMT
DBUS depends on coreutils which in turn used to pull in shadow then.
I've posted another bug for avahi with same problem. avahi makes use of useradd in the same way dbus does, but also depends on dbus so it's shadow dependency would have been pulled in that way.

A fix in dbus-core would solve both for now, but a fix in both pacakges would prevent a repeat of this issue should dbus-core change in the future.

Comment by Jelle van der Waa (jelly) - Monday, 09 April 2012, 09:14 GMT
Nope, shadow is in base and it's expected that you have it installed
Comment by Matthias Dienstbier (fs4000) - Monday, 09 April 2012, 10:14 GMT
The real problem is that pacman won't know at install time that shadow has to be installed before dbus-core as it uses useradd and groupadd in its install script.
It seems this cannot happen with our installer but e.g. "pacman -S systemd base" will trigger this problem.
Comment by Ionut Biru (wonder) - Monday, 09 April 2012, 10:18 GMT
one can argue that systemd is unsupported and should be dropped.
Comment by Rob (android_808) - Monday, 09 April 2012, 10:30 GMT
this happened on fresh install with base + samba & lm_sensors selected

Loading...