Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#29340 - [linux] 3.3.1-1 wlan

Attached to Project: Arch Linux
Opened by Tevin (tevin) - Sunday, 08 April 2012, 18:37 GMT
Last edited by Tobias Powalowski (tpowa) - Monday, 16 April 2012, 14:28 GMT
Task Type Bug Report
Category Kernel
Status Closed
Assigned To Tobias Powalowski (tpowa)
Thomas Bächler (brain0)
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 54
Private No

Details

Description:
WPA2-PSK encrypted wifi connection failed in authentication(password was correct but can not get pass)


Additional info:
* package version: 3.3.1-1
* repeating as below in dmesg:
wlan0: authenticate with AP xx:xx:xx:xx:xx:xx
wlan0: authentication timeout (try 1)
wlan0: authentication timeout (try 2)
wlan0: authentication timeout (try 3)
wlan0: authenticate with AP xx:xx:xx:xx:xx:xx
wlan0: authentication timeout (try 1)
wlan0: authentication timeout (try 2)
wlan0: authentication timeout (try 3)

* Network controller: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) (rev 01)

Steps to reproduce:
Use kernel of this version
try to connect a WPA2-PSK encrypted hotspot
This task depends upon

Closed by  Tobias Powalowski (tpowa)
Monday, 16 April 2012, 14:28 GMT
Reason for closing:  Fixed
Additional comments about closing:  3.3.2-1
Comment by st.binder (nium) - Sunday, 08 April 2012, 19:45 GMT
Same here! ath9k regression on linux 3.3.1-1, no wifi connections. linux-3.2.14-1 was working.
reported in lkml: http://lkml.indiana.edu/hypermail/linux/kernel/1204.0/00885.html
and: http://www.spinics.net/lists/linux-wireless/msg87748.html
Comment by pluto9 (pluto9) - Monday, 09 April 2012, 03:32 GMT
I have the same problem. Atheros WLAN adapter doesn't work properly on the latest kernel 3.3.1-1. After downgrading to 3.2.14-1, it worked again.
Comment by Tevin (tevin) - Monday, 09 April 2012, 03:58 GMT
3.2.14-1 works
Comment by Eric Liang (etlgfx) - Monday, 09 April 2012, 05:05 GMT
Same issue here:
02:00.0 Network controller: Atheros Communications Inc. AR9485 Wireless Network Adapter (rev 01)

3.3.1 unable to connect, 3.2.13-1 works fine.

after the upgrade to 3.3.1 wpa_supplicant ends up blocking I/O, e.g. ps shows D Uninterruptible sleep (usually IO) on the process.

A kworker thread starts eating up 100% CPU (on 1 core) and I am unable to do most anything useful. ip addr hangs, sudo hangs, etc.
Comment by Ambrevar (Ambrevar) - Monday, 09 April 2012, 09:53 GMT
Same issue with Atheros AR9285 on kernel 3.3.1
wpa_supplicant times out when trying to connect to a WPA1 network. So the issue *does not only* affect WPA2 networks.
Previous kernels worked fine.
Comment by Ido van Verseveld (idovitz) - Monday, 09 April 2012, 11:57 GMT
Got that problem too AR9285
Comment by vladder (vladder) - Monday, 09 April 2012, 17:01 GMT
Same problem whith AR928 and kernel 3.3.1, 3.2.14-1 ok.
Comment by samae (samae) - Monday, 09 April 2012, 19:05 GMT
Same problem with AR9285, no WIFI at all. Works fine with previous kernel
Comment by Sergio Correia (sergio.correia) - Monday, 09 April 2012, 19:08 GMT
For me it starts working (AR9285), however if I disabled/re-enable wifi on the network manager of after a suspend/resume cycle, I get the following messages:

wlan0: authenticate with AP xx:xx:xx:xx:xx:xx
wlan0: authentication timeout (try 1)
wlan0: authentication timeout (try 2)
wlan0: authentication timeout (try 3)

If I rmmod/modprobe the ath9k module, it works again.
Comment by Alphazo (alphazo) - Monday, 09 April 2012, 20:08 GMT
Exact same issue with AR928X. 3.3.1 fails while 3.2.14-1 works ok (WPA2 network).
Comment by pierre (pierremx) - Tuesday, 10 April 2012, 06:44 GMT
Same problem with kernel 3.3.1. Return to 3.2.14-1 and wifi worked again.
Comment by William Sewell (Alty) - Wednesday, 11 April 2012, 11:52 GMT
I have this problem. How do I roll back to 3.2.14-1? Or do you think this will be fixed quite soon? In which case I'll wait.
Comment by Bartosz Chmura (chmurli) - Wednesday, 11 April 2012, 13:44 GMT
its not place for this, but you can download old packages from here:
http://arm.konnichi.com/search
than 'pacman -U package.xy'
Comment by Cezar (predatorgcc) - Wednesday, 11 April 2012, 13:54 GMT
I changed the kernel and should work on the LTS.
Comment by Tony Thedford (tonythed) - Thursday, 12 April 2012, 03:38 GMT
Same problem here.. downgrading from kernel 3.3.1-1 to kernel 3.2.13-1 (x86_64) fixes the problem.
Comment by Heiko Saul (_heiko_) - Thursday, 12 April 2012, 06:50 GMT
A temporary solution is to revert the patch that (re)introduced these problems: https://bbs.archlinux.org/viewtopic.php?id=139274
The patch is available here http://git.kernel.org/?p=linux/kernel/git/stable/linux-stable.git;a=patch;h=c1afdaff90538ef085b756454f12b29575411214

Please consider including this patch as long as this is not fixed in the kernel sources. Reading through the lkml (see link by st.binder) shows that this seems to be only a problem with linux-3.3.

Comment by Liao Haohui (liaohaohui) - Thursday, 12 April 2012, 12:08 GMT
Just updated from 3.3 to 3.3.1 on 11 April 2012 and I can't connect to my wifi router using ath9k chip. No problem using the LTS kernel 3.0.20.
Comment by Daniel Wallace (gtmanfred) - Thursday, 12 April 2012, 22:43 GMT Comment by Sergio Correia (sergio.correia) - Friday, 13 April 2012, 17:35 GMT
3.3.2 was just released, and the patch mentioned by Daniel Wallace was reverted; the next arch release should contain the fix, then :)
Comment by Heiko Saul (_heiko_) - Friday, 13 April 2012, 23:05 GMT
Tried 3.3.2. Seems to work.
Comment by Artur Meski (meartur) - Monday, 16 April 2012, 10:06 GMT
Works fine on 3.3.2-1-ARCH.

% uname -a
Linux deneb 3.3.2-1-ARCH #1 SMP PREEMPT Sat Apr 14 09:48:37 CEST 2012 x86_64 AMD FX(tm)-6100 Six-Core Processor AuthenticAMD GNU/Linux

Loading...