Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#29337 - [netcfg] WPA Authentication/Association Failed

Attached to Project: Arch Linux
Opened by Felipe Contreras (felipec) - Sunday, 08 April 2012, 13:21 GMT
Last edited by Eric Belanger (Snowman) - Tuesday, 30 April 2013, 01:03 GMT
Task Type Bug Report
Category Arch Projects
Status Closed
Assigned To Jouke Witteveen (jouke)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

Description:

When I try to connect to a Wi-Fi hotspot with no encryption I get this error. I can connect just fine using iwconfig/ip/dhcpcd by first switching to ad-hoc mode. I tried configuring the profile with ADHOC=yes, but I get the same error.

Versioon: 2.6.8-1

Log:

DEBUG: status reported to profile_up as:
DEBUG: Loading profile n9
DEBUG: Configuring interface wlan0
DEBUG: wireless_up stop_wpa wlan0
DEBUG: wireless_up start_wpa wlan0 /run/network//wpa.wlan0/wpa.conf nl80211,wext
DEBUG: wireless_up stop_wpa wlan0
DEBUG: wireless_up Configuration generated at /run/network//wpa.wlan0/wpa.conf
DEBUG: wireless_up ifup
DEBUG: wireless_up start_wpa wlan0 /run/network//wpa.wlan0/wpa.conf nl80211,wext
DEBUG: wireless_up wpa_check
DEBUG: wpa_cli -p /run/wpa_supplicant -i wlan0 status

> WPA Authentication/Association Failed
DEBUG: profile_up connect failed
This task depends upon

Closed by  Eric Belanger (Snowman)
Tuesday, 30 April 2013, 01:03 GMT
Reason for closing:  Won't fix
Additional comments about closing:  netcfg has been moved to AUR
Comment by Jacek Wojtkowski (jacek2v) - Tuesday, 10 April 2012, 06:49 GMT
Hi,

I have similar problem with authentication via wicd. Solution is revert kernel to 3.2.9 version.
I think this problem is associated with the network card Atheros AR9285: http://www.linuxquestions.org/questions/slackware-14/bad-password-wicd-kernel-3-3-1-wpa2-aes-atheros-ar9285-938748/
Comment by Felipe Contreras (felipec) - Tuesday, 10 April 2012, 16:49 GMT
Well, I have Atheros AR9485, and I'm using 3.2.13-1. Judging from that link, the issue reported is related with suspend/resume.

I'll try compiling my own kernel.
Comment by Felipe Contreras (felipec) - Wednesday, 11 April 2012, 00:15 GMT
Nope, the issue is still there on 3.2.9. I also tried different variations of the mentioned patch, none of them worked.

Also, for the record, I can connect to other networks that have encryption, but this one doesn't have it. I wonder why netcfg runs wpa_suplicant for non-encrypted networks.
Comment by Felipe Contreras (felipec) - Wednesday, 11 April 2012, 01:11 GMT
OK, I enabled debugging in wpa_supplicant and found this:

nl80211: Join IBSS failed: ret=-22 (Invalid argument)

Which lead me to this:

"Apparently the issue is that NM isn't always sending a starting frequency when attempting to create or join an Ad-Hoc network."

https://bugzilla.redhat.com/show_bug.cgi?id=699203#c10

So I tried this configuration:

SECURITY='wpa-configsection'
ADHOC=yes
CONFIGSECTION='
ssid="Nokia N9"
frequency=2412
mode=1
key_mgmt=NONE'

And this seems to work, however, I'm thinking the issue is in the nl80211 driver; why is there no default frequency? If no the driver, then netcfg should set a default frequency when ADHOC is defined, or better yet; avoid wpa_supplicant completely.
Comment by Jacek Wojtkowski (jacek2v) - Monday, 14 May 2012, 18:39 GMT
HI, Now is SOLVED for me. Kernel 3.3.5-1, wicd 1.7.2.4-2.
Comment by Felipe Contreras (felipec) - Sunday, 20 May 2012, 12:42 GMT
This is *not* fixed for me yet (netcfg).

I still need to manually set a default frequency. Somebody needs to do that when ADHOC=yes.

Right now it seems high levels do that (NetworkManager, wicd), but I'm thinking wpa_supplicant should that, or even the nl80211 driver. The old wext driver worked fine.

See:
http://w1.fi/bugz/show_bug.cgi?id=439
http://article.gmane.org/gmane.linux.network/226816
Comment by Dimitri Sabadie (skp) - Tuesday, 09 October 2012, 14:52 GMT
I got the same error here. It first appeared when I tried to join a MSCHAPV2 encrypted network, then it did it again on an open wireless network.
If someone can briefly gives me some directions I’d like to help to fix that.
Comment by Felipe Contreras (felipec) - Thursday, 29 November 2012, 16:50 GMT
Dimitri, as I said, you need to manually specify a frequence, or use the old wext driver.

This is still happening for me.

Loading...