Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#29277 - Nm-applet crashes with assertion `dest_width > 0' failed

Attached to Project: Arch Linux
Opened by Michal Kawalec (mkawalec) - Wednesday, 04 April 2012, 16:44 GMT
Last edited by Ionut Biru (wonder) - Tuesday, 24 April 2012, 08:00 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
nm-applet crashes after most recent update. Downgrading gdk-pixbuf to community (from testing) does not fix the problem. The log output is:
** (nm-applet:13490): WARNING **: Could not initialize NMClient /org/freedesktop/NetworkManager: Launch helper exited with unknown return code 1
** Message: applet now removed from the notification area
** Message: applet now embedded in the notification area
** Message: applet now removed from the notification area

(nm-applet:13490): GdkPixbuf-CRITICAL **: gdk_pixbuf_scale_simple: assertion `dest_width > 0' failed

** (nm-applet:13490): WARNING **: fetch_connections_done: error fetching connections: (25) Launch helper exited with unknown return code 1.

** (nm-applet:13490): WARNING **: Failed to register as an agent: (25) Launch helper exited with unknown return code 1
** Message: Starting applet secret agent because GNOME Shell disappeared

** (nm-applet:13490): WARNING **: Failed to register as an agent: (25) Launch helper exited with unknown return code 1


This task depends upon

Closed by  Ionut Biru (wonder)
Tuesday, 24 April 2012, 08:00 GMT
Reason for closing:  Not a bug
Comment by Jelle van der Waa (jelly) - Sunday, 08 April 2012, 10:13 GMT
So did you cherry pick from [testing]? If so, there is no bug
Comment by Jonas Jelten (TheJJ) - Sunday, 08 April 2012, 10:34 GMT
i've got the same error but my nm-applet works as it should, just all icons are missing.

** Message: applet now removed from the notification area
** Message: applet now embedded in the notification area

(nm-applet:13955): GdkPixbuf-CRITICAL **: gdk_pixbuf_scale_simple: assertion `dest_width > 0' failed

these are all messages i get from nm-applet of [testing]
Comment by Ionut Biru (wonder) - Sunday, 08 April 2012, 10:50 GMT
he doesn't have networkmanager daemon running.

as for icons, pacman -Qk and reinstall packages that have missing files.
Comment by Michal Kawalec (mkawalec) - Sunday, 08 April 2012, 15:54 GMT
No, I am using testing, I just tried downgrading this package to fix the problem.

I will have stable internet in 2 days, I will try to pacman -Qk and see the results.
Comment by Michal Kawalec (mkawalec) - Sunday, 08 April 2012, 15:56 GMT
This would be a very peculiar miss if I don't have networkmanager running, but I admit that it is possible. I will check that in two days.
Comment by Michal Kawalec (mkawalec) - Wednesday, 11 April 2012, 17:34 GMT
Hello,
I tried many times, and it seems that now the applet sometimes occupies a 1x1 px space somewhere on the tray, and sometimes it doesn't (or I am out of luck trying to find it). I tried pacman -Qk but it reports that the only package missing files is dmraid, which shouldn't be a problem. I uninstalled the network-manager-applet and installed network-manager-applet-git from AUR, still with no luck.
I will try gnome/kde later today and let you know.
Comment by Michal Kawalec (mkawalec) - Thursday, 12 April 2012, 08:10 GMT
So, after some more testing, to sum up:
1. The network-manager-applet is running and doing its job, though its icon is invisible and really small. It works in gnome3 through the native network management.
2. No packages are missing files but the icon is still missing.

I think that the priority is no longer critical at all, but do you know of any method of restoring the icon?
Comment by Ionut Biru (wonder) - Thursday, 12 April 2012, 08:14 GMT
do you have gnome-icon-theme and gnome-icon-theme-symbolic?
also do you use other icon theme?
Comment by Michal Kawalec (mkawalec) - Thursday, 12 April 2012, 08:22 GMT
I am normally using xmonad, so I don't really know what icon theme I am using. Gnome-tweak-tools says that I am using the 'gnome (default)' icon theme.
I reinstalled the gnome-icon-theme, but still no icon.

Comment by Ryan (Ozymandias_117) - Tuesday, 24 April 2012, 05:21 GMT
On my system, this is was caused because I had my system tray height too small. Increasing the size of trayer from 15 pixels to 18 made it display correctly again.
Comment by Michal Kawalec (mkawalec) - Tuesday, 24 April 2012, 07:03 GMT
Apparently, increasing the height fixes it on my system too. Thank you.

Loading...