Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#29264 - Recent kernels cause hard system freeze

Attached to Project: Arch Linux
Opened by cfr (cfr42) - Wednesday, 04 April 2012, 02:54 GMT
Last edited by Thomas Dziedzic (tomd123) - Wednesday, 04 April 2012, 14:43 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:

Recent kernels (3.2.1[23], for example) trigger apparently random hard system freezes forcing reboot by holding down power button. (Cannot switch to tty, kill X, get response from function keys etc.) Note that this laptop has no leds on keyboard so I cannot tell if, for example, capslock still has any effect or not.

The current LTS kernels do not exhibit the same problem.

The system is completely up to date (except for one or two things which have appeared as I've been filing this.) pacman -Syu was run a few hours ago.

Additional info:

* package version(s)
linux 3.2.13-1 (and previous recent kernels) but not the lts line
xf86-video-intel 2.18.0-1
intel-dri 8.0.2-1
xorg-server 1.12.0.901-1

* config and/or log files etc.
kernel.log - this is an excerpt showing two boots. The first uses 3.2.13-1 and the second the current LTS kernel. This is the only log file I can find which has anything even near the time of the freeze. There is nothing particular in errors.log (except a standard complaint about not finding sendmail), Xorg.0.log.old, acpid.log etc. I would however be happy to post anything which might be useful.

System specs:
Arch Linux | x86_64 | GPT | EFI boot
Lenovo x121e | Intel(R) Core(TM) i3-2367M CPU @ 1.40GHz GenuineIntel | Intel Centrino Wireless-N 1000 | US keyboard with Euro | 320G HDD

I'm not sure if this is related to other bugs. I couldn't find one which looked similar on closer inspection (e.g. similar symptoms but messages in logs I don't see or freezes but only with ipv6 which is disabled on my machine.)

I've included versions for the video drivers because I'm also seeing graphics corruption. This affects the LTS line as well but the problem is worse with the 3.2.+ kernels.

Steps to reproduce:

Boot a recent kernel. Work for a little bit - sorry, there's nothing in particular and no particular timeframe - and wait for everything to freeze. I had thought firefox was particularly likely to trigger this but tonight I was just working on LaTeX source in Kile. After I saved, that was it. I didn't see any graphics corruption though I'm seeing a bit now on the LTS kernel. But the freeze was just as hard.
This task depends upon

Closed by  Thomas Dziedzic (tomd123)
Wednesday, 04 April 2012, 14:43 GMT
Reason for closing:  None
Additional comments about closing:  op requested to close this bug

Loading...