Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#29262 - [cairo] Slow bitmap font rendering with cairo-1.12.0

Attached to Project: Arch Linux
Opened by Patrick (freethebee) - Tuesday, 03 April 2012, 20:46 GMT
Last edited by Andreas Radke (AndyRTR) - Saturday, 07 April 2012, 16:34 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To Andreas Radke (AndyRTR)
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No


Bitmap font rendering in gtk applications is slow with Cairo 1.12.0-2. For example gvim and Dina (font) leads to slow buildup of the screen compared to qvim (qt) or gvim with a ttf font. The same problem also occurs for xfce-terminal, but not in urxvt. In htop it shows that xorg goes to high cpu load when making changes on the screen. With cairo-xcb 1.10.2 from AUR this problem does not occur, but cairo-xcb 1.12.0-1 from AUR does have the same problem.

Additional info:
Cairo 1.12.0-2

Steps to reproduce:
Opening gvim with a bitmap font like Dina, shows a slow buildup of the screen. Also making changes like toggling NERDtree or adding or removing menu toolbars are slow. It is also visible when switching to a desktop with gvim open. The problem is more obvious when the app window is big.
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Saturday, 07 April 2012, 16:34 GMT
Reason for closing:  Upstream
Additional comments about closing:  I'm aware of the upstream issue.
Comment by xduugu (xduugu) - Thursday, 05 April 2012, 10:36 GMT
Are you using the ati or nouveau open source driver?
Comment by Patrick (freethebee) - Friday, 06 April 2012, 07:37 GMT
No, I use the nvidia driver.
Comment by Andreas Radke (AndyRTR) - Friday, 06 April 2012, 07:40 GMT
there are already lots of bug reports about new cairo upstream. please check if that has been talked there already or report it there.
Comment by Patrick (freethebee) - Friday, 06 April 2012, 08:12 GMT
Ok, I will check the upstream.
Comment by Andreas Radke (AndyRTR) - Saturday, 07 April 2012, 16:34 GMT