Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#29256 - [linux] 3.3.0-1 panics on /etc/rc.d/bluetooth restart with BT audio

Attached to Project: Arch Linux
Opened by Jonathan Hudson (stronnag) - Tuesday, 03 April 2012, 16:55 GMT
Last edited by Tobias Powalowski (tpowa) - Wednesday, 23 May 2012, 13:14 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Tobias Powalowski (tpowa)
Thomas Bächler (brain0)
Architecture x86_64
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No


Description: my BT headset fails to work with the testing 3.3 kernel (x86_64). It had previously worked fine. When the device is enabled, it is never listed in audio devices.

Restarting bluetoothd results in a hard kernel crash. Oops attached.

Additional info:

kernel package: 3.3.0-1-ARCH
x86_64 AMD Phenom(tm) II X6 1055T Processor AuthenticAMD GNU/Linux

To reproduce:

# rc.d restart bluetooth
This task depends upon

Closed by  Tobias Powalowski (tpowa)
Wednesday, 23 May 2012, 13:14 GMT
Reason for closing:  Fixed
Additional comments about closing:  3.4.0-1
Comment by Jonathan Hudson (stronnag) - Tuesday, 03 April 2012, 17:51 GMT
BT sound works again in 3.3.1-1, so hopeful that the panics are over
Comment by Charles Briere (flatzo) - Wednesday, 25 April 2012, 12:40 GMT
Same problem with kernel 3.3.2-1. Any way I could submit the log through re-open request ?

Edit : Log attached
Comment by Andrea Scarpino (BaSh) - Wednesday, 25 April 2012, 12:40 GMT
Please report this upstream
Comment by Robert Buhren (RobertBuhren) - Wednesday, 16 May 2012, 08:25 GMT
I have a very similiar problem:
As soon as i try to switch off my bluetooth with e.g. "rfkill block 1". Kernel is : 3.3.6-1-ARCH

If i should report this bug upstream, can you give me a hint where exactly :)?

Comment by Thomas Bächler (brain0) - Wednesday, 16 May 2012, 11:15 GMT
I've had random panics and oopses on shutdown as well since 3.3.0, can't really reproduce.
Comment by Fortunato Ventre (voRia) - Wednesday, 16 May 2012, 11:50 GMT
Same problem here on my Samsung NC10 netbook.
It happens every time I restart/stop the bluetooth daemon while a bluetooth device is attached.
Getting this problem since 3.3.0 as well, but it seems fixed in the latest 3.4-rc7 (just tested with the package linux-mainline available in AUR).