Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#29240 - [linux] ite-cir kernel panic at boot-up

Attached to Project: Arch Linux
Opened by oblique (oblique) - Monday, 02 April 2012, 20:21 GMT
Last edited by Tobias Powalowski (tpowa) - Monday, 11 June 2012, 13:17 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Tobias Powalowski (tpowa)
Thomas B├Ąchler (brain0)
Architecture All
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 4
Private No


i was getting kernel panic when udev loads the modules at boot-up

Additional info:
linux >= 3.2

How to fix it:
the problem is caused by IRQ remapping subsystem which is experimental.
unset CONFIG_IRQ_REMAP from configs.
This task depends upon

Closed by  Tobias Powalowski (tpowa)
Monday, 11 June 2012, 13:17 GMT
Reason for closing:  Fixed
Additional comments about closing:  3.4.x
Comment by Tobias Powalowski (tpowa) - Wednesday, 04 April 2012, 06:26 GMT
IRQ_REMAP is also enabled on fedora, probably better to debug which module causes the issue to track it down.
Comment by oblique (oblique) - Thursday, 05 April 2012, 10:45 GMT
i found that if CONFIG_IRQ_REMAP (CONFIG_INTR_REMAP in <= 3.1) + CONFIG_X86_X2APIC are enabled the result is kernel panic..
and this bug exists also in 2.6.30 .. i didn't check in < 2.6.30 yet.. if you disable CONFIG_X86_X2APIC everything is ok..
Comment by Tobias Powalowski (tpowa) - Thursday, 05 April 2012, 12:32 GMT
Fedora enables also X2APIC
Comment by Tobias Powalowski (tpowa) - Thursday, 05 April 2012, 12:46 GMT
Try one of those kernel parameters:
enable Interrupt Remapping (default)

disable Interrupt Remapping

disable Source ID checking

BIOS x2APIC opt-out request will be ignored
Comment by oblique (oblique) - Thursday, 05 April 2012, 16:27 GMT
only with intremap=off i managed to boot, with intremap=nosid or intremap=no_x2apic_optout i have kernel panic... i will try to find the exact problem in the kernel code..
Comment by oblique (oblique) - Thursday, 05 April 2012, 16:28 GMT
btw, my cpu supports x2apic
Comment by KaiSVK (KaiSVK) - Friday, 06 April 2012, 17:06 GMT
I think I have this one too. After upgrade all of the kernels 3.0lts, 3.2, 3.3 are affected with this. The only way for me to boot is to do acpi=off. Another thing is I compiled vanilla 3.4rc1 with the ARCH .config (just copied it). It can boot and everything is ok, but as I connect to wifi it crashes into kernel panic.

I would try those option you mention.
Comment by Jiri Suchan (yedpodtrzitko) - Monday, 09 April 2012, 00:49 GMT
Suffer with this one as well. Last bootable kernel is 3.2.8. Using >=3.2.9 has kernel panic.

I'm able to boot with acpi=off/noirq or noapic, but machine froze sooner or later anyway.
Comment by David Runge (davezerave) - Wednesday, 18 April 2012, 22:02 GMT
Hmm... having the same issue here I guess.
Last bootable kernel is linux-3.2.7. Everything above dies...
Booting with acpi=off "works", but then the nvidia driver crashes.

Is this "just" a hardware related problem? Seems Dell XPS' are suffering from it:
I'm running newer kernel versions on an older machine that doesn't have these problems... it's not a laptop though.
Comment by David Runge (davezerave) - Monday, 23 April 2012, 09:35 GMT
Okay, there is a solution for me so far.
I've found the responsible module: ite_cir. Blacklisting it in /etc/modprobe.d/*.conf helped!

I've tried all the intremap settings but they all led to kernel panic... related to ite_cir.
Hope this helps track down the issue. (for intremap=nosid/off/no_x2apic_optout)
Comment by Tobias Powalowski (tpowa) - Monday, 23 April 2012, 09:48 GMT
This should be brought to kernel bugzilla then.
Comment by David Runge (davezerave) - Monday, 23 April 2012, 10:43 GMT
Found a related bug for upstream tracking:
Comment by Giorgio (uastasi) - Monday, 23 April 2012, 17:16 GMT
Blacklisting ite_cir works for me too with linux-3.3.2-ARCH
Comment by Tobias Powalowski (tpowa) - Wednesday, 23 May 2012, 13:17 GMT