Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#29229 - [mkinitcpio] ERROR: file not found: `/lib/modprobe.d/usb-load-ehci-first.conf'

Attached to Project: Arch Linux
Opened by xduugu (xduugu) - Monday, 02 April 2012, 00:11 GMT
Last edited by Dave Reisner (falconindy) - Wednesday, 04 April 2012, 00:31 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To Dave Reisner (falconindy)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

Description:
mkinitcpio complains about about a missing file that was moved to /usr/lib in the latest filesystem package.

-> Parsing hook: [base]
==> ERROR: file not found: `/lib/modprobe.d/usb-load-ehci-first.conf'

Additional info:
* mkinitcpio 0.8.5-2
* filesystem 2012.2-4

Fix:
Adjust line 36 in file /usr/lib/initcpio/install/base to point to /usr/lib instead of /lib.
This task depends upon

Closed by  Dave Reisner (falconindy)
Wednesday, 04 April 2012, 00:31 GMT
Reason for closing:  Fixed
Additional comments about closing:  mkinitcpio 0.8.6
Comment by xduugu (xduugu) - Monday, 02 April 2012, 00:12 GMT
I was too quick. It's testing, of course, not 'Packages: Extra'.
Comment by Dave Reisner (falconindy) - Monday, 02 April 2012, 02:10 GMT
It's already fixed in git. I'll likely be doing a proper release in a week -- if you rely on this rule, just add it to the FILES= var in your config.
Comment by Alexandre (alexcortes) - Monday, 02 April 2012, 04:13 GMT
I also have issues using stable version of filesystem and mkinitcpio togheter with udev-181-9 from testing. I can't boot if I generate a initramfs with any of this testing packages installed.

udev-181-9
mkinitcpio-0.8.5-2
filesystem-2012.2-4
Comment by Dave Reisner (falconindy) - Monday, 02 April 2012, 09:51 GMT
Partial upgrades are not supported, and in particular, testing is all or none. Your issue is entirely unrelated to this bug report.

Loading...