Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#29218 - [firefox] Graphics artifacts / glitches with cairo-1.12.0-1

Attached to Project: Arch Linux
Opened by Ifai Gios (ifaigios) - Sunday, 01 April 2012, 10:40 GMT
Last edited by Jan de Groot (JGC) - Tuesday, 03 April 2012, 14:15 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

Description:

When using cairo-1.12.0-1 from [testing], random artifacts / glitches appear in normal Firefox usage (see attached screenshot). Downgrading to cairo-1.10.2-3 solves the problem.

01:05.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI RS780M/RS780MN [Mobility Radeon HD 3200 Graphics] using xf86-video-ati-6.14.4-2

Additional info:
* package versions: firefox-11.0-2, cairo-1.12.0-1

Steps to reproduce:

Permorm system upgrade with [testing] repository enabled / Install cairo-1.12.0-1 and start Firefox.
This task depends upon

Closed by  Jan de Groot (JGC)
Tuesday, 03 April 2012, 14:15 GMT
Reason for closing:  Fixed
Comment by Andreas Radke (AndyRTR) - Sunday, 01 April 2012, 15:11 GMT
Try as a workaround this your xorg.conf device section. It's a known upstream issue.

Option "EXAPixmaps" "off"
Comment by Kevin (anonymous_user) - Sunday, 01 April 2012, 16:30 GMT
cairo 1.12.0-2 was released a short while ago, might want to try it out.
Comment by alex (kabolt) - Monday, 02 April 2012, 09:58 GMT
I had the artifacts too.
But firefox 11.0-3 fix it. Cairo seems to be the problem
Comment by Ifai Gios (ifaigios) - Monday, 02 April 2012, 16:45 GMT
With cairo-1.12.0-3 and firefox-11.0-3 the issue seems fixed. Please close this bug, and thanks for the immediate resolution.

Loading...