Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#29207 - [gnome-settings-daemon] crash with cairo-1.12.0-1

Attached to Project: Arch Linux
Opened by Otto Allmendinger (OttoA) - Saturday, 31 March 2012, 20:48 GMT
Last edited by Jan de Groot (JGC) - Sunday, 01 April 2012, 19:56 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To Ionut Biru (wonder)
Jan Steffens (heftig)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Gnome 3.2.2 crashes with cairo-1.12.0-1 from [testing], including gdm

reproducible on my i686 default system as well as in a i686 virtual machine

The gnome-shell starts fine, but the gnome-settings-daemon crashes in the background, producing the "Something has gone wrong" screen.

from /var/log/gdm/:0-greeter.log


gnome-session[1716]: DEBUG(+): GsmAutostartApp: (pid:1731) done (signal:11)
gnome-session[1716]: WARNING: Application 'gnome-settings-daemon.desktop' killed by signal


downgrade to cairo-1.10.2-3 fixes the problem
This task depends upon

Closed by  Jan de Groot (JGC)
Sunday, 01 April 2012, 19:56 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed with 1.12.0-2, can't reproduce crashes anymore.
Comment by Jonathan Hudson (stronnag) - Sunday, 01 April 2012, 07:09 GMT
Exactly the same on x86_64 (cairo 1.12.0-1 on ati). As for the OP, downgrading fixes it.
Comment by Ionut Biru (wonder) - Sunday, 01 April 2012, 08:20 GMT
can you compile gnome-settings-daemon and cairo with debug symbols and try to get a backtrace?

https://wiki.archlinux.org/index.php/Debug_-_Getting_Traces#One_package_settings_only

kill gnome-settings-daemon two times, you will get the fail whail window but you can close it with alt+f4
then run
gdb /usr/lib/gnome-settings-daemon/gnome-settings-daemon
run
Comment by Jan de Groot (JGC) - Sunday, 01 April 2012, 09:04 GMT
It's not only gnome-settings-daemon that crashes, flashplugin also crashes, and in many cases it takes firefox with it.
Comment by Jonathan Hudson (stronnag) - Sunday, 01 April 2012, 11:11 GMT
Here's a trace from x86_64 (cairo 1.12.0-1 on ati). Do I need XCB ?
Comment by Ionut Biru (wonder) - Sunday, 01 April 2012, 11:23 GMT
better recompile gtk3 and glib2 as well with debug and get another trace. Then please submit a bug in cairo bugtracker and paste the link in here so we can can follow.
Comment by Jonathan Hudson (stronnag) - Sunday, 01 April 2012, 12:52 GMT
Upstream bug, with full stack trace https://bugs.freedesktop.org/show_bug.cgi?id=48159
Comment by Jan Steffens (heftig) - Sunday, 01 April 2012, 14:10 GMT
Try rebuilding cairo with --disable-xlib-xcb
Comment by Jonathan Hudson (stronnag) - Sunday, 01 April 2012, 14:13 GMT
Will do (and the bug does not occur on one of the previously afflcited machines after upgrading to gnome 3.4 / gtk 3.4 (but this is not really a solution given the maturity of Arch's Gnome 3.4 at the moment).
Comment by Jonathan Hudson (stronnag) - Sunday, 01 April 2012, 14:45 GMT
Rebuilding with --disable-xlib-xcb also fixes the problem.
Comment by Andreas Radke (AndyRTR) - Sunday, 01 April 2012, 15:13 GMT
Cairo 1.12.0-2 has --disable-xlib-xcb applied. Can we close this one?

Loading...