Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#29202 - [gnome-control-center] can't start in version 3.4 (gnome-unstable)

Attached to Project: Arch Linux
Opened by alex (kabolt) - Saturday, 31 March 2012, 14:39 GMT
Last edited by Jan de Groot (JGC) - Friday, 09 November 2012, 13:44 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To Ionut Biru (wonder)
Jan Steffens (heftig)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 43
Private No

Details

Description:
gnome-control-center crashes if I try to start it. I use the free ati stuff and a 64 bit system. I have no clue what it is so I include the backtrace:


*** glibc detected *** gnome-control-center: free(): invalid pointer: 0x00007fe0bbc094d8 ***
======= Backtrace: =========
/lib/libc.so.6(+0x78e66)[0x7fe0dc926e66]
/usr/lib/libstdc++.so.6(_ZNSs7reserveEm+0x6a)[0x7fe0c470044a]
/usr/lib/libstdc++.so.6(_ZNSs6appendEPKcm+0xf0)[0x7fe0c4700740]
/usr/lib/xorg/modules/dri/r600_dri.so(_ZN4llvm3sys13getHostTripleEv+0xbe)[0x7fe0bd05767e]
/usr/lib/xorg/modules/dri/r600_dri.so(_ZN4llvm13EngineBuilder12selectTargetEPNS_6ModuleENS_9StringRefES3_RKNS_15SmallVectorImplISsEENS_5Reloc5ModelENS_9CodeModel5ModelEPSs+0x368)[0x7fe0bc97fc88]
/usr/lib/xorg/modules/dri/r600_dri.so(_ZN4llvm13EngineBuilder6createEv+0xad)[0x7fe0bc97345d]
/usr/lib/xorg/modules/dri/r600_dri.so(LLVMCreateJITCompilerForModule+0x9b)[0x7fe0bc97f0fb]
/usr/lib/xorg/modules/dri/r600_dri.so(+0x413e52)[0x7fe0bc924e52]
/usr/lib/xorg/modules/dri/r600_dri.so(+0x413f3b)[0x7fe0bc924f3b]
/usr/lib/xorg/modules/dri/r600_dri.so(+0x393bc5)[0x7fe0bc8a4bc5]
/usr/lib/xorg/modules/dri/r600_dri.so(+0x2afcfd)[0x7fe0bc7c0cfd]
/usr/lib/xorg/modules/dri/r600_dri.so(+0x2ae745)[0x7fe0bc7bf745]
/usr/lib/xorg/modules/dri/r600_dri.so(+0x1fecfb)[0x7fe0bc70fcfb]
/usr/lib/xorg/modules/dri/r600_dri.so(+0x1ed155)[0x7fe0bc6fe155]
/usr/lib/xorg/modules/dri/r600_dri.so(+0x1c26f5)[0x7fe0bc6d36f5]
/usr/lib/xorg/modules/dri/r600_dri.so(+0x1c280d)[0x7fe0bc6d380d]
/usr/lib/libGL.so.1(+0x44b53)[0x7fe0c694eb53]
/usr/lib/libGL.so.1(+0x1e2fe)[0x7fe0c69282fe]
/usr/lib/libGL.so.1(glXCreateNewContext+0x2a)[0x7fe0c692852a]
/usr/lib/libcogl.so.9(+0x64147)[0x7fe0be279147]
/usr/lib/libcogl.so.9(cogl_display_setup+0x23)[0x7fe0be2368c3]
/usr/lib/libcogl.so.9(cogl_renderer_check_onscreen_template+0x69)[0x7fe0be236129]
/usr/lib/libclutter-1.0.so.0(+0x2f5fd)[0x7fe0be6d85fd]
/usr/lib/libclutter-1.0.so.0(+0x5e539)[0x7fe0be707539]
/usr/lib/libclutter-1.0.so.0(+0x75606)[0x7fe0be71e606]
/usr/lib/libclutter-1.0.so.0(+0x80cfa)[0x7fe0be729cfa]
/usr/lib/libclutter-1.0.so.0(+0x80f3e)[0x7fe0be729f3e]
/usr/lib/libglib-2.0.so.0(g_option_context_parse+0x3b7)[0x7fe0dd1f76f7]
/usr/lib/libclutter-1.0.so.0(clutter_init+0xd4)[0x7fe0be72a1f4]
/usr/lib/libcheese-gtk.so.21(cheese_gtk_init+0x24)[0x7fe0bf4a55e4]
/usr/lib/control-center-1/panels/libuser-accounts.so(g_io_module_load+0x33)[0x7fe0bfd0f283]
/usr/lib/libgio-2.0.so.0(+0x5ae06)[0x7fe0dd741e06]
/usr/lib/libgobject-2.0.so.0(g_type_module_use+0x81)[0x7fe0dd4cc251]
/usr/lib/libgio-2.0.so.0(g_io_modules_load_all_in_directory_with_scope+0x84)[0x7fe0dd7421e4]
gnome-control-center[0x40975a]
/usr/lib/libgobject-2.0.so.0(g_type_create_instance+0x117)[0x7fe0dd4c92a7]
/usr/lib/libgobject-2.0.so.0(+0x15018)[0x7fe0dd4ae018]
/usr/lib/libgobject-2.0.so.0(g_object_newv+0x781)[0x7fe0dd4afad1]
/usr/lib/libgobject-2.0.so.0(g_object_new+0xec)[0x7fe0dd4b011c]
gnome-control-center(main+0x72)[0x407b02]
/lib/libc.so.6(__libc_start_main+0xed)[0x7fe0dc8cf38d]
gnome-control-center[0x407bb1]
======= Memory map: ========
00400000-00412000 r-xp 00000000 fe:02 2888209 /usr/bin/gnome-control-center
00611000-00612000 r--p 00011000 fe:02 2888209 /usr/bin/gnome-control-center
00612000-00613000 rw-p 00012000 fe:02 2888209 /usr/bin/gnome-control-center
01341000-0182d000 rw-p 00000000 00:00 0 [heap]
7fe0bb3b4000-7fe0bb3d5000 rw-p 00000000 00:00 0
7fe0bb3d5000-7fe0bb3d6000 ---p 00000000 00:00 0
7fe0bb3d6000-7fe0bbd10000 rw-p 00000000 00:00 0
7fe0bbd10000-7fe0bbd11000 ---p 00000000 00:00 0
7fe0bbd11000-7fe0bc511000 rw-p 00000000 00:00 0
7fe0bc511000-7fe0bd312000 r-xp 00000000 fe:02 3016094 /usr/lib/xorg/modules/dri/r600_dri.so
7fe0bd312000-7fe0bd512000 ---p 00e01000 fe:02 3016094 /usr/lib/xorg/modules/dri/r600_dri.so
7fe0bd512000-7fe0bd54b000 r--p 00e01000 fe:02 3016094 /usr/lib/xorg/modules/dri/r600_dri.so
7fe0bd54b000-7fe0bd593000 rw-p 00e3a000 fe:02 3016094 /usr/lib/xorg/modules/dri/r600_dri.so
7fe0bd593000-7fe0bd77b000 rw-p 00000000 00:00 0
7fe0bd77b000-7fe0bd780000 r-xp 00000000 fe:02 2907198 /usr/lib/libxcb-util.so.0.0.0
7fe0bd780000-7fe0bd980000 ---p 00005000 fe:02 2907198 /usr/lib/libxcb-util.so.0.0.0
7fe0bd980000-7fe0bd981000 rw-p 00005000 fe:02 2907198 /usr/lib/libxcb-util.so.0.0.0
7fe0bd981000-7fe0bd989000 r-xp 00000000 fe:02 2906801 /usr/lib/libstartup-notification-1.so.0.0.0
7fe0bd989000-7fe0bdb89000 ---p 00008000 fe:02 2906801 /usr/lib/libstartup-notification-1.so.0.0.0
7fe0bdb89000-7fe0bdb8a000 rw-p 00008000 fe:02 2906801 /usr/lib/libstartup-notification-1.so.0.0.0
7fe0bdb8a000-7fe0bdbbd000 r-xp 00000000 fe:02 2905839 /usr/lib/libgsttag-0.10.so.0.25.0
7fe0bdbbd000-7fe0bddbc000 ---p 00033000 fe:02 2905839 /usr/lib/libgsttag-0.10.so.0.25.0
7fe0bddbc000-7fe0bddbe000 r--p 00032000 fe:02 2905839 /usr/lib/libgsttag-0.10.so.0.25.0
7fe0bddbe000-7fe0bddbf000 rw-p 00034000 fe:02 2905839 /usr/lib/libgsttag-0.10.so.0.25.0
7fe0bddbf000-7fe0bddc3000 r-xp 00000000 fe:02 1707801 /lib/libattr.so.1.1.0
7fe0bddc3000-7fe0bdfc2000 ---p 00004000 fe:02 1707801 /lib/libattr.so.1.1.0
7fe0bdfc2000-7fe0bdfc3000 rw-p 00003000 fe:02 1707801 /lib/libattr.so.1.1.0
7fe0bdfc3000-7fe0be011000 r-xp 00000000 fe:02 2891956 /usr/lib/libgee.so.2.0.0
7fe0be011000-7fe0be211000 ---p 0004e000 fe:02 2891956 /usr/lib/libgee.so.2.0.0
7fe0be211000-7fe0be214000 r--p 0004e000 fe:02 2891956 /usr/lib/libgee.so.2.0.0
7fe0be214000-7fe0be215000 rw-p 00051000 fe:02 2891956 /usr/lib/libgee.so.2.0.0
7fe0be215000-7fe0be29b000 r-xp 00000000 fe:02 2920742 /usr/lib/libcogl.so.9.1.0
7fe0be29b000-7fe0be49b000 ---p 00086000 fe:02 2920742 /usr/lib/libcogl.so.9.1.0
7fe0be49b000-7fe0be49f000 r--p 00086000 fe:02 2920742 /usr/lib/libcogl.so.9.1.0
7fe0be49f000-7fe0be4a1000 rw-p 0008a000 fe:02 2920742 /usr/lib/libcogl.so.9.1.0
7fe0be4a1000-7fe0be4a8000 r-xp 00000000 fe:02 2920743 /usr/lib/libcogl-pango.so.0.0.0
7fe0be4a8000-7fe0be6a7000 ---p 00007000 fe:02 2920743 /usr/lib/libcogl-pango.so.0.0.0
7fe0be6a7000-7fe0be6a8000 r--p 00006000 fe:02 2920743 /usr/lib/libcogl-pango.so.0.0.0
7fe0be6a8000-7fe0be6a9000 rw-p 00007000 fe:02 2920743 /usr/lib/libcogl-pango.so.0.0.0
7fe0be6a9000-7fe0be7c9000 r-xp 00000000 fe:02 2920758 /usr/lib/libclutter-1.0.so.0.1000.0
7fe0be7c9000-7fe0be9c8000 ---p 00120000 fe:02 2920758 /usr/lib/libclutter-1.0.so.0.1000.0
7fe0be9c8000-7fe0be9cc000 r--p 0011f000 fe:02 2920758 /usr/lib/libclutter-1.0.so.0.1000.0
7fe0be9cc000-7fe0be9ce000 rw-p 00123000 fe:02 2920758 /usr/lib/libclutter-1.0.so.0.1000.0
7fe0be9ce000-7fe0be9d0000 rw-p 00000000 00:00 0
7fe0be9d0000-7fe0be9db000 r-xp 00000000 fe:02 2911985 /usr/lib/libclutter-gtk-1.0.so.0.0.0
7fe0be9db000-7fe0bebda000 ---p 0000b000 fe:02 2911985 /usr/lib/libclutter-gtk-1.0.so.0.0.0
7fe0bebda000-7fe0bebdb000 r--p 0000a000 fe:02 2911985 /usr/lib/libclutter-gtk-1.0.so.0.0.0
7fe0bebdb000-7fe0bebdc000 rw-p 0000b000 fe:02 2911985 /usr/lib/libclutter-gtk-1.0.so.0.0.0
7fe0bebdc000-7fe0bec71000 r-xp 00000000 fe:02 2910756 /usr/lib/libmx-1.0.so.2.401.0
7fe0bec71000-7fe0bee70000 ---p 00095000 fe:02 2910756 /usr/lib/libmx-1.0.so.2.401.0
7fe0bee70000-7fe0bee71000 r--p 00094000 fe:02 2910756 /usr/lib/libmx-1.0.so.2.401.0
7fe0bee71000-7fe0bee74000 rw-p 00095000 fe:02 2910756 /usr/lib/libmx-1.0.so.2.401.0
7fe0bee74000-7fe0bee87000 r-xp 00000000 fe:02 2904469 /usr/lib/libclutter-gst-1.0.so.0.504.0
7fe0bee87000-7fe0bf087000 ---p 00013000 fe:02 2904469 /usr/lib/libclutter-gst-1.0.so.0.504.0
7fe0bf087000-7fe0bf088000 r--p 00013000 fe:02 2904469 /usr/lib/libclutter-gst-1.0.so.0.504.0
7fe0bf088000-7fe0bf089000 rw-p 00014000 fe:02 2904469 /usr/lib/libclutter-gst-1.0.so.0.504.0
7fe0bf089000-7fe0bf08a000 rw-p 00000000 00:00 0
7fe0bf08a000-7fe0bf08e000 r-xp 00000000 fe:02 1704075 /lib/libcap.so.2.22
7fe0bf08e000-7fe0bf28d000 ---p 00004000 fe:02 1704075 /lib/libcap.so.2.22
7fe0bf28d000-7fe0bf28e000 rw-p 00003000 fe:02 1704075 /lib/libcap.so.2.22
7fe0bf28e000-7fe0bf29d000 r-xp 00000000 fe:02 2896031 /usr/lib/libcheese.so.3.2.3
7fe0bf29d000-7fe0bf49c000 ---p 0000f000 fe:02 2896031 /usr/lib/libcheese.so.3.2.3
7fe0bf49c000-7fe0bf49d000 r--p 0000e000 fe:02 2896031 /usr/lib/libcheese.so.3.2.3
7fe0bf49d000-7fe0bf49e000 rw-p 0000f000 fe:02 2896031 /usr/lib/libcheese.so.3.2.3
7fe0bf49e000-7fe0bf4aa000 r-xp 00000000 fe:02 2902641 /usr/lib/libcheese-gtk.so.21.1.3
7fe0bf4aa000-7fe0bf6a9000 ---p 0000c000 fe:02 2902641 /usr/lib/libcheese-gtk.so.21.1.3
7fe0bf6a9000-7fe0bf6aa000 r--p 0000b000 fe:02 2902641 /usr/lib/libcheese-gtk.so.21.1.3
7fe0bf6aa000-7fe0bf6ab000 rw-p 0000c000 fe:02 2902641 /usr/lib/libcheese-gtk.so.21.1.3
7fe0bf6ab000-7fe0bf6b3000 r-xp 00000000 fe:02 1709913 /lib/libcrypt-2.15.so
7fe0bf6b3000-7fe0bf8b2000 ---p 00008000 fe:02 1709913 /lib/libcrypt-2.15.so
7fe0bf8b2000-7fe0bf8b3000 r--p 00007000 fe:02 1709913 /lib/libcrypt-2.15.so
7fe0bf8b3000-7fe0bf8b4000 rw-p 00008000 fe:02 1709913 /lib/libcrypt-2.15.so
7fe0bf8b4000-7fe0bf8e2000 rw-p 00000000 00:00 0
7fe0bf8e2000-7fe0bf8e4000 r-xp 00000000 fe:02 2898991 /usr/lib/libsystemd-daemon.so.0.0.1
7fe0bf8e4000-7fe0bfae4000 ---p 00002000 fe:02 2898991 /usr/lib/libsystemd-daemon.so.0.0.1
7fe0bfae4000-7fe0bfae5000 r--p 00002000 fe:02 2898991 /usr/lib/libsystemd-daemon.so.0.0.1
7fe0bfae5000-7fe0bfae6000 rw-p 00003000 fe:02 2898991 /usr/lib/libsystemd-daemon.so.0.0.1
7fe0bfae6000-7fe0bfaef000 r-xp 00000000 fe:02 2913298 /usr/lib/libsystemd-login.so.0.2.1
7fe0bfaef000-7fe0bfcef000 ---p 00009000 fe:02 2913298 /usr/lib/libsystemd-login.so.0.2.1
7fe0bfcef000-7fe0bfcf0000 r--p 00009000 fe:02 2913298 /usr/lib/libsystemd-login.so.0.2.1
7fe0bfcf0000-7fe0bfcf1000 rw-p 0000a000 fe:02 2913298 /usr/lib/libsystemd-login.so.0.2.1
7fe0bfcf1000-7fe0bfd1a000 r-xp 00000000 fe:02 3028411 /usr/lib/control-center-1/panels/libuser-accounts.so
7fe0bfd1a000-7fe0bff1a000 ---p 00029000 fe:02 3028411 /usr/lib/control-center-1/panels/libuser-accounts.so
7fe0bff1a000-7fe0bff1b000 r--p 00029000 fe:02 3028411 /usr/lib/control-center-1/panels/libuser-accounts.so
7fe0bff1b000-7fe0bff1d000 rw-p 0002a000 fe:02 3028411 /usr/lib/control-center-1/panels/libuser-accounts.so
7fe0bff1d000-7fe0bff28000 r-xp 00000000 fe:02 3028398 /usr/lib/control-center-1/panels/libkeyboard.so
7fe0bff28000-7fe0c0128000 ---p 0000b000 fe:02 3028398 /usr/lib/control-center-1/panels/libkeyboard.so
7fe0c0128000-7fe0c0129000 r--p 0000b000 fe:02 3028398 /usr/lib/control-center-1/panels/libkeyboard.so
7fe0c0129000-7fe0c012a000 rw-p 0000c000 fe:02 3028398 /usr/lib/control-center-1/panels/libkeyboard.so
7fe0c012a000-7fe0c014d000 r-xp 00000000 fe:02 2907834 /usr/lib/libxkbfile.so.1.0.2
7fe0c014d000-7fe0c034d000 ---p 00023000 fe:02 2907834 /usr/lib/libxkbfile.so.1.0.2
7fe0c034d000-7fe0c034e000 r--p 00023000 fe:02 2907834 /usr/lib/libxkbfile.so.1.0.2
7fe0c034e000-7fe0c034f000 rw-p 00024000 fe:02 2907834 /usr/lib/libxkbfile.so.1.0.2
7fe0c034f000-7fe0c036b000 r-xp 00000000 fe:02 2920116 /usr/lib/libxklavier.so.16.2.0
7fe0c036b000-7fe0c056a000 ---p 0001c000 fe:02 2920116 /usr/lib/libxklavier.so.16.2.0
7fe0c056a000-7fe0c056b000 r--p 0001b000 fe:02 2920116 /usr/lib/libxklavier.so.16.2.0
7fe0c056b000-7fe0c056c000 rw-p 0001c000 fe:02 2920116 /usr/lib/libxklavier.so.16.2.0
7fe0c056c000-7fe0c056d000 rw-p 00000000 00:00 0
7fe0c056d000-7fe0c0574000 r-xp 00000000 fe:02 2914829 /usr/lib/libgnomekbd.so.7.0.0
7fe0c0574000-7fe0c0773000 ---p 00007000 fe:02 2914829 /usr/lib/libgnomekbd.so.7.0.0
7fe0c0773000-7fe0c0774000 r--p 00006000 fe:02 2914829 /usr/lib/libgnomekbd.so.7.0.0
7fe0c0774000-7fe0c0775000 rw-p 00007000 fe:02 2914829 /usr/lib/libgnomekbd.so.7.0.0
7fe0c0775000-7fe0c078a000 r-xp 00000000 fe:02 2918100 /usr/lib/libgnomekbdui.so.7.0.0
7fe0c078a000-7fe0c098a000 ---p 00015000 fe:02 2918100 /usr/lib/libgnomekbdui.so.7.0.0
7fe0c098a000-7fe0c098b000 r--p 00015000 fe:02 2918100 /usr/lib/libgnomekbdui.so.7.0.0
7fe0c098b000-7fe0c098c000 rw-p 00016000 fe:02 2918100 /usr/lib/libgnomekbdui.so.7.0.0
7fe0c098c000-7fe0c09a1000 r-xp 00000000 fe:02 3028334 /usr/lib/control-center-1/panels/libregion.so
7fe0c09a1000-7fe0c0ba0000 ---p 00015000 fe:02 3028334 /usr/lib/control-center-1/panels/libregion.so
7fe0c0ba0000-7fe0c0ba1000 r--p 00014000 fe:02 3028334 /usr/lib/control-center-1/panels/libregion.so
7fe0c0ba1000-7fe0c0ba2000 rw-p 00015000 fe:02 3028334 /usr/lib/control-center-1/panels/libregion.so
7fe0c0ba2000-7fe0c0bb2000 r-xp 00000000 fe:02 2897468 /usr/lib/libupower-glib.so.1.0.1
7fe0c0bb2000-7fe0c0db1000 ---p 00010000 fe:02 2897468 /usr/lib/libupower-glib.so.1.0.1
7fe0c0db1000-7fe0c0db2000 r--p 0000f000 fe:02 2897468 /usr/lib/libupower-glib.so.1.0.1
7fe0c0db2000-7fe0c0db3000 rw-p 00010000 fe:02 2897468 /usr/lib/libupower-glib.so.1.0.1
7fe0c0db3000-7fe0c0db9000 r-xp 00000000 fe:02 3027939 /usr/lib/control-center-1/panels/libpower.so
7fe0c0db9000-7fe0c0fb8000 ---p 00006000 fe:02 3027939 /usr/lib/control-center-1/panels/libpower.so
7fe0c0fb8000-7fe0c0fb9000 r--p 00005000 fe:02 3027939 /usr/lib/control-center-1/panels/libpower.so
7fe0c0fb9000-7fe0c0fba000 rw-p 00006000 fe:02 3027939 /usr/lib/control-center-1/panels/libpower.so
7fe0c0fba000-7fe0c0ff3000 r-xp 00000000 fe:02 2915702 /usr/lib/libnspr4.so
7fe0c0ff3000-7fe0c11f2000 ---p 00039000 fe:02 2915702 /usr/lib/libnspr4.so
7fe0c11f2000-7fe0c11f3000 r--p 00038000 fe:02 2915702 /usr/lib/libnspr4.so
7fe0c11f3000-7fe0c11f5000 rw-p 00039000 fe:02 2915702 /usr/lib/libnspr4.so
7fe0c11f5000-7fe0c11f7000 rw-p 00000000 00:00 0
7fe0c11f7000-7fe0c11fb000 r-xp 00000000 fe:02 2915786 /usr/lib/libplc4.so
7fe0c11fb000-7fe0c13fa000 ---p 00004000 fe:02 2915786 /usr/lib/libplc4.so
7fe0c13fa000-7fe0c13fb000 r--p 00003000 fe:02 2915786 /usr/lib/libplc4.soAbgebrochen (Speicherabzug geschrieben)
This task depends upon

Closed by  Jan de Groot (JGC)
Friday, 09 November 2012, 13:44 GMT
Reason for closing:  Fixed
Additional comments about closing:  Marking as fixed. Upstream has committed fixes for this.
Comment by Nicolas Maître (nimai) - Sunday, 01 April 2012, 14:41 GMT
I can confirm this. The problem has just appeared after upgrading to gnome 3.4 from testing.

I'm also using an ATI card with the mesa r600 driver on 64bits system.
This might be related since I get some unusual graphical bugs too, namely some labels/text are blurred, like if it had been scrubbed or something...

Edit: added a screenshot of this page rendered in epiphany.
Comment by Nikita Malyavin (foobarrior) - Sunday, 01 April 2012, 15:58 GMT
I have the same problem, but i'm on NVidia with nouveau drivers
   out (10.4 KiB)
Comment by Ionut Biru (wonder) - Sunday, 01 April 2012, 16:10 GMT
recompile gnome-control-center and get a proper backtrace.
https://wiki.archlinux.org/index.php/Step_By_Step_Debugging_Guide
Comment by Nikita Malyavin (foobarrior) - Sunday, 01 April 2012, 16:38 GMT
going under the recipe i've got an attached backtrace. Think I should recompile cheese with -g?
   out (4.5 KiB)
Comment by Ionut Biru (wonder) - Sunday, 01 April 2012, 17:29 GMT
yes, recompile packages that are involved in that trace please
Comment by alex (kabolt) - Sunday, 01 April 2012, 18:57 GMT
before I forget it: gnome-control-center 3.2.2-1 works fine. The bug must be introduced by a new feature
Comment by alex (kabolt) - Sunday, 01 April 2012, 19:00 GMT
and an other thing I noticed: gnome-shell crash sometimes if you use gnome-control-center especially if you change the version
Comment by Nikita Malyavin (foobarrior) - Sunday, 01 April 2012, 19:11 GMT
sorry, i've recompiled gnome-control-center, cheese and clutter with -g flag following that article, and i hope it was successful, because sizes of packages have increased, but i still don't see any changes in stack trace -- all that symbols stay unrecognized

what have i exactly done:
git clone git clone git://projects.archlinux.org/svntogit/packages.git --depth 1
cd packages/$package/repos/testing-$(uname -m)/
edit 'build' function like in that guide
makepkg ; pacman -U ***
gdb gnome-control-center
run
bt full
   log (5.1 KiB)
Comment by Jan Steffens (heftig) - Sunday, 01 April 2012, 19:13 GMT
Have you added '!strip' to the options of the PKGBUILDs?
Comment by Nikita Malyavin (foobarrior) - Sunday, 01 April 2012, 19:30 GMT
Now i am. Here the trace is.
   log (6 KiB)
Comment by Nikita Malyavin (foobarrior) - Sunday, 01 April 2012, 19:41 GMT
BTW, reverting cheese to extra also made control center work
And reverting only clutter also makes it work
Comment by Ionut Biru (wonder) - Saturday, 07 April 2012, 05:56 GMT
did you guys reported upstream this issue, now that we have a good backtrace
Comment by Nikita Malyavin (foobarrior) - Saturday, 07 April 2012, 06:05 GMT
no, i'm not. do you think it's good anough? i just hadn't anymore time to play with and recompile the rest packages
*EDIT* okay i've forced myself; i'll do it in a minute
*EDIT* done https://bugzilla.gnome.org/show_bug.cgi?id=673681
Comment by Alen Skondro (alesko) - Saturday, 07 April 2012, 22:05 GMT
This seems to happen with all mesa/gallium3d drivers (r600, nouveau, swrast).
I will try to install the nvidia driver just to see if this is a mesa specific issue..
Comment by Ionut Biru (wonder) - Tuesday, 10 April 2012, 15:23 GMT
can you guys report this issue to mesa and paste the link?
Comment by Alen Skondro (alesko) - Tuesday, 10 April 2012, 16:00 GMT
Already did. Forgot to add link...

Here it is:
https://bugs.freedesktop.org/show_bug.cgi?id=48441
Comment by Ionut Biru (wonder) - Monday, 23 April 2012, 20:20 GMT
Can you guys do the following and paste the results?
add the following above extra repository in /etc/pacman.conf
[debug]
SigLevel = Never
Server = http://pkgbuild.com/~ioni/debug/$arch

pacman -Syu and relogin
after than run
$ valgrind gnome-control-center
Comment by Kev (Kev) - Monday, 23 April 2012, 21:27 GMT
I can confirm this with latest gnome 3.4 upgrade on archlinux which moved from testing to stable today(!).
Using extra/xf86-video-ati 6.14.4-2 if it matters..
Comment by Ionut Biru (wonder) - Monday, 23 April 2012, 21:30 GMT
confirming doesn't help us and especially doesn't help you in any way.
what does it help is to provide the information that i'm asking.
Comment by Patrick (Weegee) - Monday, 23 April 2012, 21:41 GMT
Weird, when using gnome-control-center from your debug repository it doesn't crash, yet it leads to 100% cpu usage.

e: nvm, it crashes when I don't run it via valgrind.
Comment by Kev (Kev) - Monday, 23 April 2012, 21:48 GMT
Same for me. Running with valgrind it doesn't crash and output looks like Patrick's log file.
Running the debug gnome-control-center without valdgrind crashs and produces the attached output.
Comment by Henry78 (Henry78) - Tuesday, 24 April 2012, 10:05 GMT
Another valgrind log. System was updated to stable 3.4.1 series a couple of hours ago.
Comment by Daniel Apolinario (dapolinario) - Tuesday, 24 April 2012, 10:43 GMT
Valgrind log.
Comment by Ionut Biru (wonder) - Tuesday, 24 April 2012, 10:44 GMT
Thanks for the logs. It seems that is a problem with llvm compiler or even with gcc.

I'll keep you posted and ask for feedback when i have other packages for testing
Comment by Ionut Biru (wonder) - Tuesday, 24 April 2012, 13:24 GMT
can you guys run gdb gnome-control-center and then after it crashes paste the output of the command:
print Triple._M_dataplus._M_p
Comment by Daniel Apolinario (dapolinario) - Tuesday, 24 April 2012, 13:26 GMT
(gdb) print Triple._M_dataplus._M_p
$1 = 0x85350f8 ""
Comment by Ionut Biru (wonder) - Tuesday, 24 April 2012, 13:53 GMT
i'm sorry, i forgot to tell you do add a break before.

break llvm::sys::getHostTriple()
run
print Triple._M_dataplus._M_p
Comment by Alen Skondro (alesko) - Tuesday, 24 April 2012, 13:59 GMT
(gdb) print Triple
$1 = {static npos = <optimized out>,
_M_dataplus = {<std::allocator<char>> = {<__gnu_cxx::new_allocator<char>> = {<No data fields>}, <No data fields>},
_M_p = 0x7f3287a5b4f0 "x86_64-"}}
(gdb) print Triple._M_dataplus._M_p
$2 = 0x7f3287a5b4f0 "x86_64-"
Comment by Ionut Biru (wonder) - Tuesday, 24 April 2012, 14:10 GMT
@Alen, can you join #dri-devel@freenode and help debug more? I'm there with nickname ioni
Comment by Alen Skondro (alesko) - Tuesday, 24 April 2012, 14:18 GMT
yeah, sure. As soon as I get home (ca. 2 hours).
Comment by Ionut Biru (wonder) - Wednesday, 25 April 2012, 14:52 GMT
please upgrade to the latest packages and let me know if is working.

mesa was built with gcc4.6 as well as llvm
Comment by Henry78 (Henry78) - Wednesday, 25 April 2012, 15:06 GMT
wich packages are have been updated?
Comment by Ionut Biru (wonder) - Wednesday, 25 April 2012, 15:07 GMT
mesa and dri
Comment by Henry78 (Henry78) - Wednesday, 25 April 2012, 15:19 GMT
Maybe I'm too impatient, but there are no updates in git yet...?
Comment by Ionut Biru (wonder) - Wednesday, 25 April 2012, 15:20 GMT Comment by Henry78 (Henry78) - Wednesday, 25 April 2012, 15:24 GMT
oh, my fault! extpected them released in extra. Thanks for pointing out.
Comment by Patrick (Weegee) - Wednesday, 25 April 2012, 17:09 GMT
Updated packages, still crashes. I hope these logfiles are useful in any way ...
Comment by Alen Skondro (alesko) - Wednesday, 25 April 2012, 20:54 GMT
Can you guys please try to execute this gnome-control-center (x86_64) binary directly from your home directory?

When I build gnome-control-center directly from git (tag 3.4.1) and specify the install prefix to my home directory, the resulting binary works. Well, at least for me.
I used all the configuration parameters from the ABS version (including patches).

I'm beginning to think that there is an issue somewhere in the makepkg procedure.

Comment by Ionut Biru (wonder) - Wednesday, 25 April 2012, 21:07 GMT
i guess is about optimization. try to build at least with 02
Comment by Pierre-Henri Berard (pierrebe) - Wednesday, 25 April 2012, 23:03 GMT
Hi. Same bug for me I think.
Arch x86_64
OpenGL vendor string: X.Org R300 Project
OpenGL renderer string: Gallium 0.4 on ATI R580
OpenGL version string: 2.1 Mesa 8.0.2
OpenGL shading language version string: 1.20

I try to use the gnome-control-center from Alen Skondro without success.

$ gnome-control-center ("normal" version)

(gnome-control-center:7079): Gtk-WARNING **: Theme directory apps/24 of theme fs-icons-gnome-style has no size field


(gnome-control-center:7079): Gtk-WARNING **: Theme directory status/24 of theme fs-icons-gnome-style has no size field


(gnome-control-center:7079): Gtk-WARNING **: Theme directory apps/24 of theme fs-icons has no size field


(gnome-control-center:7079): Gtk-WARNING **: Theme directory status/24 of theme fs-icons has no size field

*** glibc detected *** gnome-control-center: free(): invalid pointer: 0x00007f4457fdb4d8 ***
======= Backtrace: =========
/lib/libc.so.6(+0x78a56)[0x7f447a125a56]
/usr/lib/libstdc++.so.6(_ZNSs7reserveEm+0x68)[0x7f446197c5d8]
/usr/lib/libstdc++.so.6(_ZNSs6appendEPKcm+0xb5)[0x7f446197c865]
/usr/lib/xorg/modules/dri/r300_dri.so(_ZN4llvm3sys13getHostTripleEv+0xbe)[0x7f4459437d2e]
/usr/lib/xorg/modules/dri/r300_dri.so(_ZN4llvm13EngineBuilder12selectTargetEPNS_6ModuleENS_9StringRefES3_RKNS_15SmallVectorImplISsEENS_5Reloc5ModelENS_9CodeModel5ModelEPSs+0x368)[0x7f4458d60338]
/usr/lib/xorg/modules/dri/r300_dri.so(_ZN4llvm13EngineBuilder6createEv+0xad)[0x7f4458d53b0d]
/usr/lib/xorg/modules/dri/r300_dri.so(LLVMCreateJITCompilerForModule+0x9b)[0x7f4458d5f7ab]
/usr/lib/xorg/modules/dri/r300_dri.so(+0x4237c2)[0x7f4458d067c2]
/usr/lib/xorg/modules/dri/r300_dri.so(+0x4238ab)[0x7f4458d068ab]
/usr/lib/xorg/modules/dri/r300_dri.so(+0x3a1575)[0x7f4458c84575]
/usr/lib/xorg/modules/dri/r300_dri.so(+0x2be18d)[0x7f4458ba118d]
/usr/lib/xorg/modules/dri/r300_dri.so(+0x2bcbd5)[0x7f4458b9fbd5]
/usr/lib/xorg/modules/dri/r300_dri.so(+0x20d18b)[0x7f4458af018b]
/usr/lib/xorg/modules/dri/r300_dri.so(+0x1c4e35)[0x7f4458aa7e35]
/usr/lib/xorg/modules/dri/r300_dri.so(+0x1c12e5)[0x7f4458aa42e5]
/usr/lib/xorg/modules/dri/r300_dri.so(+0x1c13fd)[0x7f4458aa43fd]
/usr/lib/libGL.so.1(+0x44b53)[0x7f4463ba2b53]
/usr/lib/libGL.so.1(+0x1e2fe)[0x7f4463b7c2fe]
/usr/lib/libGL.so.1(glXCreateNewContext+0x2a)[0x7f4463b7c52a]
/usr/lib/libcogl.so.9(+0x63a8a)[0x7f445a657a8a]
/usr/lib/libcogl.so.9(cogl_display_setup+0x23)[0x7f445a6158a3]
/usr/lib/libcogl.so.9(cogl_renderer_check_onscreen_template+0x69)[0x7f445a615129]
/usr/lib/libclutter-1.0.so.0(+0x2f6ce)[0x7f445aab76ce]
/usr/lib/libclutter-1.0.so.0(+0x5e279)[0x7f445aae6279]
/usr/lib/libclutter-1.0.so.0(+0x753b3)[0x7f445aafd3b3]
/usr/lib/libclutter-1.0.so.0(+0x80d6a)[0x7f445ab08d6a]
/usr/lib/libclutter-1.0.so.0(+0x80f9b)[0x7f445ab08f9b]
/usr/lib/libglib-2.0.so.0(g_option_context_parse+0x3b7)[0x7f447a9f66e7]
/usr/lib/libclutter-1.0.so.0(clutter_init+0xd2)[0x7f445ab09262]
/usr/lib/libcheese-gtk.so.21(cheese_gtk_init+0x24)[0x7f445b8855e4]
/usr/lib/control-center-1/panels/libuser-accounts.so(g_io_module_load+0x33)[0x7f445c0ef2c3]
/usr/lib/libgio-2.0.so.0(+0x5ae06)[0x7f447af40e06]
/usr/lib/libgobject-2.0.so.0(g_type_module_use+0x81)[0x7f447accb271]
/usr/lib/libgio-2.0.so.0(g_io_modules_load_all_in_directory_with_scope+0x84)[0x7f447af411e4]
gnome-control-center[0x40975a]
/usr/lib/libgobject-2.0.so.0(g_type_create_instance+0x117)[0x7f447acc82c7]
/usr/lib/libgobject-2.0.so.0(+0x15038)[0x7f447acad038]
/usr/lib/libgobject-2.0.so.0(g_object_newv+0x781)[0x7f447acaeaf1]
/usr/lib/libgobject-2.0.so.0(g_object_new+0xec)[0x7f447acaf13c]
gnome-control-center(main+0x72)[0x407b02]
/lib/libc.so.6(__libc_start_main+0xf5)[0x7f447a0ce455]
gnome-control-center[0x407bb1]
======= Memory map: ========
00400000-00412000 r-xp 00000000 08:23 791601 /usr/bin/gnome-control-center
00611000-00612000 r--p 00011000 08:23 791601 /usr/bin/gnome-control-center
00612000-00613000 rw-p 00012000 08:23 791601 /usr/bin/gnome-control-center
01e6d000-022ba000 rw-p 00000000 00:00 0 [heap]
7f4457591000-7f4457592000 ---p 00000000 00:00 0
7f4457592000-7f4457d92000 rw-p 00000000 00:00 0
7f4457d92000-7f4457d96000 r-xp 00000000 08:23 829532 /usr/lib/libtxc_dxtn.so
7f4457d96000-7f4457f95000 ---p 00004000 08:23 829532 /usr/lib/libtxc_dxtn.so
7f4457f95000-7f4457f96000 r--p 00003000 08:23 829532 /usr/lib/libtxc_dxtn.so
7f4457f96000-7f4457f97000 rw-p 00004000 08:23 829532 /usr/lib/libtxc_dxtn.so
7f4457fa0000-7f44580e2000 rw-p 00000000 00:00 0
7f44580e2000-7f44580e3000 ---p 00000000 00:00 0
7f44580e3000-7f44588e3000 rw-p 00000000 00:00 0
7f44588e3000-7f44596f3000 r-xp 00000000 08:23 828179 /usr/lib/xorg/modules/dri/r300_dri.so
7f44596f3000-7f44598f2000 ---p 00e10000 08:23 828179 /usr/lib/xorg/modules/dri/r300_dri.so
7f44598f2000-7f445992c000 r--p 00e0f000 08:23 828179 /usr/lib/xorg/modules/dri/r300_dri.so
7f445992c000-7f4459972000 rw-p 00e49000 08:23 828179 /usr/lib/xorg/modules/dri/r300_dri.so
7f4459972000-7f4459b5a000 rw-p 00000000 00:00 0
7f4459b5a000-7f4459b5f000 r-xp 00000000 08:23 810539 /usr/lib/libxcb-util.so.0.0.0
7f4459b5f000-7f4459d5f000 ---p 00005000 08:23 810539 /usr/lib/libxcb-util.so.0.0.0
7f4459d5f000-7f4459d60000 rw-p 00005000 08:23 810539 /usr/lib/libxcb-util.so.0.0.0
7f4459d60000-7f4459d68000 r-xp 00000000 08:23 803155 /usr/lib/libstartup-notification-1.so.0.0.0
7f4459d68000-7f4459f68000 ---p 00008000 08:23 803155 /usr/lib/libstartup-notification-1.so.0.0.0
7f4459f68000-7f4459f69000 rw-p 00008000 08:23 803155 /usr/lib/libstartup-notification-1.so.0.0.0
7f4459f69000-7f4459f9c000 r-xp 00000000 08:23 828861 /usr/lib/libgsttag-0.10.so.0.25.0
7f4459f9c000-7f445a19b000 ---p 00033000 08:23 828861 /usr/lib/libgsttag-0.10.so.0.25.0
7f445a19b000-7f445a19d000 r--p 00032000 08:23 828861 /usr/lib/libgsttag-0.10.so.0.25.0
7f445a19d000-7f445a19e000 rw-p 00034000 08:23 828861 /usr/lib/libgsttag-0.10.so.0.25.0
7f445a19e000-7f445a1a2000 r-xp 00000000 08:23 528788 /lib/libattr.so.1.1.0
7f445a1a2000-7f445a3a1000 ---p 00004000 08:23 528788 /lib/libattr.so.1.1.0
7f445a3a1000-7f445a3a2000 rw-p 00003000 08:23 528788 /lib/libattr.so.1.1.0
7f445a3a2000-7f445a3f0000 r-xp 00000000 08:23 822183 /usr/lib/libgee.so.2.0.0
7f445a3f0000-7f445a5f0000 ---p 0004e000 08:23 822183 /usr/lib/libgee.so.2.0.0
7f445a5f0000-7f445a5f3000 r--p 0004e000 08:23 822183 /usr/lib/libgee.so.2.0.0
7f445a5f3000-7f445a5f4000 rw-p 00051000 08:23 822183 /usr/lib/libgee.so.2.0.0
7f445a5f4000-7f445a67a000 r-xp 00000000 08:23 835636 /usr/lib/libcogl.so.9.1.1
7f445a67a000-7f445a87a000 ---p 00086000 08:23 835636 /usr/lib/libcogl.so.9.1.1
7f445a87a000-7f445a87e000 r--p 00086000 08:23 835636 /usr/lib/libcogl.so.9.1.1
7f445a87e000-7f445a880000 rw-p 0008a000 08:23 835636 /usr/lib/libcogl.so.9.1.1
7f445a880000-7f445a887000 r-xp 00000000 08:23 835637 /usr/lib/libcogl-pango.so.0.0.0
7f445a887000-7f445aa86000 ---p 00007000 08:23 835637 /usr/lib/libcogl-pango.so.0.0.0
7f445aa86000-7f445aa87000 r--p 00006000 08:23 835637 /usr/lib/libcogl-pango.so.0.0.0
7f445aa87000-7f445aa88000 rw-p 00007000 08:23 835637 /usr/lib/libcogl-pango.so.0.0.0
7f445aa88000-7f445aba8000 r-xp 00000000 08:23 833691 /usr/lib/libclutter-1.0.so.0.1000.2
7f445aba8000-7f445ada8000 ---p 00120000 08:23 833691 /usr/lib/libclutter-1.0.so.0.1000.2
7f445ada8000-7f445adac000 r--p 00120000 08:23 833691 /usr/lib/libclutter-1.0.so.0.1000.2
7f445adac000-7f445adae000 rw-p 00124000 08:23 833691 /usr/lib/libclutter-1.0.so.0.1000.2
7f445adae000-7f445adb0000 rw-p 00000000 00:00 0
7f445adb0000-7f445adbb000 r-xp 00000000 08:23 811408 /usr/lib/libclutter-gtk-1.0.so.0.0.0
7f445adbb000-7f445afba000 ---p 0000b000 08:23 811408 /usr/lib/libclutter-gtk-1.0.so.0.0.0
7f445afba000-7f445afbb000 r--p 0000a000 08:23 811408 /usr/lib/libclutter-gtk-1.0.so.0.0.0
7f445afbb000-7f445afbc000 rw-p 0000b000 08:23 811408 /usr/lib/libclutter-gtk-1.0.so.0.0.0
7f445afbc000-7f445b051000 r-xp 00000000 08:23 798895 /usr/lib/libmx-1.0.so.2.401.0
7f445b051000-7f445b250000 ---p 00095000 08:23 798895 /usr/lib/libmx-1.0.so.2.401.0
7f445b250000-7f445b251000 r--p 00094000 08:23 798895 /usr/lib/libmx-1.0.so.2.401.0
7f445b251000-7f445b254000 rw-p 00095000 08:23 798895 /usr/lib/libmx-1.0.so.2.401.0
7f445b254000-7f445b267000 r-xp 00000000 08:23 791681 /usr/lib/libclutter-gst-1.0.so.0.504.0
7f445b267000-7f445b467000 ---p 00013000 08:23 791681 /usr/lib/libclutter-gst-1.0.so.0.504.0
7f445b467000-7f445b468000 r--p 00013000 08:23 791681 /usr/lib/libclutter-gst-1.0.so.0.504.0
7f445b468000-7f445b469000 rw-p 00014000 08:23 791681 /usr/lib/libclutter-gst-1.0.so.0.504.0
7f445b469000-7f445b46a000 rw-p 00000000 00:00 0
7f445b46a000-7f445b46e000 r-xp 00000000 08:23 522834 /lib/libcap.so.2.22
7f445b46e000-7f445b66d000 ---p 00004000 08:23 522834 /lib/libcap.so.2.22
7f445b66d000-7f445b66e000 rw-p 00003000 08:23 522834 /lib/libcap.so.2.22
7f445b66e000-7f445b67d000 r-xp 00000000 08:23 813524 /usr/lib/libcheese.so.3.2.4
7f445b67d000-7f445b87c000 ---p 0000f000 08:23 813524 /usr/lib/libcheese.so.3.2.4
7f445b87c000-7f445b87d000 r--p 0000e000 08:23 813524 /usr/lib/libcheese.so.3.2.4
7f445b87d000-7f445b87e000 rw-p 0000f000 08:23 813524 /usr/lib/libcheese.so.3.2.4
7f445b87e000-7f445b88a000 r-xp 00000000 08:23 813525 /usr/lib/libcheese-gtk.so.21.1.4
7f445b88a000-7f445ba89000 ---p 0000c000 08:23 813525 /usr/lib/libcheese-gtk.so.21.1.4
7f445ba89000-7f445ba8a000 r--p 0000b000 08:23 813525 /usr/lib/libcheese-gtk.so.21.1.4
7f445ba8a000-7f445ba8b000 rw-p 0000c000 08:23 813525 /usr/lib/libcheese-gtk.so.21.1.4
7f445ba8b000-7f445ba93000 r-xp 00000000 08:23 522476 /lib/libcrypt-2.15.so
7f445ba93000-7f445bc92000 ---p 00008000 08:23 522476 /lib/libcrypt-2.15.so
7f445bc92000-7f445bc93000 r--p 00007000 08:23 522476 /lib/libcrypt-2.15.so
7f445bc93000-7f445bc94000 rw-p 00008000 08:23 522476 /lib/libcrypt-2.15.so
7f445bc94000-7f445bcc2000 rw-p 00000000 00:00 0
7f445bcc2000-7f445bcc4000 r-xp 00000000 08:23 840246 /usr/lib/libsystemd-daemon.so.0.0.1
7f445bcc4000-7f445bec4000 ---p 00002000 08:23 840246 /usr/lib/libsystemd-daemon.so.0.0.1
7f445bec4000-7f445bec5000 r--p 00002000 08:23 840246 /usr/lib/libsystemd-daemon.so.0.0.1
7f445bec5000-7f445bec6000 rw-p 00003000 08:23 840246 /usr/lib/libsystemd-daemon.so.0.0.1
7f445bec6000-7f445becf000 r-xp 00000000 08:23 840248 /usr/lib/libsystemd-login.so.0.2.1
7f445becf000-7f445c0cf000 ---p 00009000 08:23 840248 /usr/lib/libsystemd-login.so.0.2.1
7f445c0cf000-7f445c0d0000 r--p 00009000 08:23 840248 /usr/lib/libsystemd-login.so.0.2.1
7f445c0d0000-7f445c0d1000 rw-p 0000a000 08:23 840248 /usr/lib/libsystemd-login.so.0.2.1
7f445c0d1000-7f445c0fa000 r-xp 00000000 08:23 791432 /usr/lib/control-center-1/panels/libuser-accounts.so
7f445c0fa000-7f445c2fa000 ---p 00029000 08:23 791432 /usr/lib/control-center-1/panels/libuser-accounts.so
7f445c2fa000-7f445c2fb000 r--p 00029000 08:23 791432 /usr/lib/control-center-1/panels/libuser-accounts.so
7f445c2fb000-7f445c2fd000 rw-p 0002a000 08:23 791432 /usr/lib/control-center-1/panels/libuser-accounts.so
7f445c2fd000-7f445c30d000 r-xp 00000000 08:23 817857 /usr/lib/libgtop-2.0.so.7.2.0
7f445c30d000-7f445c50d000 ---p 00010000 08:23 817857 /usr/lib/libgtop-2.0.so.7.2.0
7f445c50d000-7f445c50e000 r--p 00010000 08:23 817857 /usr/lib/libgtop-2.0.so.7.2.0
7f445c50e000-7f445c50f000 rw-p 00011000 08:23 817857 /usr/lib/libgtop-2.0.so.7.2.0
7f445c50f000-7f445c51a000 r-xp 00000000 08:23 787929 /usr/lib/control-center-1/panels/libinfo.so
7f445c51a000-7f445c719000 ---p 0000b000 08:23 787929 /usr/lib/control-center-1/panels/libinfo.so
7f445c719000-7f445c71a000 r--p 0000a000 08:23 787929 /usr/lib/control-center-1/panels/libinfo.so
7f445c71a000-7f445c71b000 rw-p 0000b000 08:23 787929 /usr/lib/control-center-1/panels/libinfo.so
7f445c71b000-7f445c73f000 r-xp 00000000 08:23 798810 /usr/lib/libgnome-bluetooth.so.10.0.0
7f445c73f000-7f445c93e000 ---p 00024000 08:23 798810 /usr/lib/libgnome-bluetooth.so.10.0.0
7f445c93e000-7f445c940000 r--p 00023000 08:23 798810 /usr/lib/libgnome-bluetooth.so.10.0.0
7f445c940000-7f445c941000 rw-p 00025000 08:23 798810 /usr/lib/libgnome-bluetooth.so.10.0.0
7f445c941000-7f445c947000 r-xp 00000000 08:23 791586 /usr/lib/control-center-1/panels/libbluetooth.so
7f445c947000-7f445cb46000 ---p 00006000 08:23 791586 /usr/lib/control-center-1/panels/libbluetooth.so
7f445cb46000-7f445cb47000 r--p 00005000 08:23 791586 /usr/lib/control-center-1/panels/libbluetooth.so
7f445cb47000-7f445cb48000 rw-p 00006000 08:23 791586 /usr/lib/control-center-1/panels/libbluetooth.so
7f445cb48000-7f445cb68000 r-xp 00000000 08:23 813296 /usr/lib/libcolord.so.1.0.10
7f445cb68000-7f445cd67000 ---p 00020000 08:23 813296 /usr/lib/libcolord.so.1.0.10
7f445cd67000-7f445cd68000 r--p 0001f000 08:23 813296 /usr/lib/libcolord.so.1.0.10
7f445cd68000-7f445cd69000 rw-p 00020000 08:23 813296 /usr/lib/libcolord.so.1.0.10
7f445cd69000-7f445cd75000 r-xp 00000000 08:23 784211 /usr/lib/control-center-1/panels/libcolor.so
7f445cd75000-7f445cf74000 ---p 0000c000 08:23 784211 /usr/lib/control-center-1/panels/libcolor.so
7f445cf74000-7f445cf75000 r--p 0000b000 08:23 784211 /usr/lib/control-center-1/panels/libcolor.so
7f445cf75000-7f445cf76000 rw-p 0000c000 08:23 784211 /usr/lib/control-center-1/panels/libcolor.so
7f445cf76000-7f445cf81000 r-xp 00000000 08:23 789588 /usr/lib/control-center-1/panels/libkeyboard.so
7f445cf81000-7f445d181000 ---p 0000b000 08:23 789588 /usr/lib/control-center-1/panels/libkeyboard.so
7f445d181000-7f445d182000 r--p 0000b000 08:23 789588 /usr/lib/control-center-1/panels/libkeyboard.so
7f445d182000-7f445d183000 rw-p 0000c000 08:23 789588 /usr/lib/control-center-1/panels/libkeyboard.so
7f445d183000-7f445d193000 r-xp 00000000 08:23 810548 /usr/lib/libupower-glib.so.1.0.1
7f445d193000-7f445d392000 ---p 00010000 08:23 810548 /usr/lib/libupower-glib.so.1.0.1
7f445d392000-7f445d393000 r--p 0000f000 08:23 810548 /usr/lib/libupower-glib.so.1.0.1
7f445d393000-7f445d394000 rw-p 00010000 08:23 810548 /usr/lib/libupower-glib.so.1.0.1
7f445d394000-7f445d39a000 r-xp 00000000 08:23 783434 /usr/lib/control-center-1/panels/libpower.so
7f445d39a000-7f445d599000 ---p 00006000 08:23 783434 /usr/lib/control-center-1/panels/libpower.so
7f445d599000-7f445d59a000 r--p 00005000 08:23 783434 /usr/lib/control-center-1/panels/libpower.so
7f445d59a000-7f445d59b000 rw-p 00006000 08:23 783434 /usr/lib/control-center-1/panels/libpower.soAbandon
Comment by Allan McRae (Allan) - Thursday, 26 April 2012, 11:24 GMT
I would love to see someone recompile gcc with debug symbols (add -g and !strip) so I can see what is being passed to std::string at the end there... It is a longish build but you can use --nocheck to avoid running the test-suite. I find it difficult to believe std:string is at fault.

Comment by Lakis Euthimiou (konos5) - Thursday, 26 April 2012, 13:43 GMT
Unfortunately problem remains even after the update...
(Arch x86)

Please see my attached log file.
   error.log (14.9 KiB)
Comment by Vladimir G. Ivanovic (vgivanovic0) - Thursday, 26 April 2012, 16:45 GMT
Same problem here. I'm using the radeon driver on an AMD64 netbook.
Comment by Vladimir G. Ivanovic (vgivanovic0) - Thursday, 26 April 2012, 17:08 GMT
A workaround has been posted to the Arch Forum Applications & Desktop Environments
» "Workaround to get gnome-control-center(system setting)working gnome3.4"
(https://bbs.archlinux.org/viewtopic.php?id=140331)

I made `gncc' into a proper shell script and changed its permissions to match those of gnome-control-center, and I could launch 'System Settings' from the Applications menu.
Comment by Patrick (Weegee) - Tuesday, 01 May 2012, 09:42 GMT
After rebuilding gcc and gnome-control-center with debug symbols it works flawlessly.
Comment by Lakis Euthimiou (konos5) - Tuesday, 01 May 2012, 09:57 GMT
Could you give us detailed instructions on how to do that...?
Comment by Patrick (Weegee) - Tuesday, 01 May 2012, 10:07 GMT
I've copied the PKGBUILDs from ABS, added -g to my CFLAGS/CXXFLAGS and !strip to the OPTIONS array in /etc/makepkg.conf, and eventually I've started building the packages by using 'makepkg -i' ...
Comment by Mitch Humpherys (mitch_feaster) - Saturday, 05 May 2012, 17:51 GMT
For anyone in a pinch, it also runs fine under valgrind. It's slow, but it runs.
Comment by Hilton Medeiros (hilton) - Saturday, 05 May 2012, 21:41 GMT
@Mitch
I saw some days ago in a bug report an easier way:

MALLOC_CHECK_=1 gnome-control-center
Comment by Ionut Biru (wonder) - Sunday, 06 May 2012, 22:35 GMT
please try gnome-control-center-3.4.1-2 which just hit extra.
Comment by Mitch Humpherys (mitch_feaster) - Monday, 07 May 2012, 00:14 GMT
3.4.1-2 works for me! (nvidia chipset, nouveau and DRI drivers)
Comment by Juan Donadio (LoKi) - Monday, 07 May 2012, 00:24 GMT
3.4.1-2 works for me too!
Comment by Juan Donadio (LoKi) - Monday, 07 May 2012, 02:26 GMT
3.4.1-2 works for me too!
Comment by MaxB (bal0r) - Monday, 07 May 2012, 07:02 GMT
3.4.1-2 is working again, thanks alot
Comment by Nikita Malyavin (foobarrior) - Friday, 22 June 2012, 12:39 GMT
  • Field changed: Percent Complete (100% → 0%)
Okay, somebody released a workaround, but do you really think this could be called a fix?? Isn't it abnormal to fall down without cheese disabled? I think building without cheese doesn' fix a bug, so it should stay open
Comment by Ionut Biru (wonder) - Friday, 22 June 2012, 12:41 GMT
Nikita, now that we have more details on this:
check out https://plus.google.com/u/0/104877287288155269055/posts/grHDgRNc1gi
please try the patch from https://bugs.webkit.org/show_bug.cgi?id=89358 and recompile g-c-c with cheese support.
Comment by Greg (dolby) - Monday, 15 October 2012, 02:32 GMT
Is this fixed in 3.6?

Loading...