Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#29201 - [firefox] Crash with some sites with cairo-1.12.0-1

Attached to Project: Arch Linux
Opened by Laurent Carlier (lordheavy) - Saturday, 31 March 2012, 12:48 GMT
Last edited by Jan de Groot (JGC) - Tuesday, 03 April 2012, 14:16 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To Andreas Radke (AndyRTR)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Firefox crash when cairo-1.12.0 is installed, for example when visiting http://www.mifassur.com/
Downgrading to 1.10.2-3 fixes the problem.
This task depends upon

Closed by  Jan de Groot (JGC)
Tuesday, 03 April 2012, 14:16 GMT
Reason for closing:  Fixed
Comment by Pierre Schmitz (Pierre) - Saturday, 31 March 2012, 12:52 GMT
I can confirm this issue. Seems to be related to the usage of flash though.
Comment by Andreas Radke (AndyRTR) - Saturday, 31 March 2012, 12:55 GMT
Works well in Xxxterm. You should report this to the FF/Mozilla guys upstream.
Comment by Ionut Biru (wonder) - Saturday, 31 March 2012, 15:50 GMT
we can compile firefox without system cairo support.
Comment by Laurent Carlier (lordheavy) - Sunday, 01 April 2012, 17:20 GMT
Crash is fixed with cairo-1.12.0-2

Still some text corruption, but nothing too much annoying (at least for me)
Comment by Óscar Pereira (gauthma) - Sunday, 01 April 2012, 17:23 GMT
I had the same issue, with a site containing flash content. It also happens with the URL in the task's description. As suggested in  FS#29218 , downgrading cairo to 1.10.2-3 is a temporary fix.

Loading...