Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#29181 - [xf86-video-ati] Hardware acceleration broken, system freeze

Attached to Project: Arch Linux
Opened by Andrew (Shiz0) - Thursday, 29 March 2012, 20:19 GMT
Last edited by Andreas Radke (AndyRTR) - Friday, 30 March 2012, 15:37 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Andreas Radke (AndyRTR)
Architecture x86_64
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 22
Private No

Details

Description:
Updating xf86-video-ati to 6.14.4-1 has broken any hardware acceleration. I can`t watch any video, games like Hedgewars are giving very poor fps and freezing the whole system.

This happens at least on AMD E450 processor and HD6320 video card.
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Friday, 30 March 2012, 15:37 GMT
Reason for closing:  Fixed
Comment by Bastien Dejean (baskerville) - Thursday, 29 March 2012, 20:36 GMT
I also had problems with this release: I couldn't start X.
The log said: "[dri] RADEONDRIGetVersion failed because of a version mismatch.".
I solved it by installing the Git version.
Comment by Robert Beckmann (robfloop) - Thursday, 29 March 2012, 21:14 GMT
I also couldn't start X after updating to this version. X starts again after downgrading to previous version.
Comment by Jan de Groot (JGC) - Thursday, 29 March 2012, 21:43 GMT
Can you attach outputs of dmesg and /var/log/Xorg.0.log(.old) that belongs to the failed driver?
Regarding git: the 6.14.4 is current git master, so there should be no differences between the released driver and a git snapshot, unless it's an outdated git snapshot you're using.
Comment by maxi jac (maxi_jac) - Thursday, 29 March 2012, 21:48 GMT
Had the same problem, X was falling back to vesa and was plain black.
Removing vesa to force radeon I had an error about RADEON wanting to be used on KMS driver even though my kernel was run with a kms radeon drm.
I downgraded to 6.13-2.
Comment by Anton (anthonio) - Thursday, 29 March 2012, 23:14 GMT
@Jan de Groot
Comment by LBJ (indarkness) - Friday, 30 March 2012, 00:27 GMT
Exact same problem here. Downgrade to 6.14.3-2 solved the problem
Comment by Gagan (ico) - Friday, 30 March 2012, 02:59 GMT
Confirming this. I also downgraded to 6.14.3-2.
Comment by Brian (bws) - Friday, 30 March 2012, 03:21 GMT
Same issue here. Unable to startx. Downgrade to xf86-video-ati-6.14.3-2 fixed the issue.
Comment by Aleksey Nikitin (souz9) - Friday, 30 March 2012, 03:52 GMT
Confirm this. I can't start X with xf86-video-ati-6.14.4-1-i686 installed. Downgrade to xf86-video-ati-6.14.3-2-i686 solved the problem
Comment by Christos Kotsaris (TemplarGR) - Friday, 30 March 2012, 04:20 GMT
I can also confirm this, x cannot start with 6.14.4-1 , reverted to 6.14.3-2(64 bit packages).
Comment by Will Brokenbourgh (willbprog127) - Friday, 30 March 2012, 04:22 GMT
Same here with similar configuration. Added 'nomodeset' to kernel boot parameter as workaround.
Comment by Michael (c0da) - Friday, 30 March 2012, 04:52 GMT
Confirm this. Using fbdev as fallback. And fbdev works fine: correct screen resolution over HDMI output, quite fast and so on... That shows kernel modesetting is operational
   Xorg.0.log (45.5 KiB)
   dmesg (53.9 KiB)
Comment by Nikolay (madgnu) - Friday, 30 March 2012, 06:13 GMT
$ pacman -Si libdrm | grep Date
Build Date : Thu Mar 29 21:25:08 2012
$ pacman -Si xf86-video-ati | grep Date
Build Date : Thu Mar 29 21:16:15 2012

Maintainer, JFYI, libdrm must be built _before_ xf86-video-ati.
Simple driver rebuild will solve this problem.
Comment by Jan de Groot (JGC) - Friday, 30 March 2012, 06:38 GMT
Looks like this driver was compiled without KMS support, so it always starts in UMS mode now. A recompile with latets libdrm should fix that.
Comment by Jussi Saarinen (jtts) - Friday, 30 March 2012, 06:56 GMT
I can confirm this bug also. I agree with Jan de Groot: looks like the driver was build with KMS disabled. More details in bug #29178. This seems to be a duplicate of that bug.
Comment by Harry Zhang (robotment) - Friday, 30 March 2012, 09:51 GMT
After I update xf86-video-ati, I got this in my log file.

[ 19.370] (EE) RADEON(0): [dri] RADEONDRIGetVersion failed because of a version mismatch.
[dri] This chipset requires a kernel module version of 1.17.0,
[dri] but the kernel reports a version of 2.12.0.[dri] Make sure your module is loaded prior to starting X, and
[dri] that this driver was built with support for KMS.
[dri] Aborting.
[ 19.370] (II) RADEON(0): RADEONFreeScreen
[ 19.371] (II) UnloadModule: "radeon"
[ 19.371] (II) UnloadSubModule: "int10"
[ 19.371] (II) Unloading int10
[ 19.371] (II) UnloadSubModule: "vgahw"
[ 19.371] (II) Unloading vgahw
[ 19.371] (EE) Screen(s) found, but none have a usable configuration.
[ 19.371]
Fatal server error:
[ 19.371] no screens found
[ 19.371]
Then I install an older version from cache, this problem goes.
Comment by Michael Pusterhofer (feanor12) - Friday, 30 March 2012, 12:01 GMT
I rebuild xf86-video-ati locally via abs and now it works again :)
Comment by Mike Bridge (buckethead) - Friday, 30 March 2012, 12:43 GMT
This is a duplicate of 29178.
Comment by Tony Thedford (tonythed) - Friday, 30 March 2012, 14:01 GMT
On my computer Xorg server will no longer start up. Error says:

---
[ 302.939] (EE) RADEON(0): [dri] RADEONDRIGetVersion failed because of a version mismatch.
[dri] This chipset requires a kernel module version of 1.17.0,
[dri] but the kernel reports a version of 2.12.0.[dri] Make sure your module is loaded prior to starting
X, and
[dri] that this driver was built with support for KMS.
[dri] Aborting.
[ 302.940] (II) UnloadModule: "radeon"
[ 302.940] (II) UnloadSubModule: "int10"
[ 302.940] (II) Unloading int10
[ 302.940] (II) UnloadSubModule: "vgahw"
[ 302.940] (II) Unloading vgahw
[ 302.940] (EE) Screen(s) found, but none have a usable configuration.
[ 302.940]
Fatal server error:
[ 302.940] no screens found
[ 302.940]
Please consult the The X.Org Foundation support
at http://wiki.x.org
for help.
[ 302.940] Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[ 302.940]
[ 302.989] Server terminated with error (1). Closing log file.
---

My video card is:
01:05.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI RS690M [Radeon X1200 Series]

Down grading to xf86-video-ati-6.14.3-2-x86_64.pkg.tar.xz fixes problem.


Comment by Andreas Radke (AndyRTR) - Friday, 30 March 2012, 14:13 GMT
should be fixed in 6.14.4-2
Comment by ushi (ushi) - Friday, 30 March 2012, 15:24 GMT
> should be fixed in 6.14.4-2

Yes, thx!

Loading...