Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#29173 - [cups] lpstat and lpq failed/no output

Attached to Project: Arch Linux
Opened by Gerhard Brauer (GerBra) - Thursday, 29 March 2012, 12:06 GMT
Last edited by Andreas Radke (AndyRTR) - Thursday, 17 May 2012, 18:46 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Andreas Radke (AndyRTR)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


lpq and lpstat don't show the expected output. They only print (several) empty lines.
Printing itself via lp works, cups(d) is setup properly.

Downgrading only cups package to old 1.5.0-2 give back the lpq, lpstat functionality.
Recompiling 1.5.2-1 with up-to-date system dont't solve this...

Additional info:
* package version(s)
cups 1.5.2-1
* config and/or log files etc.

Steps to reproduce:
~ # lpq
<empty line>
<empty line>
~ #
Similar with pstat -p or lpstat -v

Downgrading to 1.5.0-2 (don't need to restart cupsd)
~ # lpq
Samsung_ML-2010 is ready
no entries
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Thursday, 17 May 2012, 18:46 GMT
Reason for closing:  Fixed
Comment by Andreas Radke (AndyRTR) - Saturday, 31 March 2012, 13:26 GMT
report this upstream!
Comment by Gerhard Brauer (GerBra) - Wednesday, 04 April 2012, 15:10 GMT Comment by Allan McRae (Allan) - Saturday, 28 April 2012, 11:45 GMT
Upstream reports will be fixed in 1.5.3.
Comment by Gerhard Brauer (GerBra) - Thursday, 17 May 2012, 16:51 GMT
Fixed with 1.5.3-1