Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#29150 - [flashplugin] flash video is visible through dark background

Attached to Project: Arch Linux
Opened by Vivien Botton (snap) - Wednesday, 28 March 2012, 13:23 GMT
Last edited by Andreas Radke (AndyRTR) - Saturday, 15 September 2012, 07:16 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Ionut Biru (wonder)
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 13
Private No



flash video are visible through dark background, ie playing a video on youtube and the video is visible on my terminal.
Moreover the colors in the video are wrong.
Screenshot does not reveal video incrustation.

Additional info:
nvidia 295.33-2 [installed]

Steps to reproduce:
Just play a flash video and enjoy.
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Saturday, 15 September 2012, 07:16 GMT
Reason for closing:  Fixed
Comment by Ionut Biru (wonder) - Wednesday, 28 March 2012, 13:50 GMT
please apply the patch from this url and let me know if is fixing the problem:
Comment by Vivien Botton (snap) - Wednesday, 28 March 2012, 20:21 GMT
Thanks, this patch solve my two problems. I already have this problem, and it was gone for a while until the last update of flashplugin. This patch was applied in the flashplugin package ?
Comment by Daniel Wallace (gtmanfred) - Thursday, 29 March 2012, 04:34 GMT
the patch mentioned in the url above fixed it for me after I did export VDPAU_TRACE=1 in the command line
Comment by grayich (grayich) - Thursday, 29 March 2012, 09:09 GMT
Ionut Biru, no, it does not work.
besides, my video card(GeForce FX 5700LE, nvidia-173xx nvidia-173xx-utils) does not support vdpau
/usr/lib/firefox/plugin-container /usr/lib/mozilla/plugins/ process does not even appear
Comment by Frederic Bezies (fredbezies) - Friday, 30 March 2012, 20:55 GMT
Same bug here.

[fred@fredo-arch ~]$ pacman -Qi nvidia
Name : nvidia
Version : 295.33-2

Card ? GeForce GT210
Comment by Frederic Bezies (fredbezies) - Friday, 30 March 2012, 21:00 GMT
Additional comment : only in youtube. Works for dailymotion :(
Comment by vincent (la_poigne) - Tuesday, 03 April 2012, 16:41 GMT
The patch work for me after export VDPAU_TRACE=1
Card: GeForce GT220
Comment by bandit (banditsan) - Sunday, 08 April 2012, 23:33 GMT
For me this latest version didn't work at all. Allways crashes or gets black screen
Video: GF FX 5600XT and for now found only one solution to make flash work.
Downgrade to
Comment by Swift Geek (swiftgeek) - Saturday, 14 April 2012, 14:43 GMT
I want to add one thing. Only after enabling hw accel by "/etc/adobe/", plugins are crashing on sites other than youtube (embed yt movie crashes as well).
Comment by Nassim K. (blueicefield) - Tuesday, 24 April 2012, 09:51 GMT
Disabling hardware acceleration in flash solves the problem until a permanent solution was found.
Comment by John Henderson (jwhendy) - Friday, 27 April 2012, 18:50 GMT
I think I may have this problem as well... a flash video (youtube) in one tab shows on all other Chromium tabs as well as some other applications (like Lotus Notes and Geeqie). Is this the same issue others are experiencing? Colors are fine for me.
Comment by Wilson Perdomo (xavierp94) - Friday, 27 July 2012, 03:33 GMT
If you right click on the flash window, like Nassim says, gives you an option to disable the Hardware Acceleration option on your flash installation. I have tried this solution and it has worked.
Comment by Daniel Wallace (gtmanfred) - Friday, 27 July 2012, 03:53 GMT