Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#29133 - [chromium] HTML5 audio playback is choppy

Attached to Project: Arch Linux
Opened by Thomas McGrew (mcgrew) - Tuesday, 27 March 2012, 14:52 GMT
Last edited by Evangelos Foutras (foutrelis) - Thursday, 29 March 2012, 00:05 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Evangelos Foutras (foutrelis)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description: HTML5 audio playback is choppy

Additional info:
package version chromium 17.0.963.83-1
I believe this is related to this upstream issue: http://code.google.com/p/chromium/issues/detail?id=110375

As is reported in the above issue, audio playback stutters about every 1-5 seconds.

My audio device info from lspci:
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 02)

Steps to reproduce:
Play audio in chromium, such as on Google Music or Youtube (without flash).

As per the suggestion of one of the commenters in the upstream bug report, the issue seems to have be a regression caused by svn commit 109852. I have included a patch for the chromium PKGBUILD file which will roll back that commit before compiling. This seems to correct the issue. I also updated the hash for nacl_sdk.zip, as the file seems to have changed, and added flex as a build dependency.

According to the upstream report, this problem is fixed by Chromium 18.x. Let me know if you need any additional information.
This task depends upon

Closed by  Evangelos Foutras (foutrelis)
Thursday, 29 March 2012, 00:05 GMT
Reason for closing:  Fixed
Additional comments about closing:  chromium 18.0.1025.142-1
Comment by Thomas McGrew (mcgrew) - Tuesday, 27 March 2012, 14:55 GMT
Just noticed that I didn't enter a summary. Sorry about that.
Comment by Evangelos Foutras (foutrelis) - Wednesday, 28 March 2012, 20:08 GMT
flex is not included as a build dependency because it belongs to the base-devel group which is a assumed to be installed if you're building packages.

Regarding the actual bug, I have never noticed it myself. However, Chromium 18 went stable today and will soon be in [extra], so I suppose we can skip the patch if it's fixed there.
Comment by Thomas McGrew (mcgrew) - Wednesday, 28 March 2012, 20:13 GMT
My desktop machine (ICH8 family Intel audio) also doesn't exhibit this behavior, so I assume it's hardware dependent. Since 18 will be out soon, that works for me. I just wanted to share my solution in case anyone else was experiencing this problem.

Loading...