Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#29079 - [xf86-video-*] Git patches need updating

Attached to Project: Arch Linux
Opened by Connor Behan (connorbehan) - Friday, 23 March 2012, 20:13 GMT
Last edited by Andreas Radke (AndyRTR) - Saturday, 07 April 2012, 14:47 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Andreas Radke (AndyRTR)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description: Many people are unable to stat the Xserver after the update to 1.12.

https://bbs.archlinux.org/viewtopic.php?id=137803
https://bbs.archlinux.org/viewtopic.php?id=137868
https://bbs.archlinux.org/viewtopic.php?id=137666
https://bbs.archlinux.org/viewtopic.php?id=137784

Unfortunately this came at the same time as the mesa 8.0 update but it has nothing to do with that. The main problem is that each DDX using the vgahw module now needs an extra line to initialize it. This has been fixed in git but most DDXs have not received a release since then.

Affected packages:
* extra/xf86-video-apm 1.2.3-5
* extra/xf86-video-ati 6.14.3-2
* extra/xf86-video-chips
* extra/xf86-video-cirrus 1.3.2-8
* extra/xf86-video-i128
* extra/xf86-video-i740
* extra/xf86-video-neomagic 1.2.5-6
* extra/xf86-video-nv 2.1.18-5
* extra/xf86-video-r128 6.8.1-8
* extra/xf86-video-rendition 4.2.4-6
* extra/xf86-video-s3 0.6.3-7
* extra/xf86-video-s3virge
* extra/xf86-video-savage 2.3.3-3
* extra/xf86-video-siliconmotion 1.7.5-4
* extra/xf86-video-tdfx 1.4.3-8
* extra/xf86-video-trident 1.3.4-6
* extra/xf86-video-xgi 1.6.0-4
* extra/xf86-video-xgixp 1.8.0-5

For the following packages, all you have to do is find the commit "Fix for new vgahw ABI" cby Adam Jackson that changes one line:

apm, chips, cirrus, i128, i740, neomagic, nv, rendition, s3, s3virge, savage, siliconmotion, trident, xgi, xgixp

For ati, the same commit was done but it is called "Update for new vgaHW API" by Matthieu Herrb.

For r128 and tdfx, more patches are needed. I know they work for r128 but cannot verify for tdfx:

http://cgit.freedesktop.org/xorg/driver/xf86-video-r128/commit/?id=b4892e34011d6da577002a29913a803d5dbe1c06
http://cgit.freedesktop.org/xorg/driver/xf86-video-r128/commit/?id=67aaa4698586d75242627b7ce8f4815eeb08f853
http://cgit.freedesktop.org/xorg/driver/xf86-video-r128/commit/?id=ea9e6b548633df5b6ffeac8071f27a5c04ac817e

http://cgit.freedesktop.org/xorg/driver/xf86-video-tdfx/commit/?id=5b5d3c8b23865724d4f6d71610760e80e4b032e6
http://cgit.freedesktop.org/xorg/driver/xf86-video-tdfx/commit/?id=4ea96c222ad0900ad53f506e485588e2a49a22f4
http://cgit.freedesktop.org/xorg/driver/xf86-video-tdfx/commit/?id=32cd2dfa1214ed3260bf2e40bad06927b18f7f7b

I also recommend patches from the commits that say "Make failure to XAA non-fatal" and "Fall back to shadowfb if XAA is unavailable" since these will cause systemic breakage if the drivers still haven't been updated by the time xorg-server 1.13 comes out. However, I leave that up to you since it is not a bug yet.
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Saturday, 07 April 2012, 14:47 GMT
Reason for closing:  Fixed
Comment by atlas jobinson (jobinson99) - Saturday, 24 March 2012, 10:11 GMT
my laptop could not start x after the update of 12 March 2012.

xf86-video-ati

1,with nomodeset,the X will not start
[II][KMS]drm report modesetting isn't support

2,without nomodeset, the screen will be full of vertical line, i can't see any thing,the login-window of course

god tell me how i can do for it
Comment by Jan de Groot (JGC) - Saturday, 24 March 2012, 10:38 GMT
This morning several drivers received new upstream releases, so most of them are fixed now.
Pending drivers:
apm
ati
chips
i740
nv
rendition
s3
s3virge
xgi
xgixp

Some of them have been fixed by Andy already though.
Comment by Andreas Radke (AndyRTR) - Saturday, 24 March 2012, 16:40 GMT
What drivers are missing?
Comment by UroŇ° Vampl (Gusar) - Friday, 06 April 2012, 10:06 GMT
nv is still missing. The current version crashes X, git has updates for the 1.12 ABI. So updating xf86-video-nv to latest git should make it work.
Comment by Andreas Radke (AndyRTR) - Saturday, 07 April 2012, 14:47 GMT
nv has now also been patched. closing this meta issue now. if something is still missing please open new bugs.

Loading...