Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#29043 - [grub2-common]: harmless error message should be corrected

Attached to Project: Arch Linux
Opened by John (graysky) - Wednesday, 21 March 2012, 20:16 GMT
Last edited by Ronald van Haren (pressh) - Wednesday, 20 June 2012, 07:30 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Ronald van Haren (pressh)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 6
Private No

Details

Description: This error is shown for literally a fraction of a second just before Grub is displayed:

error: file `/grub/locale/en.mo.gz` not found

Seems harmless but should be corrected.

Additional info:
* package version(s) extra/grub2-common 1:2.00beta2-2

Steps to reproduce:
Boot a system with grub2 installed. You might need a video camera since the damn thing happens so fast! I have attached a pic of the error on my machine.
   error.jpg (42.5 KiB)
This task depends upon

Closed by  Ronald van Haren (pressh)
Wednesday, 20 June 2012, 07:30 GMT
Reason for closing:  Upstream
Additional comments about closing:  Workaround for harmless error added to wiki as per https://bugs.archlinux.org/task/29043#co mment95774
Comment by Keshav Amburay (the.ridikulus.rat) - Thursday, 22 March 2012, 11:19 GMT
Please report this in bug-grub ML.
Comment by Keshav Amburay (the.ridikulus.rat) - Tuesday, 03 April 2012, 04:34 GMT
Does this error occur with grub2 2.00beta3-1 ?
Comment by John (graysky) - Tuesday, 03 April 2012, 06:29 GMT
Yes, it does... does it not on your system?
Comment by John (graysky) - Tuesday, 03 April 2012, 06:36 GMT
Ah, more people see this bug as well:

http://savannah.gnu.org/bugs/?35880
https://bbs.archlinux.org/viewtopic.php?pid=1077783

This definitively isn't an Arch problem.
Comment by Keshav Amburay (the.ridikulus.rat) - Tuesday, 03 April 2012, 07:59 GMT
No. Not for me, since I manually maintain my grub.cfg . This error occurs only for user using grub-mkconfig generated grub.cfg . But yes, this is not Arch specific.
Comment by Keshav Amburay (the.ridikulus.rat) - Monday, 16 April 2012, 14:03 GMT Comment by John (graysky) - Monday, 16 April 2012, 20:09 GMT
Nice. Can this be integrated into our package somehow?
Comment by Keshav Amburay (the.ridikulus.rat) - Wednesday, 20 June 2012, 05:28 GMT
The solution to this bug is :

# mkdir -p /boot/grub/locale
# cp /usr/share/locale/en@quot/LC_MESSAGES/grub.mo /boot/grub/locale/en.mo

I have added this to the wiki.

Loading...