Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#29017 - [r8168-lts] Module doesn't load on linux-lts 3.0.24: "Exec format error"

Attached to Project: Community Packages
Opened by Thomas Jost (Schnouki) - Tuesday, 20 March 2012, 16:55 GMT
Last edited by Massimiliano Torromeo (mtorromeo) - Tuesday, 24 July 2012, 15:05 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Massimiliano Torromeo (mtorromeo)
Architecture x86_64
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Today I ran pacman -Syu on my server. It included an upgrade from linux-lts 3.0.19-1 to 3.0.24-1. After the upgrade (and updating all .pacnew/.pacsave/...), I rebooted my server but the module wouldn't load.
So of course no network connection, which is quite annoying for a remote dedicated server...
I had to reboot it in a special rescue mode offered by my host (inside a VM accessible through VNC) and rebuild and reinstall the package by hand for my server to reboot correctly.

Relevant part from /var/log/boot:
Tue Mar 20 16:34:23 2012: :: Loading User-specified Modules [BUSY] ERROR: could not insert 'r8168': Exec format error
Tue Mar 20 16:34:23 2012: [FAIL]

Relevant part from dmesg before rebuilding the module:
[ 15.582253] r8168: disagrees about version of symbol module_layout

This was on x86_64, I don't know if the i686 version is affected too.

Please bump pkgrel and rebuild the package as soon as possible, this kind of problem is terrible for servers.
This task depends upon

Closed by  Massimiliano Torromeo (mtorromeo)
Tuesday, 24 July 2012, 15:05 GMT
Reason for closing:  Not a bug
Additional comments about closing:  Kernel 3.4.6-1-ARCH is not lts and a bug is already open for the non-lts module:  FS#30832 
Comment by Pablo Ruiz Muzquiz (diacritica) - Tuesday, 24 July 2012, 15:02 GMT
  • Field changed: Percent Complete (100% → 0%)
Problem reapeared
kernel 3.4.6-1-ARCH
x86_64
ERROR: could not insert 'r8168': Exec format error

Loading...