Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#29005 - [libsndfile] ABS Compile fail

Attached to Project: Arch Linux
Opened by Goffredo (Goffredo) - Monday, 19 March 2012, 13:48 GMT
Last edited by Thomas Dziedzic (tomd123) - Monday, 19 March 2012, 16:07 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

Trying to compile with the unmodified PKGBUILD retrieved with abs gives the following error:

Making all in examples
make[1]: Entering directory `/home/francesco/abs/libsndfile/src/libsndfile-1.0.25/examples'
CC make_sine.o
CCLD make_sine
../src/.libs/libsndfile.so: undefined reference to `vorbis_version_string'
collect2: ld returned 1 exit status
make[1]: *** [make_sine] Error 1
make[1]: Leaving directory `/home/francesco/abs/libsndfile/src/libsndfile-1.0.25/examples'
make: *** [all-recursive] Error 1
==> ERROR: A failure occurred in build().
Aborting...

Additional info:
* package version(s)
libsndfile 1.0.25-2

Steps to reproduce:
This task depends upon

Closed by  Thomas Dziedzic (tomd123)
Monday, 19 March 2012, 16:07 GMT
Reason for closing:  Not a bug
Comment by Daniel Wallace (gtmanfred) - Monday, 19 March 2012, 14:03 GMT
It compiles fine for me
   error.log (85.9 KiB)
Comment by Goffredo (Goffredo) - Monday, 19 March 2012, 14:39 GMT
Yes problem was on me. Sorry, but thanks for the log file, was really helpful.

Loading...