Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#28955 - Synaptics touchpad driver coasting feature stopped working.

Attached to Project: Arch Linux
Opened by Tony Thedford (tonythed) - Saturday, 17 March 2012, 07:57 GMT
Last edited by Andrea Scarpino (BaSh) - Wednesday, 25 April 2012, 12:36 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

Description:

Synaptics touchpad driver coasting feature suddenly stopped working on the last system update.

The synaptics driver:
extra/xf86-input-synaptics 1.5.99.901-2

Additional info:

My system is fully synced and updated as of 3/17/2012.

Video chip: Radeon X1200 Series

Touchpad:
root@nb2 ~# dmesg | grep -i synaptic
[ 7.295912] psmouse serio1: synaptics: Touchpad model: 1, fw: 6.3, id: 0x9280b1, caps: 0xa04711/0xa04000/0x0
[ 7.295919] psmouse serio1: synaptics: Toshiba Satellite A215 detected, limiting rate to 40pps.
[ 7.331766] input: SynPS/2 Synaptics TouchPad as /devices/platform/i8042/serio1/input/input7

kernel: linux 3.2.11-1

/etc/X11/xorg.conf.d/10-synaptics.conf:

Section "InputClass"
Identifier "touchpad catchall"
Driver "synaptics"
MatchIsTouchpad "on"
MatchDevicePath "/dev/input/event*"
Option "TouchpadOff" "0"
Option "PalmDetect" "on"
Option "TapButton1" "1"
Option "TapButton2" "2"
Option "TapButton3" "0"
Option "AccelFactor" "0.5"
Option "MinSpeed" "0.5"
Option "MaxSpeed" "2"
Option "MaxTapTime" "130"
Option "MaxDoubleTapTime" "130"
Option "SingleTapTimeout" "130"
Option "CornerCoasting" "false"
Option "CoastingSpeed" "30"
Option "CoastingFriction" "25"
Option "HorizTwoFingerScroll" "true"
EndSection


Steps to reproduce:

Check your touchpad coasting feature operation after updating your system.
This task depends upon

Closed by  Andrea Scarpino (BaSh)
Wednesday, 25 April 2012, 12:36 GMT
Reason for closing:  Fixed
Additional comments about closing:  xf86-input-synaptics 1.5.99.901-3
Comment by Andreas Radke (AndyRTR) - Saturday, 17 March 2012, 10:11 GMT
report it upstream!
Comment by Cosimo Sacco (thecellarguardian) - Monday, 19 March 2012, 17:03 GMT
In my case, I think it's also tonythed's case, it works BUT it takes something like 18 seconds between a tick (small mini-scroll composing the full scroll) and the next. If I set ScrollButtonRepeat to 1 (default: 100), there's a tick per second.
Comment by Simonas (nagi) - Saturday, 07 April 2012, 18:16 GMT Comment by Thomas Wouters (twouters) - Thursday, 19 April 2012, 11:17 GMT
This is "fixed" in xf86-input-synaptics 1.5.99.901-3, but causes another bug: https://bugs.freedesktop.org/show_bug.cgi?id=48855 (which is fixed upstream - and has a workaround)
Comment by Simonas (nagi) - Thursday, 19 April 2012, 14:03 GMT
Yeah, coasting works for me too after 1.5.99.901-3, however it coasts for very long time now.

No reaction to CoastingFriction option (is it related to bug posted by Thomas Wouters?) is confirmed. I have tried setting that option to absurdly big value (like 1000) too and it still keeps coasting for like 30 seconds until scrolling stops.

EDIT: Thanks to Thomas Wouters.
Comment by Thomas Wouters (twouters) - Thursday, 19 April 2012, 14:11 GMT
Simonas, the bug I mentioned is exactly about that issue.
Comment by Andrea Scarpino (BaSh) - Wednesday, 25 April 2012, 12:36 GMT
See  FS#29573  for the "scrolling tends to coast" bug introduced

Loading...