Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#28922 - [nx-common] needs rebuild against openssl 1.0.1

Attached to Project: Arch Linux
Opened by xduugu (xduugu) - Thursday, 15 March 2012, 01:17 GMT
Last edited by Pierre Schmitz (Pierre) - Thursday, 15 March 2012, 20:16 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To Tobias Powalowski (tpowa)
Pierre Schmitz (Pierre)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
nx-common needs a rebuild against the latest openssl release.

Error message when trying to connect to a server using nxclient:

NX> 203 NXSSH running with pid: 5892
OpenSSL version mismatch. Built against 1000007f, you have 1000100f


Additional info:
* nx-common 3.5.0-3
* openssl 1.0.1-1


Steps to reproduce:
This task depends upon

Closed by  Pierre Schmitz (Pierre)
Thursday, 15 March 2012, 20:16 GMT
Reason for closing:  Fixed
Comment by Thomas B├Ąchler (brain0) - Thursday, 15 March 2012, 09:41 GMT
Why does openssl break ABI without bumping the library version? This is ridiculous.
Comment by Pierre Schmitz (Pierre) - Thursday, 15 March 2012, 17:50 GMT Comment by Pierre Schmitz (Pierre) - Thursday, 15 March 2012, 18:23 GMT
Does nx-common-3.5.0-4 work for you?
Comment by xduugu (xduugu) - Thursday, 15 March 2012, 19:22 GMT
Yes, it works with nxclient.

Loading...