Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#28891 - [kdepim-kalarm] Kalarm doesn't save changes to alarms

Attached to Project: Arch Linux
Opened by David Rosenstrauch (darose) - Tuesday, 13 March 2012, 13:45 GMT
Last edited by Andrea Scarpino (BaSh) - Thursday, 15 March 2012, 13:53 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Andrea Scarpino (BaSh)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:

Kalarm no longer will save changes to existing alarms; I can only create new ones.

Additional info:
* package version: 4.8.1-2


Steps to reproduce:
* Launch kalarm from the console. (i.e., $ kalarm)
* Edit an existing alarm.
* Change the alarm time.
* Click OK.
* GUI displays error dialog saying: "Error saving alarm"
* Console displays error saying: "kalarm(2504): Old event not found"

I believe this is a recent breakage, resulting from a recent package upgrade (perhaps the upgrade to kde 4.8.1?) since I don't remember seeing this until very recently.

Perhaps this is an upstream bug? Whatever it is, it's pretty severe, as it pretty much renders kalarm useless.
This task depends upon

Closed by  Andrea Scarpino (BaSh)
Thursday, 15 March 2012, 13:53 GMT
Reason for closing:  Fixed
Additional comments about closing:  kdepim-kalarm 4.8.1-3
Comment by David Rosenstrauch (darose) - Tuesday, 13 March 2012, 15:09 GMT
Ugh - it's even worse: you can't delete alarms either!
Comment by David Rosenstrauch (darose) - Wednesday, 14 March 2012, 16:48 GMT
Screenshot
Comment by zless (roentgen) - Wednesday, 14 March 2012, 19:17 GMT
I confirm both issues.
Comment by David Rosenstrauch (darose) - Wednesday, 14 March 2012, 19:58 GMT
Thanks for the confirm.

Was about to file an upstream bug for this, but it looks like one already existed:

https://bugs.kde.org/show_bug.cgi?id=295926

It looks there's a fix for this going into KDE 4.8.2 (git commit ae66e32fb194e01e06521c78e9c72d772d291261 - see https://bugs.kde.org/show_bug.cgi?id=295926#c1). Any chance Arch could release a fixed version of the kalarm 4.8.1 package that includes that fix, before 4.8.2 gets released? This is a pretty severe bug, and really cripples kalarm's functionality the way things stand right now.

Loading...