Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#28859 - [linux] acpi creates high interrupts

Attached to Project: Arch Linux
Opened by Haochen Tong (hexchain) - Sunday, 11 March 2012, 05:32 GMT
Last edited by Tobias Powalowski (tpowa) - Monday, 12 November 2012, 08:15 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Tobias Powalowski (tpowa)
Thomas Bächler (brain0)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

Description:
acpi is creating too many interrupts, draining battery a lot.

Additional info:
This bug is there since I've installed Arch.
PowerTOP output:

Wakeups-from-idle per second : 10839.5 interval: 10.0s
no ACPI power usage estimate available

Top causes for wakeups:
98.2% (23534.8) [acpi] <interrupt>
0.9% (214.9) [Rescheduling interrupts] <kernel IPI>
0.3% ( 62.9) [uhci_hcd:usb3, mmc0, jmb38x_ms:slot0, firewire_ohci, nvidia]
0.2% ( 51.4) swapper/1
0.2% ( 47.7) swapper/0
0.1% ( 31.4) firefox

   foo (1.9 KiB)
This task depends upon

Closed by  Tobias Powalowski (tpowa)
Monday, 12 November 2012, 08:15 GMT
Reason for closing:  No response
Comment by Jelle van der Waa (jelly) - Tuesday, 13 March 2012, 11:39 GMT
And in other distro's it doesn't? Added your log as attachment named foo.
Comment by Alexander F. Rødseth (xyproto) - Tuesday, 13 March 2012, 14:18 GMT
Thanks for reporting. Please report this upstream at:
http://sourceforge.net/tracker/?func=browse&group_id=230605&atid=1080675
Comment by Haochen Tong (hexchain) - Wednesday, 14 March 2012, 13:16 GMT
@jelly: I didn't see this bug when I was using Fedora on the same computer.

@trontonic: I've reported it here: https://sourceforge.net/tracker/?func=detail&aid=3504352&group_id=230605&atid=1080675
Comment by Alexander F. Rødseth (xyproto) - Wednesday, 14 March 2012, 14:12 GMT
Great, thanks.
Comment by Jelle van der Waa (jelly) - Wednesday, 14 March 2012, 16:49 GMT
WEll we don't know what magic fedora uses.
Comment by Gaetan Bisson (vesath) - Tuesday, 03 April 2012, 08:28 GMT
Is this really an ACPI client bug? It seems to me that those interrupts are generated by the kernel: powertop says "[acpi]" not "acpi"... I'll add Thomas and Tobias as assignees, see what they think.

Hexchain: Which linux package and version are you running? And also what version is your ACPI client?
Comment by wes (wes) - Wednesday, 04 April 2012, 04:37 GMT
I also have this very same issue. Here is some system information:

$ pacman -Qi linux
Name : linux
Version : 3.2.13-1
URL : http://www.kernel.org/
...
Packager : Tobias Powalowski <...>
Architecture : x86_64
Build Date : Sat Mar 24 04:19:04 2012
Install Date : Tue Mar 27 00:34:23 2012
...

pacman -Qi acpi
Name : acpi
Version : 1.6-1
URL : http://sourceforge.net/projects/acpiclient
...
Packager : Dan McGee <...>
Architecture : x86_64
Build Date : Sun Jan 29 22:40:16 2012
Install Date : Tue Mar 27 04:03:32 2012
...

Please let me know how else I can help.
Comment by Haochen Tong (hexchain) - Wednesday, 04 April 2012, 05:50 GMT
One of my friends, who is using Archlinux on his ThinkPad, don't have this issue.

Package version:
$ pacman -Q linux acpi
linux 3.3-1
acpi 1.6-1
Comment by Haochen Tong (hexchain) - Wednesday, 04 April 2012, 05:54 GMT
And it seems that no dev of acpiclient project is interested in the tracker...
Comment by wes (wes) - Wednesday, 04 April 2012, 06:54 GMT
I don't know how much this will increase people's interest in the bug, but it may be worthwhile to note that it has more ill-effects than just power consumption. It costs me about a factor of two for the time of some arithmetic operations:
https://bbs.archlinux.org/viewtopic.php?id=138780
Comment by wes (wes) - Friday, 06 April 2012, 20:56 GMT
I found a possible solution. I was trying to figure the source of the gpe storm, and thought maybe it could be the battery. So, I turned off the machine, removed the battery, and rebooted. And behold! No more acpi interrupt issues. That already made me happy. Then, I turned off the machine, put the battery back, and rebooted... and there are *still* no acpi interrupts... o_O

I don't have a lot of intuition for why on earth this worked, so I still feel uneasy about it. But I hope it will help you out.
Comment by Haochen Tong (hexchain) - Sunday, 08 April 2012, 03:10 GMT
@wes: This doesn't work for me. Did you make any other changes to you system?
Comment by wes (wes) - Sunday, 08 April 2012, 03:49 GMT
Yes, actually. And some of them are glaring omissions, but the boot sans battery was the only thing that appeared to have an effect. Maybe it was just the final step of the solution though... o.o

Anyway, here are other things I did first:

Added some kernel boot parameters. It currently looks like this:

kernel /vmlinuz-linux root=/dev/disk/by-uuid/... ro acpi_os_name="Microsoft Windows NT" i915.i915_enable_rc6=1 i915.lvds_downclock=1

The acpi_os_name=... was the most recent change.

The glaring omission is that I compiled my own kernel. But I didn't mention this for two reasons: the first is that I no longer have the problem when I boot the stock kernel. The second is that aside from setting up the architecture more specifically for my processor, I didn't change much of the configuration. I know, still glaring. I can send you the .config file if needed. Let me know if you get it to work... it has a big impact on performance. Also, my system runs 8-9 degrees cooler now and the battery lasts much longer.

Just to be clear, are you having the same number of interrupts with the battery removed? Or only once you put it back?
One last thing I thought of: I think the battery was partially discharged (perhaps 70-80% left) when I performed the above steps. No idea if this matters.
Comment by F toda O (Loch1985) - Sunday, 06 May 2012, 19:21 GMT
Had same Issue and the workaround with the battery worked.

I thought it was caused by my broadcom wireless chip as described here:
https://bbs.archlinux.org/viewtopic.php?id=141036

I'm right now booting without the boot parameter:
acpi_os_name="Microsoft Windows NT"

and it still works...

Same problem appeared with Fedora 15/16 kernel 3.0 - 3.3
Comment by Alexander F. Rødseth (xyproto) - Monday, 07 May 2012, 13:10 GMT
As I understand, this isn't a problem with the acpi-client ("acpi" packgage), but acpid and/or the kernel.
Changing subject and reassigning.
Comment by Haochen Tong (hexchain) - Thursday, 10 May 2012, 14:58 GMT
Yes, I can confirm that after applying acpi_os_name parameter to kernel, acpi no longer wakes up too much.

I'm using Broadcom Corporation NetLink BCM5784M Gigabit Ethernet PCIe (rev 10).
Comment by Sébastien Luttringer (seblu) - Thursday, 10 May 2012, 21:53 GMT
It does not seem to be talked about acpid, but acpi kernel thread.
These looks like a kernel issue and not archlinux related. Should probably reported upstream.
Comment by Greg (dolby) - Monday, 15 October 2012, 09:47 GMT
Still a problem with 3.6.2?
Comment by Haochen Tong (hexchain) - Tuesday, 16 October 2012, 05:59 GMT
@dolby: I'm sorry I can't do any test about this issue any more. That old laptop has been given to other people and the current one I'm using doesn't have such problem at all.

To others in this thread: Please help test, thank you!

Loading...