Pacman

Welcome to the Pacman bug tracker. Please search the current bugs and feature requests before filing a new one! Use advanced search and select "Search in Comments".

* Please select the correct category and version.
* Write a descriptive summary, background info, and provide a reproducible test case whenever possible.
Tasklist

FS#28823 - installation notes should be recognizable in the output

Attached to Project: Pacman
Opened by Pierpaolo Valerio (gondsman) - Thursday, 08 March 2012, 13:58 GMT
Last edited by Dan McGee (toofishes) - Thursday, 08 March 2012, 14:35 GMT
Task Type Feature Request
Category Output
Status Closed
Assigned To No-one
Architecture All
Severity Medium
Priority Normal
Reported Version 4.0.2
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Summary and Info:
When pacman upgrades or installs packages containing post-install or pre-install scripts meant to display useful information to the user, messages are "buried" among standard pacman output, so that during operations on large number of packages, they can be easily missed. An example of a package producing important output during the installation is the Linux kernel. There are also many AUR packages which display any kind of useful information after their installation (e.g. catalyst).
In order to better explain how I think the output should be organized, we can take emerge, the package manager used by Gentoo, as an example. It displays important messages about packages after everything else in its output, so that the user can immediately look through them after a full system update.
In my opinion having an option to display these information at the end of the output, in a clearer way, or at least the possibility of saving these lines in a separate log file, would be a nice improvement for pacman. It would also allow maintainers to consistently display infos about package upgrades after the update process, if for example the update requires manual operations by the user (the kind of notices usually posted on archlinux.org homepage).
This task depends upon

Closed by  Dan McGee (toofishes)
Thursday, 08 March 2012, 14:35 GMT
Reason for closing:  Duplicate
Additional comments about closing:  See comments on  FS#12861  as to why we won't fix this.
Comment by Dan McGee (toofishes) - Thursday, 08 March 2012, 14:35 GMT
Duplicate of  FS#12861 ,  FS#28794 .

Loading...