Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#28801 - [mplayer] interrupted by signal 11 in module: decode_video

Attached to Project: Arch Linux
Opened by bloger (bloger) - Tuesday, 06 March 2012, 11:54 GMT
Last edited by Ionut Biru (wonder) - Saturday, 07 July 2012, 16:30 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Ionut Biru (wonder)
Architecture i686
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


Description: This problem appear today immediately after executing "pacman -Syu" command. Looks like "upstream". Did you test own package before issue it? Where I can get previous package version?

Additional info:
* package version(s) mplayer 34799
* config and/or log files etc.
vo = sdl

MPlayer UNKNOWN-4.6.3 (C) 2000-2012 MPlayer Team
183 audio & 398 video codecs
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.

libavformat version 54.2.100 (internal)
AVI file format detected.
[aviheader] Video stream found, -vid 0
[aviheader] Audio stream found, -aid 1
VIDEO: [xvid] 640x480 24bpp 25.000 fps 1025.4 kbps (125.2 kbyte/s)
Clip info:
Software: Lavf53.31.100
Load subtitles in ./
[VO_SDL] Using driver: x11.
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
libavcodec version 54.8.100 (internal)
Unsupported PixelFormat 61
Unsupported PixelFormat 53
Unsupported PixelFormat 81
Selected video codec: [ffodivx] vfm: ffmpeg (FFmpeg MPEG-4)
Opening audio decoder: [mpg123] MPEG 1.0/2.0/2.5 layers I, II, III
AUDIO: 44100 Hz, 2 ch, s16le, 112.0 kbit/7.94% (ratio: 14000->176400)
Selected audio codec: [mpg123] afm: mpg123 (MPEG 1.0/2.0/2.5 layers I, II, III)
AO: [alsa] 44100Hz 2ch s16le (2 bytes per sample)
Starting playback...
[mpeg4 @ 0x8b49580]Invalid and inefficient vfw-avi packed B frames detected
Movie-Aspect is 1.33:1 - prescaling to correct movie aspect.
VO: [sdl] 640x480 => 640x480 Planar YV12 [fs]
[ASPECT] Warning: No suitable new res found!
w/h: 640 400
[VO_SDL] Info - please use -vm or -zoom to switch to the best resolution.

MPlayer interrupted by signal 11 in module: decode_video
- MPlayer crashed by bad usage of CPU/FPU/RAM.
Recompile MPlayer with --enable-debug and make a 'gdb' backtrace and
disassembly. Details in DOCS/HTML/en/bugreports_what.html#bugreports_crash.
- MPlayer crashed. This shouldn't happen.
It can be a bug in the MPlayer code _or_ in your drivers _or_ in your
gcc version. If you think it's MPlayer's fault, please read
DOCS/HTML/en/bugreports.html and follow the instructions there. We can't and
won't help unless you provide this information when reporting a possible bug.
Parent process disappeared, exiting cache process.

Steps to reproduce:
pacman -Syu && mplayer file.avi
This task depends upon

Closed by  Ionut Biru (wonder)
Saturday, 07 July 2012, 16:30 GMT
Reason for closing:  Works for me
Comment by Ionut Biru (wonder) - Tuesday, 06 March 2012, 12:06 GMT
of course I tested the package and works fine for me.

is that our package? because i see MPlayer UNKNOWN-4.6.3 instead of MPlayer SVN-r34799-4.6.3 (C) 2000-2012 MPlayer Team
Comment by bloger (bloger) - Wednesday, 07 March 2012, 07:52 GMT
I build my own package when discover this problem. Don't care about reported version, both have the same termination reason. You did not answer - where I can get previous mplayer package?
Comment by Kevin (anonymous_user) - Wednesday, 07 March 2012, 18:37 GMT