Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#28759 - [mplayer] mplayer fail to build

Attached to Project: Arch Linux
Opened by Maxime de Roucy (akira86) - Saturday, 03 March 2012, 12:15 GMT
Last edited by Ionut Biru (wonder) - Monday, 05 March 2012, 09:37 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Ionut Biru (wonder)
Giovanni Scafora (giovanni)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


Mplayer fail to build with the error :
libmpdemux/demux_rtp.cpp: In function 'char* openURL_rtsp(RTSPClient*, const char*)':
libmpdemux/demux_rtp.cpp:99:20: error: 'class RTSPClient' has no member named 'describeWithPassword'
libmpdemux/demux_rtp.cpp:101:20: error: 'class RTSPClient' has no member named 'describeURL'

This is due to the fact that RTSPCLIENT_SYNCHRONOUS_INTERFACE isn't defined anymore in the new live-media version. And so describeWithPassword isn't defined anymore in the RTSPClient class. See /usr/include/liveMedia/RTSPClient.hh line 288.

I had to add "--disable-live" to the configure statement in the PKGBUILD in order to build mplayer.

Additional info:
* mplayer package version : 34426-3
* live-media package version : 2012.02.29-1

Steps to reproduce:
install live-media and try to makepkg mplayer.
This task depends upon

Closed by  Ionut Biru (wonder)
Monday, 05 March 2012, 09:37 GMT
Reason for closing:  Fixed
Additional comments about closing:  live-media-2012.02.29-2
Comment by Ionut Biru (wonder) - Sunday, 04 March 2012, 18:50 GMT
mplayer didn't fix this issue upstream yet but we can workaround around this.

For that we need to
1) recompile live-media with -DRTSPCLIENT_SYNCHRONOUS_INTERFACE=1
2) "#define"ing RTSPCLIENT_SYNCHRONOUS_INTERFACE before "include/RTSPClient.hh" is included for the first time.

@Giovanni is it ok if we do this until is fixed properly by mplayer?
Comment by Giovanni Scafora (giovanni) - Sunday, 04 March 2012, 23:24 GMT
@Ionut it's ok for me. Go ahead.