Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#28724 - eclipse crashes when xulrunner is installed

Attached to Project: Arch Linux
Opened by Otto Allmendinger (OttoA) - Thursday, 01 March 2012, 09:21 GMT
Last edited by Ionut Biru (wonder) - Thursday, 01 March 2012, 19:41 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Ionut Biru (wonder)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

This is basically the same problem as https://bugs.archlinux.org/task/27130


Installed packages

eclipse 3.7.2-1
xulrunner 10.0.2-1

Steps

1. Open Java Project
2. Hover mouse over a method identifier
[boom]


Traceback


# A fatal error has been detected by the Java Runtime Environment:
#
# SIGSEGV (0xb) at pc=0x8959fa54, pid=25451, tid=3076187840
#
# JRE version: 7.0_03-b147
# Java VM: OpenJDK Client VM (22.0-b10 mixed mode linux-x86 )
# Derivative: IcedTea7 2.1
# Distribution: Custom build (Wed Feb 15 15:35:38 UTC 2012)
# Problematic frame:
# C [UTF-16.so+0xa54] gconv+0x374
#
# Failed to write core dump. Core dumps have been disabled. To enable core dumping, try "ulimit -c unlimited" before starting Java again

Fix:

Add the line -Dorg.eclipse.swt.browser.XULRunnerPath=/usr/lib/xulrunner-10.0.2/ to eclipse.ini

Adding -Dorg.eclipse.swt.browser.UseWebKitGTK=true does not seem to work anymore, but when xulrunner is not installed everything works fine, even if the XULRunnerPath is set in eclipse.ini.
This task depends upon

Closed by  Ionut Biru (wonder)
Thursday, 01 March 2012, 19:41 GMT
Reason for closing:  Fixed
Additional comments about closing:  added xul to conflicts in 3.7.2-2
Comment by Ionut Biru (wonder) - Thursday, 01 March 2012, 09:53 GMT
why do you even try to install xul and apply that workaround?

eclipse works perfectly fine without xul because is using libwebkit.

the best solution is to remove xulrunner.
Comment by Otto Allmendinger (OttoA) - Thursday, 01 March 2012, 10:14 GMT
Some people may need xulrunner installed.

See "required by" on http://www.archlinux.org/packages/extra/i686/xulrunner/

No package should break just because another package is installed on the system.

Comment by Ionut Biru (wonder) - Thursday, 01 March 2012, 10:20 GMT
is not our problem, really. our eclipse is the one precompiled and it comes with xul 1.9.2 support. We do not support this version and newer versions are not compatible.
Comment by Otto Allmendinger (OttoA) - Thursday, 01 March 2012, 10:24 GMT
then add conflicts=("xulrunner>1.9.2") to the PKGBUILD please
Comment by Ionut Biru (wonder) - Thursday, 01 March 2012, 18:55 GMT
i'll add conflicts=('xulrunner') to cover all versions. If you try to downgrade xul to 1.9.2 you are doing it wrong because it won't work with current packages available in arch.

Loading...