Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#28711 - [xorg-fonts-encodings] PLEASE ENTER SUMMARY

Attached to Project: Arch Linux
Opened by KATO Hiroshi (katoh) - Wednesday, 29 February 2012, 11:41 GMT
Last edited by Allan McRae (Allan) - Tuesday, 06 March 2012, 08:16 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Andreas Radke (AndyRTR)
Allan McRae (Allan)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
When I upgraded xorg-fonts-encodings to 1.0.4-2 from 1.0.4-1, freetype always says

"Freetype couldn't find encoding 'jisx0208.1983-0' for (fontpath)"

in /var/log/Xorg.0.log and Japanese characters are not displayed with those fonts.

So I downgraded xorg-fonts-encodings to 1.0.4-1, the problem has resolved.
http://ftp.yz.yamagata-u.ac.jp/pub/linux/chakra/platform/i686/xorg-fonts-encodings-1.0.4-1-any.pkg.tar.xz

Because of this, I think 1.0.4-2 has a bug.

This problem is also resolved by this way.

# rm /usr/share/fonts/encodings/encodings.dir /usr/share/fonts/encodings/large/encodings.dir
# mkfontdir -n -e /usr/share/fonts/encodings/
# mkfontdir -n -e /usr/share/fonts/encodings/large

Additional info:
* package version(s)
xorg-fonts-encodings 1.0.4-2

* config and/or log files etc.
none

Steps to reproduce:
Upgrade to 1.0.4-2
This task depends upon

Closed by  Allan McRae (Allan)
Tuesday, 06 March 2012, 08:16 GMT
Reason for closing:  Fixed
Additional comments about closing:  1.0.4-3
Comment by Andreas Radke (AndyRTR) - Wednesday, 29 February 2012, 17:23 GMT
Hm. Can you check what is different in both packages? Acording to the commit log is was a simple rebuild.

Allan?
Comment by KATO Hiroshi (katoh) - Wednesday, 29 February 2012, 22:05 GMT
I compared all contain files in two versions, and found 1.0.4-2 's encodings.dir is sorted.
I don't know why but this does affect freetype.
Comment by Allan McRae (Allan) - Tuesday, 06 March 2012, 08:15 GMT
Fun bug... the encodings files are generated before installation and both the compressed and non-compressed versions exist. The non-compressed versions do not get installed so the encodings.dir file is wrong... Having it sorted put the non-compressed entry for jisx0208.1983-0 before the compressed entry causing this issue.

Loading...