Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#28699 - [xfig] 3.2.5b-7 hangs when any operation selected

Attached to Project: Arch Linux
Opened by Peter Ross (peterross) - Tuesday, 28 February 2012, 13:04 GMT
Last edited by Eric Belanger (Snowman) - Monday, 02 April 2012, 00:26 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Eric Belanger (Snowman)
Architecture i686
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

xfig starts OK, and I can select "Grid mode" and choose a grid successfully.
But if I the try to select a drawing operation such as drawing a rectangle,
the program hangs before it can show the options buttons across the bottom.
'top' reports that xfig is in the run queue and using 100%. The window's "Close"
button is ineffective, program has to be killed to stop it.


Additional info:
* package version(s): xfig 3.2.5b-7

System fully up to date as at Feb 28 2012, linux-3.2.7-1, KDE 4.8.00
xfig-3.2.5b-5 (installed Jan 16) worked OK on the same hardware.
xfig-3.2.5b-7 was installed Feb 6, but has not been used until now, when this
bug showed up. Other drawing programs such as inkscape still work OK.

A thought: there have been some significant upgrades of other packages since I
last used xfig a month or so ago, e.g. font handling. Unlikely to be an upstream
problem: the latest xfig release works OK on a Mandriva system that I also use.





Steps to reproduce:

See the description above.
This task depends upon

Closed by  Eric Belanger (Snowman)
Monday, 02 April 2012, 00:26 GMT
Reason for closing:  Fixed
Additional comments about closing:  xfig-3.2.5b-8 uses libxaw instead of xaw3d. Should fix the problems mentionned here.
Comment by Peter Ross (peterross) - Tuesday, 28 February 2012, 14:30 GMT

Additional information: I tried recompiling the source (with patches to f_readpng.c, f_wrpng.c,..) and the same problem recurred. I then tried commenting out the "#define XAW3D" in the Imakefile, and the bug disappears, though it does have a problem finding fonts.
Progress! The earlier working version used libxaw3d 1.5E-3, the buggy version used libxaw3d 1.6-1.
Comment by Karol Błażewicz (karol) - Tuesday, 28 February 2012, 14:38 GMT
Cannot reproduce on my 32-bit Arch.
Comment by Luis Sarmiento (donpicoro) - Tuesday, 28 February 2012, 16:56 GMT
I filed a report about xfig being broken with the upgrade of libxaw3d. The bug report was closed since the solution was accepted upstream but the fix hasn't downstream yet AFAIK:

https://bugs.archlinux.org/task/28318

Perhaps this error is related with the other -already closed- one?
check if you can apply the mentioned workaround.

Edit: mmm it seems this should have been solved with xaw3d 1.6.1. bummer !
Comment by Sven (avanc) - Sunday, 11 March 2012, 13:42 GMT
I have the same problem. However, it doesn't seem to be related to xaw3d. First, xfig doesn't need xaw3d (it wasn't installed on my machine). Second, xaw3d-1.6.1-1 has the mentoned patch included.
Comment by Sven (avanc) - Sunday, 11 March 2012, 13:49 GMT
I was wrong, xfig depends on xfig. However, the problem still exists.
Comment by Lóránt Farkas (farkaslory) - Sunday, 18 March 2012, 15:08 GMT
I have exactly the same problem on my X86_64 box.
Comment by Lóránt Farkas (farkaslory) - Sunday, 18 March 2012, 15:25 GMT
Deleting the line

#define XAW3D

also worked!
Comment by Lóránt Farkas (farkaslory) - Sunday, 18 March 2012, 15:32 GMT
It is possible to package the file (at least in the 64-bit version, and at least till the problem disappears) without depending on the XAW3d widget set?
I use this program for my work, so it is quite annoying that it doesn't work because of a buggy widget set (which widget set I never use).
Comment by Eric Belanger (Snowman) - Sunday, 18 March 2012, 19:17 GMT
I can't reproduce that on x86_64. I'll need some time to find what is causing the problem. Meanwhile, you can rebuild it with ABS without the "#define XAW3D" if that make it work for you.
Comment by Florian Wickert (float) - Saturday, 24 March 2012, 12:48 GMT
I can confirm that bug. Tested on two machines (x86).
Removing "#define XAW3D" works out for me, too!

Loading...