Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#28685 - [mercurial] Unable to update *-hg packages due to return code problem

Attached to Project: Arch Linux
Opened by jstjohn (jstjohn) - Monday, 27 February 2012, 18:09 GMT
Last edited by Giovanni Scafora (giovanni) - Wednesday, 29 February 2012, 09:45 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Giovanni Scafora (giovanni)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No


Description: With the current version of mercurial in [extra], which is version 2.1-1, users cannot build *-hg development packages in the AUR. The problem arises from a return code change that upstream put in mercurial 2.1. I documented the things I noticed in the comments of [1]. Upstream has already reversed the commit in their 'stable' branch[2], but upstream has not released a stable 2.1.1 or 2.2 version yet. I am requesting that the mercurial package in [extra] have that commit reversed and re-released as 2.1-2. According to [3], there will probably be a 2.1.1 or 2.2 released around 2012-03-01, so if this is true, just ignore this bug report.


Additional info:
* package version: 2.1-1

Steps to reproduce:

* Install an AUR package that uses hg
* Try to update the package
* Receive this error:
==> ERROR: A failure occurred in build().
This task depends upon

Closed by  Giovanni Scafora (giovanni)
Wednesday, 29 February 2012, 09:45 GMT
Reason for closing:  Fixed
Comment by Giovanni Scafora (giovanni) - Tuesday, 28 February 2012, 20:55 GMT
Just pushed to [extra] mercurial-2.1-2
Please, let me know if it works now, so I can close this bug report.
Comment by jstjohn (jstjohn) - Wednesday, 29 February 2012, 00:42 GMT
I just tested this multiple times with ttf-google-webfonts, and it worked every time without issue. Thanks for the quick turnaround! :)