Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#28667 - pacman reporting wrong architecture on b43 upgrade

Attached to Project: Arch Linux
Opened by Kevin Hutson (mrjabba) - Sunday, 26 February 2012, 21:10 GMT
Last edited by Allan McRae (Allan) - Tuesday, 28 February 2012, 03:08 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To No-one
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

I tried upgrading on February 11, 2012. I had a version of Arch that was a few months old (September/October 2011).

Prior to upgrade, I removed the b43-firmware package as instructed by a forum post.
I upgraded without issue.
When I grabbed the latest b43-firmware package, I get this error when trying to to run:
sudo pacman -U b43-firmware-5.100.138-1-i686.pkg.tar.xz
Now, this SHOULD have generated a 64 bit package. I am on 64 bit.
And, I have verified that a 64-bit package exists with the package maintainer.

I have comments posts on the package and also a discussion in the forum.
I have provided the links to avoid duplication.

My real problem is not the error message, but that pacman will not build a 64-bit version of b43-firmware.
The package maintainer requested that I file a bug report for pacman.

https://aur.archlinux.org/packages.php?ID=21690&comments=all
https://bbs.archlinux.org/viewtopic.php?pid=1062104#p1062104

Additional info:
* package version(s)
Pacman v4.0.2 - libalpm v7.0.2
b43-firmware 5.100.138-1

* config and/or log files etc.
https://gist.github.com/1919000 - my pacman.conf file
https://gist.github.com/1919006 - my rc.conf file

Steps to reproduce:

Given an existing Arch 64 bit installation,
Remove existing b43-firmware installation
Upgrade Arch on your 64 bit system
Try to build new b43-firmware package.
It will build a 32-bit package instead of a 64-bit one.
And that one is not installable.
Reports: package b43-firmware-5.100.138-1-i686 does not have a valid architecture

This task depends upon

Closed by  Allan McRae (Allan)
Tuesday, 28 February 2012, 03:08 GMT
Reason for closing:  Not a bug
Comment by Dave Reisner (falconindy) - Sunday, 26 February 2012, 21:34 GMT
The fact that you're generating i686 packages means that your makepkg.conf has CARCH=i686 in it. Even the package maintainer on the AUR pointed this out and you ignored it. I don't see that config file here, either.

This is no bug in pacman or makepkg.
Comment by Kevin Hutson (mrjabba) - Monday, 27 February 2012, 10:34 GMT
Actually, no.
This is what I have for makepkg.conf

CARCH="x86_64"
CHOST="x86_64-unknown-linux-gnu"

And the full file is available here:
https://gist.github.com/1919255

I didn't ignore that comment. Rather, I missed it as it was minutes between my other reply.
Thanks for your quick reply. I was merely doing as the package maintainer asked.
Regards,
Kevin
Comment by Allan McRae (Allan) - Monday, 27 February 2012, 10:34 GMT
what about ~/.makepkg.conf?
Comment by Kevin Hutson (mrjabba) - Tuesday, 28 February 2012, 03:05 GMT
Wow. I didn't even know I had that file.

from ~/.makepkg.conf
CARCH="i686"
CHOST="i686-pc-linux-gnu"
CFLAGS="-march=i686 -O2 -pipe -m32"
CXXFLAGS="${CFLAGS}"

I'm assuming I should go ahead and change those to this?
CARCH="x86_64"
CHOST="x86_64-unknown-linux-gnu"
CFLAGS="-march=x86-64 -mtune=generic -O2 -pipe -fstack-protector --param=ssp-buffer-size=4 -D_FORTIFY_SOURCE=2"
CXXFLAGS="-march=x86-64 -mtune=generic -O2 -pipe -fstack-protector --param=ssp-buffer-size=4 -D_FORTIFY_SOURCE=2"
thanks so much.



Comment by Dave Reisner (falconindy) - Tuesday, 28 February 2012, 03:06 GMT
Or just get rid of it...

Loading...