Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#28616 - [vlc] segfault when loading icecast list

Attached to Project: Arch Linux
Opened by AaronP (Bellum) - Friday, 24 February 2012, 01:42 GMT
Last edited by Giovanni Scafora (giovanni) - Friday, 24 February 2012, 20:27 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Giovanni Scafora (giovanni)
Architecture i686
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Segfault when loading icecast list. Seems to be new with pkgrel 5.


Additional info:
[0x93a80a0] dbus interface: listening on dbus as: org.mpris.MediaPlayer2.vlc
[0x93118f0] main libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.
QGtkStyle was unable to detect the current GTK+ theme.
[0xb3aa15a0] lua services discovery error: Error loading script /usr/lib/vlc/lua/sd/icecast.luac: lua/sd/icecast.lua:22: attempt to call global 'require' (a nil value)
[0xb3aa15a0] lua services discovery error: 'meta' keys and values must be strings
[0xb3aa15a0] lua services discovery error: 'meta' keys and values must be strings
[0xb3aa15a0] lua services discovery error: 'meta' keys and values must be strings
(repeat this error a couple hundred times)
[0xb3aa15a0] lua services discovery error: 'meta' keys and values must be strings
[0xb3aa15a0] lua services discovery error: 'meta' keys and values must be strings
[0xb53c62b0] media_library media-library error: Invalid select type or unsupported: 0
[0xb53c62b0] media_library media-library error: Parsing failed for AND/OR
Segmentation fault



Steps to reproduce:
view -> playlist -> internet -> icecast radio directory
This task depends upon

Closed by  Giovanni Scafora (giovanni)
Friday, 24 February 2012, 20:27 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed in vlc-2.0.0-6
Comment by Giovanni Scafora (giovanni) - Friday, 24 February 2012, 16:37 GMT
Please, try with vlc-2.0.0-6 and let me know.
Comment by AaronP (Bellum) - Friday, 24 February 2012, 19:43 GMT
Yep, that fixed it. Though now search is broken again, something that's been a problem off and on in a few different version of the 2.0 pkg. Should I open another report?
Comment by Giovanni Scafora (giovanni) - Friday, 24 February 2012, 19:53 GMT
Do you remember which version was working well?
By the way, check out your system, because search works fine here
Comment by AaronP (Bellum) - Friday, 24 February 2012, 19:59 GMT
Hmm. IIRC, it was working ok in the version that came before 5 (3?), but I'm not sure.
Comment by Giovanni Scafora (giovanni) - Friday, 24 February 2012, 20:00 GMT
I'm just trying search and works fine here...
I cannot reproduce that issue
Comment by AaronP (Bellum) - Friday, 24 February 2012, 20:04 GMT
Check what? This is the error I'm getting.

[0x88ea678] qt4 interface error: SEARCHING DELAYED
[0xb3b1a0b0] lua services discovery error: The script '/usr/lib/vlc/lua/sd/icecast.luac' does not define any 'search' function

I'm not sure how this could be related to something else.
Comment by Giovanni Scafora (giovanni) - Friday, 24 February 2012, 20:14 GMT
I cannot reproduce that issue on my system. ( look at http://www.freeimagehosting.net/llqcq )
You could remove/rename your ~/.config/vlc trying if it works again
Comment by AaronP (Bellum) - Friday, 24 February 2012, 20:25 GMT
+1, that fixes the issue.

Loading...