Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#28599 - [perl] Missing provides

Attached to Project: Arch Linux
Opened by Piotr Rogo┼╝a (dracorp) - Thursday, 23 February 2012, 09:33 GMT
Last edited by Justin Davis (juster) - Saturday, 25 February 2012, 20:39 GMT
Task Type Feature Request
Category Packages: Core
Status Closed
Assigned To Kevin Piche (kpiche)
Florian Pritz (bluewind)
Justin Davis (juster)
Architecture All
Severity Very Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No



Missing provides.

Additional info:
* package version(s) 5.14.2-7

Steps to reproduce:

Add to the provides: perl-test-builder perl-test-builder-io-scalar perl-test-builder-tester perl-test-builder-tester-color perl-test-more

For more info:
This task depends upon

Closed by  Justin Davis (juster)
Saturday, 25 February 2012, 20:39 GMT
Reason for closing:  Not a bug
Additional comments about closing:  provides list is for core CPAN _dists_ only
Comment by Florian Pritz (bluewind) - Saturday, 25 February 2012, 20:03 GMT
Test::More is part of the Test::Simple distribution. Since only outputs the distribution name, I assume the other modules you listed are part of something else too.

Justin please take a look and close/fix if necessary.

Edit: If you click the link in the description, you see that they are indeed part of Test::Simple. I wonder how I missed that, given that I looked at this page to check if Test::More is in it.
Comment by Justin Davis (juster) - Saturday, 25 February 2012, 20:38 GMT
Yeah I specifically did not want to provide modules. I only wanted to provide distributions. Package authors should only depend on perl-test-simple for the Test-Simple distribution and not depend on modules inside of them; such as perl-test-builder for the Test::Builder module. Perl distributions define their dependencies on modules and not distributions. The provides list is not built to encourage similar dependencies of packages upon versions of files.