Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#28578 - htop-1.0.1-1 Has Incorrect Exec= In htop.desktop

Attached to Project: Arch Linux
Opened by Das (DasFox) - Wednesday, 22 February 2012, 05:30 GMT
Last edited by Andrea Scarpino (BaSh) - Thursday, 23 February 2012, 21:48 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description: On Arch i686 htop-1.0.1-1 I has the incorrect information for Exec= in htop.desktop

Additional info:
* package version(s)
htop-1.0.1-1

* config and/or log files etc.
This is the cmd in the htop.desktop
Exec=htop

Steps to reproduce:

htop needs a terminal to run from, it can't be simply run from a name as Exec=htop

Everyone will have their own likes and dislikes for colors, but I personally think running it from a black terminal makes things stand out better.

This is the way in which it should at least be done for now, unless someone has a better idea...

Exec=xterm -ls -fg white -bg black -geometry 95x25 -T htop -e htop

THANKS
This task depends upon

Closed by  Andrea Scarpino (BaSh)
Thursday, 23 February 2012, 21:48 GMT
Reason for closing:  Not a bug
Additional comments about closing:  Everything's fine
Comment by Ionut Biru (wonder) - Wednesday, 22 February 2012, 07:39 GMT
works perfectly fine in the way is in gnome
Comment by Antonio Rojas (arojas) - Wednesday, 22 February 2012, 07:45 GMT
The .desktop file already has a "Terminal=true" field
http://standards.freedesktop.org/desktop-entry-spec/latest/ar01s05.html

Loading...