Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#28572 - [laptop-mode-tools] wrong udevadm path

Attached to Project: Arch Linux
Opened by Soup (Soup) - Tuesday, 21 February 2012, 22:56 GMT
Last edited by Dave Reisner (falconindy) - Thursday, 01 March 2012, 16:50 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description: wrong udevadm path makes laptop-mode-tools hdparm use udevinfo, which doesn't exist.


Additional info:
* package version 1.60-1
* /usr/share/laptop-mode-tools/modules/hdparm: line 32: udevinfo: command not found

--- hdparm 2012-02-22 00:42:25.093811761 +0200
+++ hdparm.1 2012-02-22 00:43:26.854684982 +0200
@@ -26,7 +26,7 @@ is_capable() {
# It assumes more or less recent udev (> 070)
if [ $HAVE_UDEVINFO -ne 0 ] ; then
log "VERBOSE" "Querying $1 media type using udevinfo: "
- if [ -x /sbin/udevadm ]; then
+ if [ -x /usr/bin/udevadm ]; then
eval "$(udevadm info -q env -n $1 | egrep '(ID_TYPE=|ID_BUS=)' )"
else
eval "$(udevinfo -q env -n $1 | egrep '(ID_TYPE=|ID_BUS=)' )"

Later on it (and what looks to be the standard for the script) uses a `which' to determine if udevadm is around, so maybe this would keep it in line:

- if [ -x /sbin/udevadm ]; then
+ if [ -x "$(which udevadm 2> /dev/null)" ]; then
This task depends upon

Closed by  Dave Reisner (falconindy)
Thursday, 01 March 2012, 16:50 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#28573 
Comment by Soup (Soup) - Tuesday, 28 February 2012, 09:31 GMT
  • Field changed: Percent Complete (100% → 0%)
Sorry to do this but I'm struggling to see how this bug is related to aif and pacman keys.
Comment by Dave Reisner (falconindy) - Thursday, 01 March 2012, 16:50 GMT
Closed as dupe of wrong bug... really, this is a dupe though.

Loading...