Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#28569 - linux 3.2.7-1 renders system unbootable when root is ext3

Attached to Project: Arch Linux
Opened by Dave Morgan (loafer) - Tuesday, 21 February 2012, 20:44 GMT
Last edited by Dave Reisner (falconindy) - Wednesday, 22 February 2012, 15:01 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To Tobias Powalowski (tpowa)
Thomas B├Ąchler (brain0)
Dave Reisner (falconindy)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:

Upgrading to linux 3.2.7-1 renders the system unbootable. I am dropped to a recovery shell with the error ext3 filesystem unknown.

Downgrading to 3.2.6-2 fixes the problem.

The upgrade appears to go smoothly and the initramfs reports it is successfully generated.

Steps to reproduce:

Upgrade to linux 3.2.7-1.
This task depends upon

Closed by  Dave Reisner (falconindy)
Wednesday, 22 February 2012, 15:01 GMT
Reason for closing:  Fixed
Additional comments about closing:  mkinitcpio 0.8.2-3
Comment by Dave Reisner (falconindy) - Tuesday, 21 February 2012, 20:51 GMT
Please post the contents of the "broken" initramfs with 'lsinitcpio -v'
Comment by Dave Morgan (loafer) - Tuesday, 21 February 2012, 21:02 GMT
File attached.
   initramfs (26.4 KiB)
Comment by Dave Reisner (falconindy) - Tuesday, 21 February 2012, 21:12 GMT
Add ext4 to MODULES and regenerate. That will at least give you a bootable image with 3.2.7-1. This is a fairly annoying bug which only happens in this one specific case because an alias exists as a module name.
Comment by Dave Reisner (falconindy) - Tuesday, 21 February 2012, 21:14 GMT
Alternatively, the fallback image should work as is.
Comment by Dave Morgan (loafer) - Tuesday, 21 February 2012, 21:20 GMT
Confirmed. Adding ext4 to modules allows 3.2.7-1 to boot.
Comment by Dave Reisner (falconindy) - Wednesday, 22 February 2012, 02:13 GMT
mkinitcpio-0.8.2-3 in testing should fix this.
Comment by Dave Morgan (loafer) - Wednesday, 22 February 2012, 05:22 GMT
Thanks. mkinitcpio-0.8.2-3 does fix this.

Loading...