Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#28529 - Systemd 43 : cannot mount DVD with /media/cdrom mount point.

Attached to Project: Arch Linux
Opened by Frederic Bezies (fredbezies) - Sunday, 19 February 2012, 21:41 GMT
Last edited by Dave Reisner (falconindy) - Monday, 20 February 2012, 14:06 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description: A very simple bug to reproduce.

I installed and configured systemd and I cannot get my DVDs to be mounted automatically in nautilus.

Here is the error message I get when double clicking on a DVD in nautilus :

"Error mounting: mount exited with exit code 1: helper failed with:
mount: mount point /media/cdrom does not exist"

Of course, when I disable systemd on start, dvd mounting works every single time.

Additional info:
systemd 43-2

Steps to reproduce:

Just install systemd, reboot and insert a DVD. After that, try to mount it. Automount doesn't work.
This task depends upon

Closed by  Dave Reisner (falconindy)
Monday, 20 February 2012, 14:06 GMT
Reason for closing:  Not a bug
Comment by Frederic Bezies (fredbezies) - Sunday, 19 February 2012, 21:43 GMT
Got this in .xsession-errors.log related to DVD mounting :

JS LOG: Unable to mount volume Disque de données (08 janv. 12): Error: Error invoking Gio.mount_finish: Error mounting: mount exited with exit code 1: helper failed with:
mount: mount point /media/cdrom does not exist
Comment by Frederic Bezies (fredbezies) - Sunday, 19 February 2012, 22:10 GMT
Forgot to add : deactivating or removing systemd restore DVD mounting.

Here is my lspci, IDE part :

00:08.0 IDE interface: NVIDIA Corporation MCP61 SATA Controller (rev a2)
00:08.1 IDE interface: NVIDIA Corporation MCP61 SATA Controller (rev a2)

And /etc/fstab (dvd part) :

/dev/cdrom /media/cdrom auto ro,user,noauto,unhide 0 0
/dev/dvd /media/dvd auto ro,user,noauto,unhide 0 0
/dev/dvdrw /media/dvdrw auto ro,user,noauto,unhide 0 0
Comment by Karol Błażewicz (karol) - Sunday, 19 February 2012, 22:35 GMT
Is the directory there?

[karol@black ~]$ ls /media/cdrom
ls: cannot access /media/cdrom: No such file or directory
Comment by Dave Reisner (falconindy) - Sunday, 19 February 2012, 22:41 GMT
You shoudn't expect these directories to exist -- /media gets a tmpfs mounted on it. Get rid of the mountpoint entries in fstab and let udisks take care of it.
Comment by Frederic Bezies (fredbezies) - Monday, 20 February 2012, 06:43 GMT
Will try this today by commenting these mountpoint entries. And as my installation is "old" (october 2010), maybe some changes in /etc/fstab where introduced since :)

Will report asap ;)
Comment by Frederic Bezies (fredbezies) - Monday, 20 February 2012, 07:34 GMT
Thanks for the fix. :)

And sorry for the spam, I did not notice /etc/fstab modification :(

Loading...