Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#28525 - pacman 4: no information about defective packages

Attached to Project: Arch Linux
Opened by new user (new-user) - Sunday, 19 February 2012, 19:37 GMT
Last edited by Allan McRae (Allan) - Sunday, 19 February 2012, 23:46 GMT
Task Type Bug Report
Category System
Status Closed
Assigned To No-one
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
Pacman just gives information about the existing of one or more broken packages when a system upgrade is done by "pacman -Syu". But there is information about which package(s) are broken.

Additional info:
Pacman v4.0.2 - libalpm v7.0.2

German info shown by pacman:
(446/446) Überprüfe Paket-Integrität [##############################################] 100%
Fehler: Konnte den Vorgang nicht durchführen (Ungültiges oder beschädigtes Paket)
Fehler sind aufgetreten, keine Pakete wurden aktualisiert.

Steps to reproduce:
- Just start a full system upgrade using pacman
- You may modify a package on your own to see the message about broken packages
This task depends upon

Closed by  Allan McRae (Allan)
Sunday, 19 February 2012, 23:46 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#28014 
Comment by Karol Błażewicz (karol) - Sunday, 19 February 2012, 20:18 GMT
Run 'LC_ALL=C <command>' to get output in English.

It looks a bit like  FS#26764 .

Does 'pacman -Syu --debug' give more info?
Comment by new user (new-user) - Sunday, 19 February 2012, 22:07 GMT
Sry, I have already solved the problem by manually deleting the broken packages and redownloading via http. Therefore, I can't reproduce the error at the moment.
The debug-mode doesn't give more info, nope.
The problem is, that pacman doesn't give any information about the broken packages (e.g. which are broken), but that there are broken ones. You can just manually figure out, which are broken by looking in /var/cache/pacman/pkg after .part-files.

Loading...